Page 1 of 1

Can't Install LMDE on MacBook Air

Posted: Tue Nov 14, 2017 2:58 pm
by finjs
Hi, I'm trying to install LMDE 2 (MATE, 64-bit, dual boot) on a brand new MacBook Air, the very last 11" model, running under El Capitan. After booting LMDE on the live USB, Betsy can't see the SSD. She only sees herself. Gparted only sees the USB stick too. No sign of the MBA SSD at all, as though there wasn't any.
For the record, I installed rEFInd and launched the live USB from it. I also partitioned the SSD in El Cap to get it ready for a fast and clean LMDE install. Everything went without a hitch.
Any idea? The situation is quite puzzling indeed. Never been up against it before. Help would be appreciated.

PS: I've been a LMDE 1 user for years on a eeePC and never had any issue with it. Still works like a charm within 4 Gb.

Re: Can't Install LMDE on MacBook Air

Posted: Wed Nov 15, 2017 7:36 am
by finjs
More information to better focus on the issue.
I booted the live USB on a Mac Mini and LMDE saw the HD. Gparted displayed all its partitions. The Mac Mini runs under Mountain Lion.
The logical conclusion is that:
Either Apple added "something" in El Capitan 10.11.5 that prevents the LMDE live USB from seeing the SSD. I disabled the System Integrity Protection (SIP) since the beginning so it can't be it.
Or the LMDE live USB doesn't comply with rules set by El Capitan 10.11.5 (note: rEFIt doesn't work on El Capitan 10.11.5 any longer, only rEFInd does).
I got into the MBA EFI volume and couldn't find anything wrong there.
That finding made me change the title of the thread because the issue seems more serious than I thought.
Any other Mac users there?

Re: Can't Install LMDE on MacBook Air

Posted: Mon Nov 20, 2017 2:27 pm
by finjs
A last update on the issue.
I downloaded a Debian iso and copied the EFI folder found in the LMDE2 live USB to the Debian live USB. Debian finely booted and immediately found the MacBook Air SSD.
That experiment tends to show that there is something wrong with the making of lmde-2-201701-mate-64bit.iso and that that something has nothing to do with the EFI folder.
Hope it helps.