Unable to install LMDE 2 Cinnamon by using ISO-DVD

Questions about Grub, the liveCD and the installer
Forum rules
Before you post please read how to get help

LMDE 2 support ends on 1-1-2019
Post Reply
123xyz
Level 1
Level 1
Posts: 2
Joined: Sun Jul 15, 2018 4:04 pm

Unable to install LMDE 2 Cinnamon by using ISO-DVD

Post by 123xyz » Sun Jul 15, 2018 4:15 pm

I downloaded a *.ISO mirror of LMDE 2 Cinnamon 64 bit, proved the image, burnt it on dvd and the live version works well.

Then I wanted to install it on hdd, replacing my old linux mint 17 which was broken. I use it as a secondary partition behind debian, just for watching movies on vlc player and for internet streamings which require flash.

Anyway, I am not able to install. And the menu to do so is a new one, does not fit to the old one described in the handbook.

If I select my secondary partition as "/" to install lmde and click on to go further I get asked for /efi stuff which I never used before. I think I just have regular bios. Anyway, if I renew the partition and build a new one with 100 MB and declare it as /boot/efi, it doesn't help either.

So I tried the advanced mode. The problem there is it says in the end I need to mount the partition as "/target" but I nowhere found how to do so. Neither in the install menu, neither in the handbook or by searching the web.

Can someone help me how to avoid using /efi and how to mount /target...?

BrunoMiranda
Level 3
Level 3
Posts: 127
Joined: Thu Jun 24, 2010 2:22 pm

Re: Unable to install LMDE 2 Cinnamon by using ISO-DVD

Post by BrunoMiranda » Wed Jul 18, 2018 2:00 pm

For what I can recall from memory, LMDE2 does create a /target during installation. You might have to create one manually yourself. I remember having to do this manually myself, years ago (on LMDE1?).

During installation, while creating the partitions on the advanced partitioning, create a 8GB partition and format it with Ext4. Honestly I can't remember if you have an option to mount it as /target, but I gess not. You'll have to mount it manually. Pay attention to the partition you've created and take note if it is /dev/sda1, /dev/sdb2 or so. Then open a terminal and browse to /media:
cd /media

create a folder where to mount it, as root:
sudo mkdir /media/target

mount it as root:
sudo mount /dev/sdXy /media/target
(where sdXy is the partition you took note a while ago, where you created it)

You can exit that terminal by typing twice (the 1st exists out of root, and the 2nd one closes the terminal)
exit

After it, you can resume your install (you might have to reload your partitions - not sure if you have that chance during installation - but if you don't and install can't find your /target and you can't resume, abort your installation (but make sure /target is created and committed to the disk) and restart the installer again, going through the advanced partitioning again and leaving /target alone. Create all the other partitions you need (/, home, swap, etc.) and then I thing you'll be able to carry on.

After a successful installation you can use gparted as root to delete the /target partition and extend the free space to be used with some other partition you prefer.

Sorry not being able to be more technically accurate but I don't have a virtual machine installed where I could test this step by step, but I hope this may be of some help. Let me know how it goes.
Bye for now,
Bruno


(Always backup before you fvckup :mrgreen: )

123xyz
Level 1
Level 1
Posts: 2
Joined: Sun Jul 15, 2018 4:04 pm

Re: Unable to install LMDE 2 Cinnamon by using ISO-DVD

Post by 123xyz » Sun Aug 05, 2018 11:56 am

Thanks Bruno,

I tried but still couldn't go on with the installation.

I was able to make the directory and mount it as /target. But if I want to go on with expert install mode the system doesn't recognize it and says I have to mount the /target. If I try to go on with normal install mode it still asks me for an /boot/efi partition on a bootable disk. It doesn't help mounting a free partition as /boot/evi.

Post Reply

Return to “Installation & Boot”