[SOLVED] StrongSwan installation problems (network manager)

Questions about applications and software
Forum rules
Before you post please read how to get help

LMDE 2 support ends on 1-1-2019
Post Reply
Sydney
Level 2
Level 2
Posts: 80
Joined: Mon Oct 28, 2013 8:31 am

[SOLVED] StrongSwan installation problems (network manager)

Post by Sydney » Tue Oct 09, 2018 9:09 am

Sorry to even post this here, it might be way too complicated to try and solve this via this forum (as I am not experienced enough), but maybe someone has an easy solution:

LMDE 2 (Betsy) 64-bit MATE, trying to install StrongSwan. Unfortunately the repository does not offer the network manager (network-manager-strongswan).
Tried to install v. 1.4.4 from https://strongswan.org/download.html and got this:

sudo ./ltmain.sh
ltmain.sh: Version mismatch error. This is libtool 2.4.6 Debian-2.4.6-0.1, but the
ltmain.sh: definition of this LT_INIT comes from an older release.
ltmain.sh: You should recreate aclocal.m4 with macros from libtool 2.4.6 Debian-2.4.6-0.1
ltmain.sh: and run autoconf again.

I tried to find out how to recreate aclocal.m4 but various solutions I found online during a half-day odysee did not work (I ended up installing a string of programs, each of which required more installations, none of which functioned correctly).
https://wiki.strongswan.org/projects/st ... orkManager tells me that I might have to compile the network manager from scratch, which unfortunately is lightyears beyond my capabilities.

I then tried to install the 1.4.4.2 version from
https://packages.debian.org/buster/netw ... strongswan.
The package installer said "Error: Dependency is not satisfiable: libnm0 (>=1.1.90)".
I could not find libnm0 in the repository, so I tried downloading it from https://packages.debian.org/sid/amd64/libnm0/download
and the installer said "Error: Dependency is not satisfiable: libc6 (>= 2.25)".
I did in fact find libc6 in the repository, installed it and went back to the last step (trying to install libnm0), only to be informed that the libc6 was not the required version (2.19 instead of the required 2.2.5).
Hence I tried installing libc6 from
https://packages.debian.org/sid/amd64/libc6/download. The installer popped up just fine, however the "install package" button is not active (it remains transparent and I can't click it).

I'm at my wit's end. Any suggestions at all ? Thank you. And sorry about the awful timing. I understand that people are migrating to LMDE3 so everybody is likely busy enough already.
Last edited by Sydney on Tue Oct 09, 2018 12:42 pm, edited 1 time in total.

Monsta
Level 10
Level 10
Posts: 3013
Joined: Fri Aug 19, 2011 3:46 am

Re: StrongSwan installation problems

Post by Monsta » Tue Oct 09, 2018 9:50 am

It might be better to add jessie-backports repo and install the package from there.

Sydney
Level 2
Level 2
Posts: 80
Joined: Mon Oct 28, 2013 8:31 am

Re: [SOLVED] StrongSwan installation problems (network manager)

Post by Sydney » Tue Oct 09, 2018 12:43 pm

Thank you, Monsta, you deserve a medal!

Post Reply

Return to “Software & Applications”