Firefox ESR 52.9 last one on Jessie (LMDE 2)?

Questions about applications and software
Forum rules
Before you post please read how to get help

LMDE 2 support ends on 1-1-2019
Post Reply
Dr. Octagon
Level 2
Level 2
Posts: 57
Joined: Mon Sep 16, 2013 4:43 pm
Location: Osnabrooklyn

Firefox ESR 52.9 last one on Jessie (LMDE 2)?

Post by Dr. Octagon » Wed Oct 17, 2018 1:38 pm

Hello,

can anyone tell me if Jessie's (LMDE 2) Firefox ESR 52.9 will ever update to 60.x ESR? For example, I read about the package "RUST" that is needed but not right included in Jessie (or something like that), but no concrete answers as to whether Jessie can still get the next higher FF ESR version.

Btw. it's already long overdue... and I feel a little bit insecure now. ;)

Cu
Dr. Octagon
A good stumbler doesn't fall...

User avatar
xenopeek
Level 24
Level 24
Posts: 23121
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Firefox ESR 52.9 last one on Jessie (LMDE 2)?

Post by xenopeek » Wed Oct 17, 2018 2:35 pm

Something is broken on your end. LMDE 2 has Firefox ESR 60.2, see: http://packages.linuxmint.com/search.ph ... rd=firefox

You must have somehow locked yourself to Firefox ESR 52.9.

Suggest to start with you sharing the output of these two commands run from the terminal. You can select and copy text from the terminal through its edit menu.

inxi -Sr

apt policy firefox
Image

Dr. Octagon
Level 2
Level 2
Posts: 57
Joined: Mon Sep 16, 2013 4:43 pm
Location: Osnabrooklyn

Re: Firefox ESR 52.9 last one on Jessie (LMDE 2)?

Post by Dr. Octagon » Wed Oct 17, 2018 3:08 pm

My current state is 52.9.0esr-1~deb8u1 and under Versions (Synaptic) I can also see the version 60.2.2esr~linuxmint1+betsy, the one you specified.

I just wasn't sure why I see:
1. my installed Debian (52.x-deb8u1) version as the last default and
2. the 60.x linuxmint1+betsy one without any notice at all

In my doubt, I thought I'd stay with the Debian variant.

Output:
apt policy firefox
firefox:
Installed: (none) (WHY none? See below!)
Installationskandidat: 60.2.2esr~linuxmint1+betsy
Versionstabelle:
60.2.2esr~linuxmint1+betsy 0
700 http://ftp.fau.de/mint/packages/ betsy/upstream amd64 Packages

BUT:
apt policy firefox-esr
firefox-esr:
Installiert: 52.9.0esr-1~deb8u1
Installationskandidat: 52.9.0esr-1~deb8u1
Versionstabelle:
*** 52.9.0esr-1~deb8u1 0
500 http://security.debian.org/ jessie/updates/main amd64 Packages
100 /var/lib/dpkg/status
52.8.1esr-1~deb8u1 0
500 ftp://ftp.de.debian.org/debian/ jessie/main amd64 Packages

I get it: In the past I have to install FF-ESR especially, because LM just gave me the Betsy Firefox (without ESR) or the Debian FF-ESR Version as an Option, am I right?


Output:
inxi -Sr
Kernel: 3.16.0-7-amd64 x86_64 (64 bit)
Desktop: Cinnamon 3.4.6 Distro: LinuxMint 2 betsy
Repos: Active apt sources in file: /etc/apt/sources.list.d/additional-repositories.list
deb http://ftp.debian.org/debian jessie-backports main (for special purposes -like firejail- ... comment out doesn't help!)
Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb http://ftp.fau.de/mint/packages betsy main upstream import
deb ftp://ftp.de.debian.org/debian/ jessie main contrib non-free
deb ftp://ftp.de.debian.org/debian/ jessie-updates main contrib non-free
deb http://security.debian.org/ jessie/updates main contrib non-free
deb http://extra.linuxmint.com betsy main


Cu
Dr. Octagon
A good stumbler doesn't fall...

zorzi
Level 2
Level 2
Posts: 68
Joined: Thu Aug 04, 2016 4:26 pm

Re: Firefox ESR 52.9 last one on Jessie (LMDE 2)?

Post by zorzi » Wed Oct 17, 2018 5:41 pm

This is strange. Firefox ESR from debian repos is still in version 52.9...

https://packages.debian.org/fr/jessie/firefox-esr

Would that mean an update has replaced Firefox with its ESR version from betsy repositories ? What would be the purpose, considering LMDE support ends in three months ?
Desktop: HP Pavilion a6435 (Athlon64 2x 2,6Ghz, Radeon R7-240, Ram 4 Go, HD 500 Go) / MX Linux 17
Laptop: Packard-Bell EasyNote G1320 (Celeron 1,3 Ghz, ATI Mobility Radeon 9100 IGP, Ram 1,2 Go, HD 40 Go) / Debian Stretch

User avatar
xenopeek
Level 24
Level 24
Posts: 23121
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Firefox ESR 52.9 last one on Jessie (LMDE 2)?

Post by xenopeek » Thu Oct 18, 2018 3:47 am

You must have installed firefox-esr manually. As you've investigated, Debian jessie only has firefox-esr 52 package and LMDE 2 only has firefox 60 package (though it is also the ESR). If you want the newer Firefox, install the firefox package from LMDE 2.

Why Debian jessie is stuck with Firefox 52 I don't know. Debian stretch has Firefox 60 just like LMDE 2 and 3.
Image

Dr. Octagon
Level 2
Level 2
Posts: 57
Joined: Mon Sep 16, 2013 4:43 pm
Location: Osnabrooklyn

Re: Firefox ESR 52.9 last one on Jessie (LMDE 2)?

Post by Dr. Octagon » Sun Oct 21, 2018 2:16 pm

Thanks for your effort and time. From now on and until the end of the year I am right on the LMDE FF ESR repository path.

btw.
As far as I remember, I've chosen the Debian FF ESR branch since the beginning of LMDE 2, because the initial LMDE2 repostiory had only inserted the normal firefox (without ESR support) in it.
If I am wrong I have at least now taken the right path. ;)

Cu
Dr. Octagon
A good stumbler doesn't fall...

User avatar
xenopeek
Level 24
Level 24
Posts: 23121
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Firefox ESR 52.9 last one on Jessie (LMDE 2)?

Post by xenopeek » Sun Oct 21, 2018 2:22 pm

I can't remember :)
Image

Post Reply

Return to “Software & Applications”