[Solved]How to enable autologin with lightdm on LMDE2 Betsy?

Questions about applications and software
Forum rules
Before you post please read how to get help

LMDE 2 support ends on 1-1-2019
Post Reply
BrunoMiranda
Level 3
Level 3
Posts: 136
Joined: Thu Jun 24, 2010 2:22 pm

[Solved]How to enable autologin with lightdm on LMDE2 Betsy?

Post by BrunoMiranda » Thu Apr 23, 2015 1:05 pm

Hi all,

I'm trying to get lightdm to autologin on LMDE2, but i'm not being able to get it to work.

I've followed this procedure: (I know it's for Wheezy, not for Jesse on which LMDE2 is based)

http://siripong-computer-tips.blogspot. ... heezy.html

But it is not working.


Here's my /etc/lightdm/lightdm.conf: (with the commented lines removed for a clearer reading)


[LightDM]


[SeatDefaults]
autologin-user={bruno}
autologin-user-timeout=0
pam-service=lightdm-autologin


[XDMCPServer]


[VNCServer]



Does anyone know if I need to add anything to this or any other file?
Any help, please? Thanks! :wink:
Last edited by BrunoMiranda on Thu Apr 23, 2015 5:26 pm, edited 1 time in total.
Bye for now,
Bruno


(Always backup before you fvckup :mrgreen: )

zerozero
Level 16
Level 16
Posts: 6506
Joined: Tue Jul 07, 2009 2:29 pm

Re: How to enable autologin with lightdm on LMDE2 Betsy?

Post by zerozero » Thu Apr 23, 2015 3:13 pm

not

Code: Select all

autologin-user={bruno}
but

Code: Select all

autologin-user=bruno
https://wiki.archlinux.org/index.php/Li ... _autologin
Image

[ bliss of ignorance ]

User avatar
jimallyn
Level 18
Level 18
Posts: 8551
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: How to enable autologin with lightdm on LMDE2 Betsy?

Post by jimallyn » Thu Apr 23, 2015 3:25 pm

Just yesterday I had to fix autologin on a system running MX-14. I had installed with one user set to autologin, then wound up deleting that user and couldn't log anybody in. To fix it, all I had to do was change the old autologin user to the desired new autologin user. Just don't put the name in curly braces and it should work fine.

Edit: I see zerozero beat me to the punch. So I second his motion.
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan

BrunoMiranda
Level 3
Level 3
Posts: 136
Joined: Thu Jun 24, 2010 2:22 pm

[Solved] How to enable autologin with lightdm on LMDE2 Betsy

Post by BrunoMiranda » Thu Apr 23, 2015 5:25 pm

Yes, you were both right. It's working now! :mrgreen:

Caught by the curly braces... :lol:


One more rounded edge! :wink: Debian for the win :P

Thank you both so much, Zerozero and Jimallyn!
Bruno
Bye for now,
Bruno


(Always backup before you fvckup :mrgreen: )

Post Reply

Return to “Software & Applications”