Cannot install mysql-client because it depends on libdbi-perl and libdbd-mysql-perl which
both depend on EXACTLY perlapi-5.18.1 not >= perlapi-5.18.1 while I have perlapi-5.20.2 …
Replies from firstname.lastname@example.org:
that is correct and not a typo. Perl XS packages compiled against Perl
5.18 need to be recompiled to work with Perl 5.20. You need to either
upgrade libdbi-perl and libdbd-mysql-perl, or downgrade your Perl
Linux Mint is a derivative of Debian. While many things may behave same
as Debian, some don't - and it seems you have hit an issue with
something that is not identical to Debian.
We appreciate your getting in touch with us (all Debian users are
welcome, also "proxy users" of derivative distributions) - and we
especially appreciate your mentioning up front using a derivative so as
to quickly identify things that is likely better worked on somewhere
Please contact the developers og Linux Mint about this issue.