[SOLVED] Cannot install mysql-client

Questions about applications and software
Locked
Hansl
Level 3
Level 3
Posts: 103
Joined: Fri Dec 09, 2011 3:50 pm

[SOLVED] Cannot install mysql-client

Post by Hansl » Fri Nov 27, 2015 5:40 am

On a recently to LMDE2 Mate x64 upgraded system:
Cannot install mysql-client because it depends on libdbi-perl and libdbd-mysql-perl which
both depend on EXACTLY perlapi-5.18.1 not >= perlapi-5.18.1 while I have perlapi-5.20.2 …

Replies from pkg-perl-maintainers@lists.alioth.debian.org:
that is correct and not a typo. Perl XS packages compiled against Perl
5.18 need to be recompiled to work with Perl 5.20. You need to either
upgrade libdbi-perl and libdbd-mysql-perl, or downgrade your Perl
version.
Linux Mint is a derivative of Debian. While many things may behave same
as Debian, some don't - and it seems you have hit an issue with
something that is not identical to Debian.

We appreciate your getting in touch with us (all Debian users are
welcome, also "proxy users" of derivative distributions) - and we
especially appreciate your mentioning up front using a derivative so as
to quickly identify things that is likely better worked on somewhere
else.

Please contact the developers og Linux Mint about this issue.
Last edited by Hansl on Wed Dec 02, 2015 1:30 pm, edited 2 times in total.

kevinthefixer
Level 4
Level 4
Posts: 278
Joined: Thu Jul 23, 2015 10:36 pm

Re: Cannot install mysql-client

Post by kevinthefixer » Fri Nov 27, 2015 11:58 am

Hmmm. That is very likely why I cannot get Dolibarr to run on mine, also 64-bit LMDE2 Mate. Dolibarr is supposed to be a comprehensive business-management software using MySQL databases.

Hansl
Level 3
Level 3
Posts: 103
Joined: Fri Dec 09, 2011 3:50 pm

Re: Cannot install mysql-client

Post by Hansl » Wed Dec 02, 2015 1:27 pm

SOLVED: I had bungled the recent upgrade from LMDE to LMDE2 betsy… after correcting this, the Perl versions are consistent again and mysql-client installed fine. Sorry!

Locked

Return to “Software & Applications”