Betsy, apt-get update: signature invalid

Questions about applications and software
Locked
eriksank
Level 1
Level 1
Posts: 2
Joined: Thu Jun 06, 2013 3:30 am

Betsy, apt-get update: signature invalid

Post by eriksank » Wed Dec 30, 2015 12:50 am

I run the latest version of betsy (lmde2/mate):

$ lsb_release -a
No LSB modules are available.
Distributor ID: LinuxMint
Description: LMDE 2 Betsy
Release: 2
Codename: betsy


and I get this error message:

$ sudo apt-get update
...
W: GPG error: http://packages.linuxmint.com betsy Release: The following signatures were invalid: BADSIG 3EE67F3D0FF405B2 Clement Lefebvre (Linux Mint Package Repository v1) <root@linuxmint.com>


Apparently, there is something wrong with signatures produced by the following key:

$ apt-key list
/etc/apt/trusted.gpg
--------------------
pub 1024D/0FF405B2 2009-04-29
uid Clement Lefebvre (Linux Mint Package Repository v1) <root@linuxmint.com>
sub 2048g/0F346519 2009-04-29


This is the key that came out of the box with the installation. Should I download another public key instead?
Last edited by karlchen on Wed Dec 30, 2015 5:29 am, edited 1 time in total.
Reason: Moved thread to "LMDE 2" forum, because "betsy (lmde2/mate)" is not the Linux Mint Main Edition (Ubuntu based Mint 13 & Mint 17.x)

barko
Level 3
Level 3
Posts: 100
Joined: Mon Dec 27, 2010 10:44 am

Re: Betsy, apt-get update: signature invalid

Post by barko » Sun Jan 03, 2016 4:21 am

Try this:

Code: Select all

sudo apt-get clean
sudo rm -fr /var/lib/apt/lists/
sudo apt-get clean
sudo apt-get update
Regards!

Locked

Return to “Software & Applications”