Cannot restore after hibernation

Questions about applications and software
Forum rules
Before you post please read how to get help

LMDE 2 support ends on 1-1-2019
Post Reply
Level 1
Level 1
Posts: 21
Joined: Thu Mar 13, 2014 6:23 am

Cannot restore after hibernation

Post by topolinik » Tue Feb 16, 2016 8:04 am

With lmde2 my laptop cannot correctly restore the previous session after a hybernation.
The pc turns on and mint loads as well, the issue is, xorg is all black and it doesn't react at all. I try to blind login but it doesn't seem to be received, i try to switch to another console but the screen keeps on black. The only working solution is hitting ctrl+halt+del, which of course, makes the hybernation useless :(
What can be wrong with my PC?
My /home was imported from my previous lmde1 installation, may it be causing a configuration mess?

Level 2
Level 2
Posts: 81
Joined: Mon Jun 18, 2012 4:26 pm

Re: Cannot restore after hibernation

Post by titetanium » Tue Feb 16, 2016 9:06 pm


Do you have a "resume=/dev/swap partition*" line in your grub kernel line? Better yet, you can test by hitting "e" then insert "resume=/dev/swap partition*" into the kernel boot line followed by f10 to boot. Then try hibernating and then turn on laptop, it should resume from the swap for it to work.

*Replace swap partition with the partition name the swap is located on, "/dev/sda4" or "UUID=lettersandnumbers"

Level 1
Level 1
Posts: 30
Joined: Sun Nov 28, 2010 5:16 pm

Re: Cannot restore after hibernation Mint 18

Post by stevedonato » Wed Jun 07, 2017 11:32 am

This happened to me as well (all of a sudden) Never ever had to add any restore or swap info to Grub to have Hibernate recover properly. I'm running linux mint since rel. 12 never had to do anything to have hibernate to work. So unless someone can admit that an update broke hibernation from working correctly, it is a new latent BUG in Linux 18.

Why is this happening?
Sailor in Florida

Level 5
Level 5
Posts: 752
Joined: Tue Jun 10, 2014 1:12 pm

Re: Cannot restore after hibernation

Post by Penn » Wed Jun 07, 2017 1:03 pm

Suspend and hibernation have been a back and forth on LMDE2 for me too. At first it did the same as you describe. Then after a kernel update it worked exactly as it should. Then, it seems, an MDM update took it back to not working. I adjusted a line in an MDM file and it worked again. Then something happened that caused it to have the same resume problem only once in a while. Then it just stopped working all together.

Finally I decided to try a different kernel. I already had the backports repo so I just went to 4.9. Every thing works as it should now.

Apparently suspend and hibernate are actually very complex procedures and what works on one or most hardware configurations may not work on another. It is impossible to test all hardware combinations.

LMDE 2 is Jessie

Post Reply

Return to “Software & Applications”