LMDE 2 Pulseaudio Problem

Questions about applications and software
Forum rules
Before you post please read how to get help

LMDE 2 support ends on 1-1-2019
Post Reply
Mister.T
Level 2
Level 2
Posts: 91
Joined: Sat Mar 05, 2011 8:10 am

LMDE 2 Pulseaudio Problem

Post by Mister.T » Thu Jun 02, 2016 5:34 pm

I have a problem with my Pulseaudio volume settings in my LMDE2 Cinnamon. The volume at start up or login, defaults to 100%. I also have a Mint 17.3 version on the same machine, with no such issue. Is there an easy fix for the Debian based system?
LMDE2 and Mint 17.3
HP Pavilion 500-260ea
8Gb ram
AMD A10 6700 (3.7GHz) 4 core
Nvidia GTX 645

User avatar
Fred Barclay
Level 12
Level 12
Posts: 4158
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

Re: LMDE 2 Pulseaudio Problem

Post by Fred Barclay » Fri Jun 03, 2016 4:39 pm

I had a similar issue on LMDE 2 MATE. I'm still not sure what caused it (it started suddenly, and I'd had both a kernel upgrade and moved to MATE 1.14 shortly before).

I fixed it by right-clicking on the audio icon in my panel, choosing "Sound Preferences", and muting the "Output volume" control. (I may have slid the slider all the way down too.) I don't know if this will directly apply to you since you're using Cinnamon but it might be worth a shot. ;)

Cheers!
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

Mister.T
Level 2
Level 2
Posts: 91
Joined: Sat Mar 05, 2011 8:10 am

Re: LMDE 2 Pulseaudio Problem

Post by Mister.T » Wed Jun 08, 2016 5:03 am

Forgot to mention that I have this exact same issue on 2 separate machines. I can't be the only one?????
LMDE2 and Mint 17.3
HP Pavilion 500-260ea
8Gb ram
AMD A10 6700 (3.7GHz) 4 core
Nvidia GTX 645

Mister.T
Level 2
Level 2
Posts: 91
Joined: Sat Mar 05, 2011 8:10 am

Re: LMDE 2 Pulseaudio Problem

Post by Mister.T » Mon Jun 13, 2016 2:55 am

This is an important issue. Surely someone can shed light on it?????
LMDE2 and Mint 17.3
HP Pavilion 500-260ea
8Gb ram
AMD A10 6700 (3.7GHz) 4 core
Nvidia GTX 645

User avatar
Fred Barclay
Level 12
Level 12
Posts: 4158
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

Re: LMDE 2 Pulseaudio Problem

Post by Fred Barclay » Mon Jun 13, 2016 10:52 am

Did you try my suggestion? :)
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

Mister.T
Level 2
Level 2
Posts: 91
Joined: Sat Mar 05, 2011 8:10 am

Re: LMDE 2 Pulseaudio Problem

Post by Mister.T » Sat Jun 18, 2016 1:10 pm

Sorry to say it didn't work.
LMDE2 and Mint 17.3
HP Pavilion 500-260ea
8Gb ram
AMD A10 6700 (3.7GHz) 4 core
Nvidia GTX 645

User avatar
Flemur
Level 16
Level 16
Posts: 6287
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: LMDE 2 Pulseaudio Problem

Post by Flemur » Sat Jun 18, 2016 1:44 pm

http://askubuntu.com/questions/97936/te ... dio-volume

I use a script with "amixer" commands (for alsa) to set audio volumes/mutes correctly at login; at the above link they also mention "pactl" for pulseaudio.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

Mister.T
Level 2
Level 2
Posts: 91
Joined: Sat Mar 05, 2011 8:10 am

Re: LMDE 2 Pulseaudio Problem

Post by Mister.T » Thu Jun 30, 2016 10:13 am

Still no luck with this. Google is not my friend with this one I'm afraid :(
LMDE2 and Mint 17.3
HP Pavilion 500-260ea
8Gb ram
AMD A10 6700 (3.7GHz) 4 core
Nvidia GTX 645

rene
Level 8
Level 8
Posts: 2371
Joined: Sun Mar 27, 2016 6:58 pm

Re: LMDE 2 Pulseaudio Problem

Post by rene » Thu Jun 30, 2016 11:12 am

Not running LMDE but does it work for you to in a terminal run "alsamixer", possibly F6 to select proper card, set volumes to sensible defaults (with the main Pulseaudio volume at its default, which is 100% for me as well but where 100% is not max for me) and then save them with "sudo alsactl -E HOME=/var/run/alsa store"?

On Mint 17.x at boot volumes are restored by /etc/init/alsa-restore.conf which amounts to that same command with store replaced by restore. If things are set up differently on LMDE you will supposedly be able to mirror its restore script.

I know the question was phrased specifically mentioning Pulseaudio volume but am wondering if justly so; have never seen Pulseaudio not store/restore its private settings.

rene
Level 8
Level 8
Posts: 2371
Joined: Sun Mar 27, 2016 6:58 pm

Re: LMDE 2 Pulseaudio Problem

Post by rene » Thu Jun 30, 2016 11:25 am

Rereading I'm noticing the explicit "startup or login" whereby the above is no doubt rendered non-effective as well.

Pulseaudio seems to store volumes in ~/.config/pulse/<id>-device-volumes.tdb. Are ~/.config and ~/.config/pulse user-owned and writeable? And/or does resetting personal Pulseaudio settings simply with "rm -r ~/.config/pulse" solve things?

Mister.T
Level 2
Level 2
Posts: 91
Joined: Sat Mar 05, 2011 8:10 am

Re: LMDE 2 Pulseaudio Problem

Post by Mister.T » Sat Jul 02, 2016 7:59 am

I've tried changing all kinds of parameters in the config files, all to no end. I even compared every line with the corresponding Ubuntu base. There was only one line different and googling seemed to suggest that the Ubuntu base line was the incorrect one. I did try matching this anyway, all to no avail.

Anyway, after further Googling, I seem to have a workaround. Just installing "Pulseaudio Volume Control" seems for now to have cured the issue. I don't have to use it, but just having it installed seems to just make everything that should work, just work.
LMDE2 and Mint 17.3
HP Pavilion 500-260ea
8Gb ram
AMD A10 6700 (3.7GHz) 4 core
Nvidia GTX 645

Post Reply

Return to “Software & Applications”