Can't Install LibreOffice due to Dependency Problem

Questions about applications and software
Forum rules
Before you post please read how to get help

LMDE 2 support ends on 1-1-2019
Post Reply
User avatar
Gameranand
Level 1
Level 1
Posts: 17
Joined: Mon Feb 01, 2016 12:00 am

Can't Install LibreOffice due to Dependency Problem

Post by Gameranand » Sat Jul 02, 2016 2:49 pm

I ran

sudo apt-get update && sudo apt-get dist upgrade
and it basically removed my LibreOffice installation. Now when I try to install it again using

sudo apt-get install libreoffice
it gave me dependency problems. So I executed

sudo apt-get purge libreoffice*
then I tried to install but same problem. I am getting this error

gameranand@serenity ~ $ sudo apt-get -f install libreoffice
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libreoffice : Depends: libreoffice-base but it is not going to be installed
Depends: libreoffice-calc but it is not going to be installed
Depends: libreoffice-core (= 1:5.2.0~rc1-0ubuntu1~xenial1) but it is not going to be installed
Depends: libreoffice-draw but it is not going to be installed
Depends: libreoffice-impress but it is not going to be installed
Depends: libreoffice-math but it is not going to be installed
Depends: libreoffice-report-builder-bin but it is not going to be installed
Depends: libreoffice-writer but it is not going to be installed
Depends: libreoffice-avmedia-backend-gstreamer but it is not going to be installed
Depends: python3-uno (>= 4.4.0~beta2) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
How do I fix this. I really need the solution because I use Libreoffice on daily basis.
In War, Victory. In Peace Vigilance. In Death Sacrifice.

User avatar
jimallyn
Level 18
Level 18
Posts: 8551
Joined: Thu Jun 05, 2014 7:34 pm
Location: Wenatchee, WA USA

Re: Can't Install LibreOffice due to Dependency Problem

Post by jimallyn » Sat Jul 02, 2016 4:21 pm

Gameranand wrote:I ran

sudo apt-get update && sudo apt-get dist upgrade
And there's your problem. Mint does not recommend running apt-get dist upgrade. Now you know why. They recommend using the Update Manager they have provided. But stick around, perhaps one of the gurus here can give you some ideas on how to fix your system.
Image

“If the government were coming for your TVs and cars, then you'd be upset. But, as it is, they're only coming for your sons.” - Daniel Berrigan

Cosmo.
Level 23
Level 23
Posts: 17823
Joined: Sat Dec 06, 2014 7:34 am

Re: Can't Install LibreOffice due to Dependency Problem

Post by Cosmo. » Sat Jul 02, 2016 4:58 pm

As jimallyn said: You created your own problem.

Open synaptic and search for broken packages.

User avatar
Gameranand
Level 1
Level 1
Posts: 17
Joined: Mon Feb 01, 2016 12:00 am

Re: Can't Install LibreOffice due to Dependency Problem

Post by Gameranand » Sat Jul 02, 2016 10:39 pm

Yes I know that after searching a little. But now how do I fix it. I searched Synaptic packet manager for Broken packages but didn't find any at all.
In War, Victory. In Peace Vigilance. In Death Sacrifice.

User avatar
Fred Barclay
Level 12
Level 12
Posts: 4158
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

Re: Can't Install LibreOffice due to Dependency Problem

Post by Fred Barclay » Sun Jul 03, 2016 8:49 am

I believe there is something else going on here as well.
Depends: libreoffice-core (= 1:5.2.0~rc1-0ubuntu1~xenial1) but it is not going to be installed
You should not be dependent upon a Ubuntu package in Debian or LMDE, particularly a Ubuntu Xenial package.

Did you perhaps mix repos? What do your repos look like currently?

Code: Select all

inxi -r
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

User avatar
Gameranand
Level 1
Level 1
Posts: 17
Joined: Mon Feb 01, 2016 12:00 am

Re: Can't Install LibreOffice due to Dependency Problem

Post by Gameranand » Tue Jul 05, 2016 12:13 pm

Yes Repositories were mixed. Removed them and it solved the problem. However I wanted to use LibreOffice 5 so didn't installed and used external source to Download and install the software.
In War, Victory. In Peace Vigilance. In Death Sacrifice.

User avatar
Fred Barclay
Level 12
Level 12
Posts: 4158
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

Re: Can't Install LibreOffice due to Dependency Problem

Post by Fred Barclay » Tue Jul 05, 2016 1:21 pm

Let's make sure that no ubuntu packages are installed to your system.

What do

Code: Select all

apt-show-versions | grep ubuntu
apt-show-versions | grep xenial
say?

Additionally, did you know that libreoffice-5 is in jessie-backports? It's what I'm using without any problems, and is much safer than adding additional repos. :)
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

Post Reply

Return to “Software & Applications”