update packages fails

Questions about applications and software
Forum rules
Before you post please read how to get help

LMDE 2 support ends on 1-1-2019
Post Reply
jajamen
Level 1
Level 1
Posts: 1
Joined: Wed Aug 31, 2016 2:13 pm

update packages fails

Post by jajamen » Wed Aug 31, 2016 4:10 pm

Since it was long time ago when I updated packages it was time to do that again.

With following command to get a new updated package list:

sudo apt-get update

but it returns some errors and I suspect corrupt config files, so how can I restore the package list and update or do I have to reinstall everything?

Here's the output:

Code: Select all

Fel http://debian.linuxmint.com testing InRelease
  
Fel http://debian.linuxmint.com testing/updates InRelease                   
  
Fel http://debian.linuxmint.com testing InRelease                           
  
Fel http://debian.linuxmint.com testing Release.gpg                         
  Kunde inte ansluta till debian.linuxmint.com:http:
Fel http://debian.linuxmint.com testing/updates Release.gpg                 
  Kunde inte ansluta till debian.linuxmint.com:http:
Fel http://debian.linuxmint.com testing Release.gpg                         
  Kunde inte ansluta till debian.linuxmint.com:http:
Ign http://packages.linuxmint.com debian InRelease                          
Ign http://extra.linuxmint.com debian InRelease                             
Bra http://packages.linuxmint.com debian Release.gpg
Ign http://extra.linuxmint.com debian Release.gpg
Bra http://extra.linuxmint.com debian Release            
Bra http://packages.linuxmint.com debian Release         
Ign http://extra.linuxmint.com debian/main amd64 Packages/DiffIndex
Ign http://extra.linuxmint.com debian/main i386 Packages/DiffIndex
Bra http://packages.linuxmint.com debian/main amd64 Packages
Bra http://packages.linuxmint.com debian/upstream amd64 Packages
Bra http://packages.linuxmint.com debian/import amd64 Packages
Bra http://packages.linuxmint.com debian/main i386 Packages
Bra http://packages.linuxmint.com debian/upstream i386 Packages
Bra http://packages.linuxmint.com debian/import i386 Packages
Bra http://extra.linuxmint.com debian/main amd64 Packages                       
Bra http://extra.linuxmint.com debian/main i386 Packages
Ign http://extra.linuxmint.com debian/main Translation-sv_SE
Ign http://extra.linuxmint.com debian/main Translation-sv
Ign http://extra.linuxmint.com debian/main Translation-en
Ign http://packages.linuxmint.com debian/import Translation-sv_SE
Ign http://packages.linuxmint.com debian/import Translation-sv
Ign http://packages.linuxmint.com debian/import Translation-en
Ign http://packages.linuxmint.com debian/main Translation-sv_SE
Ign http://packages.linuxmint.com debian/main Translation-sv
Ign http://packages.linuxmint.com debian/main Translation-en
Ign http://packages.linuxmint.com debian/upstream Translation-sv_SE
Ign http://packages.linuxmint.com debian/upstream Translation-sv
Ign http://packages.linuxmint.com debian/upstream Translation-en
Läser paketlistor... Färdig
W: Misslyckades med att hämta http://debian.linuxmint.com/latest/dists/testing/InRelease  

W: Misslyckades med att hämta http://debian.linuxmint.com/latest/security/dists/testing/updates/InRelease  

W: Misslyckades med att hämta http://debian.linuxmint.com/latest/multimedia/dists/testing/InRelease  

W: Misslyckades med att hämta http://debian.linuxmint.com/latest/dists/testing/Release.gpg  Kunde inte ansluta till debian.linuxmint.com:http:

W: Misslyckades med att hämta http://debian.linuxmint.com/latest/security/dists/testing/updates/Release.gpg  Kunde inte ansluta till debian.linuxmint.com:http:

W: Misslyckades med att hämta http://debian.linuxmint.com/latest/multimedia/dists/testing/Release.gpg  Kunde inte ansluta till debian.linuxmint.com:http:

W: Some index files failed to download. They have been ignored, or old ones used instead.

Cardenio
Level 1
Level 1
Posts: 46
Joined: Wed Nov 26, 2014 12:11 pm

Re: update packages fails

Post by Cardenio » Wed Aug 31, 2016 6:52 pm

I'll take a jab at answering this since nobody else has.

1st. You are missing the 2nd update command which is "sudo apt-get upgrade" or if you want to do everything in one shot: "sudo apt-get update && sudo apt-get upgrade". I would go ahead and install all the updates it offers then run the update/upgrade commands again.

2nd. Open the Software Sources App, and mess around with it until it has straightened everything out. Then run the update/upgrade commands again.

Sometimes the update mirrors are behind or down, if this is the case errors like yours will be generated, but disappear the next day. I don't think this is the case though, since you say you haven't updated in a long time.

Monsta
Level 10
Level 10
Posts: 3013
Joined: Fri Aug 19, 2011 3:46 am

Re: update packages fails

Post by Monsta » Thu Sep 01, 2016 1:13 am


User avatar
Fred Barclay
Level 12
Level 12
Posts: 4156
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

Re: update packages fails

Post by Fred Barclay » Thu Sep 01, 2016 3:59 pm

As Monsta pointed out, you're using LMDE 1, which has been obsolete since January 2016. While there is an upgrade path from LMDE 1 to LMDE 2, it's been so long now since LMDE 2 has been released that it's probably best for you to do a fresh install of LMDE 2.

In addition, you haven't been receiving any security updates since January, so I would really recommend a fresh install, in case you've picked up any nasties on your current system.
Cheers!
Fred
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

Post Reply

Return to “Software & Applications”