<CLOSED>MATE 1.16 Gtk-Error metathread

Questions about applications and software
Forum rules
Before you post please read how to get help
User avatar
Fred Barclay
Level 11
Level 11
Posts: 3815
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

<CLOSED>MATE 1.16 Gtk-Error metathread

Postby Fred Barclay » Fri Nov 18, 2016 2:50 pm

Several of us seem to be having problems with the newest MATE 1.16, so I'm collecting info on exactly which programmes are no longer functioning. If you see something I missed please add it below! :)

The pattern is this:

Code: Select all

(<program>:<PID>): Gtk-ERROR **: GTK+ 2.x symbols detected. Using GTK+ 2.x and GTK+ 3 in the same process is not supported
Trace/breakpoint trap


Programmes:
  • mate-network-admin
  • mate-network-admin-pkexec
  • mate-services-admin
  • mate-services-admin-pkexec
  • mate-shares-admin
  • mate-shares-admin-pkexec
  • mate-time-admin
  • mate-time-admin-pkexec
  • mate-users-admin
Last edited by Fred Barclay on Fri Nov 25, 2016 2:12 pm, edited 1 time in total.
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

ciaobello
Level 1
Level 1
Posts: 7
Joined: Tue May 26, 2015 7:38 pm

Re: MATE 1.16 Gtk-Error metathread

Postby ciaobello » Thu Nov 24, 2016 9:06 am

A workaround how to use the service, time and user-admin anyway, can be found here:
viewtopic.php?f=238&t=233814#p1243070

User avatar
Fred Barclay
Level 11
Level 11
Posts: 3815
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

Re: <CLOSED>MATE 1.16 Gtk-Error metathread

Postby Fred Barclay » Fri Nov 25, 2016 2:14 pm

ciabello: you hit the nail on the head! I pinged Clem on hexchat and he pointed out that these programmes are all part of the mate-system-tools package, which were discontinued in MATE 1.10. The replacement is gnome-system-tools.
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

kevinthefixer
Level 4
Level 4
Posts: 231
Joined: Thu Jul 23, 2015 10:36 pm

Re: <CLOSED>MATE 1.16 Gtk-Error metathread

Postby kevinthefixer » Fri Nov 25, 2016 9:52 pm

Fred--and Moderators--Perhaps this tidbit of info might be deemed important enough to rate a sticky?

User avatar
shabah
Level 1
Level 1
Posts: 7
Joined: Thu Jan 05, 2017 10:34 pm
Location: The Bay of All Waters

Re: <CLOSED>MATE 1.16 Gtk-Error metathread

Postby shabah » Sun Jan 08, 2017 3:48 am

Hi all,

I faced the same issue when had to handled with user & group configs recently.

I found answers and workaround that fixed it, inside Arch forums. But unfortunately I did not bookmarked the page. It seemed to be a known issue related to GUI composition with Gtk2/Gtk3 at that time. [...]

I just reinstalled GTK2 and GTK3 and my problem has gone. But after some time without dealing with users&groups, I faced the same problem again. What says that workaround was ephemeral.

The gnome-system-tool workaround now seems a fair solution thou...
Salutes to all!!
Namaste!

Image

>>Presentation<<


Return to “Software & Applications”

Who is online

Users browsing this forum: No registered users and 1 guest