[SOLVED] mdmwebkit error

Questions about applications and software
Forum rules
Before you post please read how to get help
Andy-A
Level 2
Level 2
Posts: 57
Joined: Tue May 19, 2015 9:09 am

[SOLVED] mdmwebkit error

Postby Andy-A » Tue Nov 22, 2016 8:23 am

My log files are being spammed with the following sorts of error message:

Code: Select all

Nov 22 12:05:00 laptop mdmwebkit[10632]: CRITICAL: void webkit_web_view_execute_script(WebKitWebView*, const gchar*): assertion 'WEBKIT_IS_WEB_VIEW(webView)' failed
Nov 22 11:53:00 lmde-2 mdmwebkit[25074]: CRITICAL: void webkit_web_view_execute_script(WebKitWebView*, const gchar*): assertion 'WEBKIT_IS_WEB_VIEW(webView)' failed


I've only noticed it since the update to mint-mdm-themes-html yesterday. MDM login screens are also very slow.
Its happening on both PC and laptop (spec for laptop is:

Code: Select all

andy@laptop ~ $ inxi -Fx
System:    Host: laptop Kernel: 3.16.0-4-amd64 x86_64 (64 bit gcc: 4.8.4)
           Desktop: MATE 1.16.1 (Gtk 3.14.5+4) Distro: LinuxMint 2 betsy
Machine:   System: Hewlett-Packard product: Presario CQ56 Notebook PC v: 0595100000242810010020100
           Mobo: Hewlett-Packard model: 1604 v: 88.05
           Bios: Hewlett-Packard v: F.03 date: 08/04/2010
CPU:       Single core AMD V140 (-UP-) cache: 512 KB
           flags: (lm nx sse sse2 sse3 sse4a svm) bmips: 4588 clocked at 2300 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS880M [Mobility Radeon HD 4225/4250]
           bus-ID: 01:05.0
           Display Server: X.Org 1.16.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           Resolution: 1366x768@59.64hz
           GLX Renderer: Gallium 0.4 on AMD RS880
           GLX Version: 3.0 Mesa 10.3.2 Direct Rendering: Yes
Audio:     Card Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA)
           driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture v: k3.16.0-4-amd64
Network:   Card-1: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 03:00.0
           IF: eth0 state: down mac: 60:eb:69:35:4e:ff
           Card-2: Broadcom BCM4313 802.11bgn Wireless Network Adapter
           driver: wl bus-ID: 02:00.0
           IF: wlan0 state: up mac: 00:26:82:8f:c6:7f
Drives:    HDD Total Size: 320.1GB (7.4% used)
           ID-1: /dev/sda model: Hitachi_HTS54503 size: 320.1GB
Partition: ID-1: / size: 14G used: 5.9G (47%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 275G used: 11G (5%) fs: ext4 dev: /dev/sda2
           ID-3: swap-1 size: 6.03GB used: 0.04GB (1%) fs: swap dev: /dev/sda3
Sensors:   System Temperatures: cpu: 55.1C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 203 Uptime: 5 days Memory: 1028.3/2761.4MB
           Init: systemd runlevel: 5 Gcc sys: 4.9.2
           Client: Shell (bash 4.3.301) inxi: 2.1.28
Last edited by Andy-A on Tue Nov 22, 2016 11:45 am, edited 1 time in total.
LMDE2-64, MATE 1.18, on a 10 year old PC

Andy-A
Level 2
Level 2
Posts: 57
Joined: Tue May 19, 2015 9:09 am

Re: mdmwebkit error

Postby Andy-A » Tue Nov 22, 2016 8:37 am

When I change the login window preference, I get these errors, then the mdmwebkit errors start (at a rate of 9 per minute):

Code: Select all

Nov 22 12:31:23 lmde-2 mdmsetup[30290]: Gtk-CRITICAL: IA__gtk_label_get_label: assertion 'GTK_IS_LABEL (label)' failed
Nov 22 12:31:23 lmde-2 mdmsetup[30290]: Gtk-CRITICAL: IA__gtk_label_set_use_markup: assertion 'GTK_IS_LABEL (label)' failed
Nov 22 12:31:23 lmde-2 mdmsetup[30290]: Gtk-CRITICAL: IA__gtk_label_set_label: assertion 'GTK_IS_LABEL (label)' failed
Nov 22 12:31:23 lmde-2 mdmsetup[30290]: Gtk-CRITICAL: IA__gtk_label_get_label: assertion 'GTK_IS_LABEL (label)' failed
Nov 22 12:31:23 lmde-2 mdmsetup[30290]: Gtk-CRITICAL: IA__gtk_label_set_use_markup: assertion 'GTK_IS_LABEL (label)' failed
Nov 22 12:31:23 lmde-2 mdmsetup[30290]: Gtk-CRITICAL: IA__gtk_label_set_label: assertion 'GTK_IS_LABEL (label)' failed
Nov 22 12:31:41 lmde-2 mdmsetup[30290]: Gtk-WARNING: Attempting to store changes into `/root/.local/share/recently-used.xbel', but failed: Failed to create file '/root/.local/share/recently-used.xbel.5GG8QY': No such file or directory
Nov 22 12:31:41 lmde-2 mdmsetup[30290]: Gtk-WARNING: Attempting to set the permissions of `/root/.local/share/recently-used.xbel', but failed: No such file or directory
Nov 22 12:31:41 lmde-2 console-kit-daemon[1135]: GLib-CRITICAL: Source ID 279 was not found when attempting to remove it


Seems to be the same if I choose an HTML or a GDM theme.
Has anyone else found this?
LMDE2-64, MATE 1.18, on a 10 year old PC

Andy-A
Level 2
Level 2
Posts: 57
Joined: Tue May 19, 2015 9:09 am

Re: mdmwebkit error

Postby Andy-A » Tue Nov 22, 2016 11:41 am

Rebooting has stopped the mdm-related errors.
LMDE2-64, MATE 1.18, on a 10 year old PC


Return to “Software & Applications”

Who is online

Users browsing this forum: No registered users and 2 guests