Firefox as default browser

Questions about applications and software
Forum rules
Before you post please read how to get help
Andy-A
Level 2
Level 2
Posts: 57
Joined: Tue May 19, 2015 9:09 am

Firefox as default browser

Postby Andy-A » Thu Dec 08, 2016 6:48 pm

If I open Control panel -> Preferred applications

Firefox is not listed as one of the Web browsers (I also have Palemoon and Vivaldi installed, which are both available in the drop-down list):
Preferred_apps.jpg

Firefox is installed, and works, and I mostly use it, but Mint has decided that Palemoon is my default browser and that sometimes opens when I don't want it to.
Both Firefox and Palemoon say they are the default browser in their Preferences. Is there some way I can get Firefox back in the drop-down list?
LMDE2-64, MATE 1.18, on a 10 year old PC

User avatar
bartszu
Level 4
Level 4
Posts: 288
Joined: Thu Aug 28, 2014 7:39 pm
Location: Eire

Re: Firefox as default browser

Postby bartszu » Thu Dec 08, 2016 9:16 pm

run it as it is:

sudo update-alternatives --config x-www-browser

Andy-A
Level 2
Level 2
Posts: 57
Joined: Tue May 19, 2015 9:09 am

Re: Firefox as default browser

Postby Andy-A » Fri Dec 09, 2016 5:30 am

Same problem - no Firefox listed by update-alternatives. It only gives me a choice of Palemoon or Vivaldi.

I also have a laptop with LMDE2 MATE, which only has Firefox and Vivaldi browsers installed, and update-alternatives says:
"There is only one alternative in link group x-www-browser (providing /usr/bin/x-www-browser): /usr/bin/vivaldi-stable
Nothing to configure."

Why is it not finding Firefox?
LMDE2-64, MATE 1.18, on a 10 year old PC

User avatar
Moem
Level 10
Level 10
Posts: 3406
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: Firefox as default browser

Postby Moem » Fri Dec 09, 2016 6:56 am

Have you tried setting Firefox as default browser from inside Firefox itself, in the preferences?
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

User avatar
bartszu
Level 4
Level 4
Posts: 288
Joined: Thu Aug 28, 2014 7:39 pm
Location: Eire

Re: Firefox as default browser

Postby bartszu » Fri Dec 09, 2016 1:18 pm

Andy-A wrote:Why is it not finding Firefox?


Did you install FF from software sources ?

User avatar
Fred Barclay
Level 11
Level 11
Posts: 3928
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

Re: Firefox as default browser

Postby Fred Barclay » Fri Dec 09, 2016 1:51 pm

What does

Code: Select all

which firefox
whereis firefox
say?
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

Andy-A
Level 2
Level 2
Posts: 57
Joined: Tue May 19, 2015 9:09 am

Re: Firefox as default browser

Postby Andy-A » Fri Dec 09, 2016 5:16 pm

@moem Firefox, Palemoon and vivaldi all said they were the default browser in the preferences! I managed to get Palemoon to stop being default.

@bartszu installation of Firefox was from software sources.

Code: Select all

andy@lmde-2 ~ $ which firefox
/usr/bin/firefox
andy@lmde-2 ~ $ whereis firefox
firefox: /usr/bin/firefox /usr/share/firefox
andy@lmde-2 ~ $


I have removed Palemoon and vivaldi, so no problem with wrong browser starting, but still an empty box shown in the Preferred applications as in my original post.

I launch FF with a custom launcher (using firejail) but the original launchers are still there, but that should not affect this issue.
LMDE2-64, MATE 1.18, on a 10 year old PC

User avatar
bartszu
Level 4
Level 4
Posts: 288
Joined: Thu Aug 28, 2014 7:39 pm
Location: Eire

Re: Firefox as default browser

Postby bartszu » Fri Dec 09, 2016 8:39 pm

Andy-A wrote:I have removed Palemoon and vivaldi, so no problem with wrong browser starting, but still an empty box shown in the Preferred applications as in my original post.


So you have workaround ;)

User avatar
bartszu
Level 4
Level 4
Posts: 288
Joined: Thu Aug 28, 2014 7:39 pm
Location: Eire

Re: Firefox as default browser

Postby bartszu » Fri Dec 09, 2016 8:44 pm

Well I don’t know but if you really want to mess around it more, you could.

sudo apt-get purge firefox

log in/out

sudo apt-get install firefox
sudo update-alternatives --config x-www-browser

Andy-A
Level 2
Level 2
Posts: 57
Joined: Tue May 19, 2015 9:09 am

Re: Firefox as default browser

Postby Andy-A » Sat Dec 10, 2016 10:53 am

I tried sudo apt-get purge firefox but it wants to install replacements (this was done with the -s flag):

Code: Select all

The following packages will be REMOVED:
  firefox*
The following NEW packages will be installed:
  firefox-esr iceweasel
0 upgraded, 2 newly installed, 1 to remove and 0 not upgraded.


which I don't want. Is this because I have no other browsers installed?
LMDE2-64, MATE 1.18, on a 10 year old PC

User avatar
Fred Barclay
Level 11
Level 11
Posts: 3928
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

Re: Firefox as default browser

Postby Fred Barclay » Sat Dec 10, 2016 5:11 pm

Try using sudo dpkg -P firefox instead.

Also, what do these say?

Code: Select all

apt policy firefox
apt policy iceweasel
apt policy firefox-esr
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

Andy-A
Level 2
Level 2
Posts: 57
Joined: Tue May 19, 2015 9:09 am

Re: Firefox as default browser

Postby Andy-A » Sat Dec 10, 2016 7:52 pm

Well that dpkg command helped me find the culprit - it was flashplayer-mozilla that depends on iceweasel or a www-browser - removed that and firefox can be removed. However, after reinstalling firefox:

Code: Select all

update-alternatives: error: no alternatives for x-www-browser


I have also now lost Thunderbird from the Mail reader picklist and vlc from the Video player picklist in 'Preferred applications' (both apps still installed and working).

I think I'm going to stop this before I lose something important, at the moment everything is still working fine apart from the strange behaviour of the 'Preferred applications' screen. Thanks for all your suggestions everyone.
LMDE2-64, MATE 1.18, on a 10 year old PC

User avatar
bartszu
Level 4
Level 4
Posts: 288
Joined: Thu Aug 28, 2014 7:39 pm
Location: Eire

Re: Firefox as default browser

Postby bartszu » Sat Dec 10, 2016 11:39 pm

Well your system is really Debian.
And sure Debian is main line of Linux, but is the bottom of the chain.
Dispute over Iceweasel is a good example what Debian really is.
Loads of libs and system components don’t exist there.
I have tons of things, files and system components on my Mint you don’t have on your Debian.
Not mentioning age or version of those packages.

Maybe you missing some dependencies to for example update-alternatives, that allow it to see Firefox.
Or maybe, you missing some other dependencies allowing you to make it default.

Look this is mine whereis firefox output:

Code: Select all

 firefox:
 /usr/bin/firefox
 /etc/firefox
 /usr/lib/firefox
 /usr/bin/X11/firefox
 /usr/share/firefox
 /usr/share/man/man1/firefox.1.gz


Looks very different that yours, isn’t it ??
This is really Debian forum question, coz your Firefox as far as your system is concerned, is not installed simply.

Monsta
Level 9
Level 9
Posts: 2987
Joined: Fri Aug 19, 2011 3:46 am

Re: Firefox as default browser

Postby Monsta » Mon Mar 20, 2017 10:04 am

Andy-A wrote:I launch FF with a custom launcher (using firejail) but the original launchers are still there, but that should not affect this issue.

Unfortunately, it does. We have a bug there... launchers from ~/.local/share/applications aren't recognized by the Preferred Applications tool (see here and here).


Return to “Software & Applications”

Who is online

Users browsing this forum: No registered users and 2 guests