cannot install WINE, PPA issue

Questions about applications and software
Forum rules
Before you post please read how to get help
w_houle
Level 1
Level 1
Posts: 27
Joined: Sun Nov 20, 2016 2:04 pm

cannot install WINE, PPA issue

Postby w_houle » Fri Jan 06, 2017 9:54 pm

Tried to install WINE from https://wiki.winehq.org/Ubuntu here
and when I went to install it, got this
william@williamlaptop ~ $ sudo dpkg --add-architecture i386
[sudo] password for william:
william@williamlaptop ~ $ sudo add-apt-repository ppa:wine/wine-builds
Adding PPAs is not supported
william@williamlaptop ~
cannot get past this point,what do I do

User avatar
MintBean
Level 7
Level 7
Posts: 1657
Joined: Fri Aug 07, 2015 6:54 am
Location: Blighty

Re: cannot install WINE, PPA issue

Postby MintBean » Fri Jan 06, 2017 10:36 pm

Are you running Debian Edition (LMDE)?

User avatar
Pierre
Level 15
Level 15
Posts: 5551
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: cannot install WINE, PPA issue

Postby Pierre » Fri Jan 06, 2017 10:59 pm

if you use the inbuilt Software Manager:
- Menu - software manager:
then under the Featured icon - wine is the 6th item in that list

can you install that ./wine version ?.
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

User avatar
hinto
Level 8
Level 8
Posts: 2165
Joined: Thu Jul 09, 2009 7:32 pm
Location: Cary NC, USA

Re: cannot install WINE, PPA issue

Postby hinto » Fri Jan 06, 2017 11:14 pm

I use PlayOnLinux to manage my wine installations. It's much easier. You can do multiple versions as well as 32/64 bit (on a 64 bit machine)
-H
"In God we trust, all others bring data."- W. Edwards Deming

w_houle
Level 1
Level 1
Posts: 27
Joined: Sun Nov 20, 2016 2:04 pm

Re: cannot install WINE, PPA issue

Postby w_houle » Sat Jan 07, 2017 12:29 pm

Host: williamlaptop Kernel: 3.16.0-4-amd64 x86_64 (64 bit gcc: 4.8.4)
Desktop: Cinnamon 3.2.7 (Gtk 3.14.5+4) Distro: LinuxMint 2 betsy
Not sure the exact distro, but thought the answer might be here
went and did the software manager version
william@williamlaptop ~ $ wine --version
wine-1.6.2
but the reason I took it off in the first place was it didn't work, doesn't work, and the winehq page said to not have other versions of wine on the machine when installing
play on linux doesn't open my .exe files either
Message: PlayOnLinux (4.2.5)
this is what I get from POL
Error in POL_Wine
Wine seems to have crashed

If your program is running, just ignore this message
Last edited by w_houle on Sat Jan 07, 2017 3:43 pm, edited 1 time in total.

w_houle
Level 1
Level 1
Posts: 27
Joined: Sun Nov 20, 2016 2:04 pm

Re: cannot install WINE, PPA issue

Postby w_houle » Sat Jan 07, 2017 1:57 pm

Not sure what this is telling me, but
william@williamlaptop ~ $ winecfg
fixme:service:scmdatabase_autostart_services Auto-start service L"MountMgr" failed to start: 2
err:winecfg:open_mountmgr failed to open mount manager err 2
fixme:ole:RemUnknown_QueryInterface No interface for iid {00000019-0000-0000-c000-000000000046}
fixme:msg:pack_message msg 14 (WM_ERASEBKGND) not supported yet
err:winecfg:open_mountmgr failed to open mount manager err 2

I still cannot figure out how to make this work

User avatar
Moem
Level 10
Level 10
Posts: 3056
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: cannot install WINE, PPA issue

Postby Moem » Sat Jan 07, 2017 7:01 pm

Mod note:
Moved post to the LMDE forum section because you're apparently running LMDE.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

kevinthefixer
Level 4
Level 4
Posts: 236
Joined: Thu Jul 23, 2015 10:36 pm

Re: cannot install WINE, PPA issue

Postby kevinthefixer » Sat Jan 07, 2017 9:35 pm

Are you trying to open 32-bit .exe files? If so you will need wine32, the standard wine is for 64-bit. You can have both installed on the same system, but you need to make sure the correct one opens when you click a Windows file.

Don't try to add PPAs to your sources, if you are running Betsy you have LMDE2 which will break with PPAs.

ron_h
Level 4
Level 4
Posts: 264
Joined: Tue Apr 15, 2014 7:03 am
Location: Sydney, NSW, AU

Re: cannot install WINE, PPA issue

Postby ron_h » Mon Jan 09, 2017 1:24 am

LMDE2 Cinnamon 64bit installed from the iso on a USB stick

I am using PlayOnLinux (1.6.2-20) as a front end to Wine (4.2.5-1), using Synaptic Package Manager. I selected to set up a 32bit Windows environment and that seems to be OK. But the program I want to install, fails to install in PlayOnLinux.

As far as I can see in the Synaptic Package Manager list of packages on a vanilla LMDE2 installation, there is no Wine32 package to install. How and where do I get Wine32 ?

BTW the program I want to install is Lotus WordPro (part of Lotus SmartSuite 9.5) so I can read some old .lwp files (LibreOffice Writer doesn't handle them). In my old LMDE (that is, LMDE 1 Cinnamon 64bit) system with PlayOnLinux 4.2.1-1 and Wine 1.4.1-4 I installed Lotus WordPro (and some other apps from SmartSuite) just fine. If someone has installed Lotus WordPro using PlayOnLinux/Wine on LMDE2, hints on how they did it would be welcome.

UPDATE after some messing around, based on other posts in these forums, but still no success, I used PlayOnLinux to install Wine 1.4.1 and then did the install of Lotus WordPro using PlayOnLinux plus Wine 1.4.1. No problems. I also installed Lotus 123, Lotus Freelance and Lotus Notes Client version 5.04 also using Wine 1.4.1.

Ron

User avatar
Fred Barclay
Level 11
Level 11
Posts: 3890
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

Re: cannot install WINE, PPA issue

Postby Fred Barclay » Mon Jan 09, 2017 3:41 pm

kevinthefixer wrote:Don't try to add PPAs to your sources, if you are running Betsy you have LMDE2 which will break with PPAs.

This.

Betsy/LMDE 2 is not compatible with PPAs and should try to make it somewhat difficult for you to add them. :) If you circumvent that protection you run the risk of something breaking eventually.
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

kevinthefixer
Level 4
Level 4
Posts: 236
Joined: Thu Jul 23, 2015 10:36 pm

Re: cannot install WINE, PPA issue

Postby kevinthefixer » Tue Jan 10, 2017 11:32 am

Ron, glad to hear it worked. Wine32 is in the software manager, though. I needed it to run an old audio editor I like, Cool Edit 2000.


Return to “Software & Applications”

Who is online

Users browsing this forum: No registered users and 1 guest