[SOLVED] Jessie-backports not automatically prompting to update

Questions about applications and software
Forum rules
Before you post please read how to get help
dg1727
Level 1
Level 1
Posts: 24
Joined: Mon Sep 22, 2014 4:08 pm

[SOLVED] Jessie-backports not automatically prompting to update

Postby dg1727 » Thu Feb 09, 2017 11:42 am

LMDE2 Cinnamon 64-bit, very recent install (the Jan. 2017 beta installer). I'd like to have the jessie-backports version of the kernel, as well as any other packages that already exist on this computer & can be upgraded without breaking anything.

The kernel packagename is linux-image-amd64. This is a virtual package that depends on a kernel package whose name includes the version number.

The kernel version in LMDE is 3.16.something and in jessie-backports is 4.9.something.

Per viewtopic.php?f=238&t=216678&p=1270719#p1270719
First I added /etc/apt/sources.list.d/custom.list with one line for jessie-backports as suggested in that forum posting.

I intentionally omitted the APT pinning because I think the version numbers in jessie-backports should typically [*] be higher than in the default LMDE repositories, so (unless the jessie-backports version of a specific package is found to break something) I think APT should (with the added sources.list.d line) default to the jessie-backports version without needing pinning.

*Furthermore, software (Cinnamon etc.) that's being developed by the Linux Mint project is expected to be at a higher version in the LMDE repos than in jessie-backports, so pinning to jessie-backports would result in an older version of those packages.

Then I clicked "Reload" in Synaptic (the equivalent of "apt-get update"). Almost all packages were then shown with a "Not installed (new in repository)" icon (a star icon). The linux-image-xyz-amd64 packages with 4.x version numbers in their names were now listed in Synaptic. But there were a couple of issues:

  • Nothing (no Update Manager type of GUI) prompted me to install any jessie-backports packages.
  • Synaptic still shows "Latest Version" of linux-image-amd64 as 3.16.x rather than 4.x.

In Synaptic, if I right-click linux-image-amd64 > Properties > Versions tab, the jessie-backports version 4.x is listed, and is shown above the LMDE default repo's version 3.x.

I then added the /etc/apt/preferences.d/custom.pref APT-pinning paragraph for jessie-backports as given in the forum posting. Once I clicked Synaptic's Reload button, the star icons went away, but the 2 mentioned issues (bulleted list above) remained. I then rebooted and opened Synaptic again, with no change.

In Synaptic's Settings > Preferences > Distribution tab, "Package upgrade behavior" has (throughout the scenario described here) been set to "Always prefer the highest version." As stated near the beginning of this posting, the wording of that option is what I'd like APT to do on this machine. But APT doesn't seem to be doing that.

I don't think I should have to "apt-get install" on a per-package basis as in the 4th code quotation in the referenced forum posting.

Comments will be much appreciated. If this situation warrants a bug report, I'll be happy to copy-and-paste into the appropriate bugtracker.
Last edited by dg1727 on Thu Feb 09, 2017 2:49 pm, edited 1 time in total.
--dg1727

User avatar
xenopeek
Level 24
Level 24
Posts: 20376
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Jessie-backports not automatically prompting to update

Postby xenopeek » Thu Feb 09, 2017 12:53 pm

It is highly discouraged to do as you want:
Backports cannot be tested as extensively as Debian stable, and backports are provided on an as-is basis, with risk of incompatibilities with other components in Debian stable. Use with care!

It is therefore recommended to only select single backported packages that fit your needs, and not use all available backports.

If you do want to go ahead and gamble with your system and security (there are no security updates for backports packages) you would likely have to set the apt pinning priority. As per the apt_preferences manpage:
P > 1000
causes a version to be installed even if this constitutes a downgrade of the package.

990 < P <=1000
causes a version to be installed even if it does not come from the target release, unless the installed version is more recent.

500 < P <=990
causes a version to be installed unless there is a version available belonging to the target release or the installed version is more recent.

100 < P <=500
causes a version to be installed unless there is a version available belonging to some other distribution or the installed version is more recent.

0 < P <=100
causes a version to be installed only if there is no installed version of the package.

P < 0
prevents the version from being installed.

The backports repository is automatically set to priority 100 unless overridden. You should prefer it at lower than 500.
Image

dg1727
Level 1
Level 1
Posts: 24
Joined: Mon Sep 22, 2014 4:08 pm

[SOLVED] Jessie-backports not automatically prompting to update

Postby dg1727 » Thu Feb 09, 2017 2:49 pm

Thanks for your reply. I changed the Pin-Priority in the .pref file from 400 to 500; now the jessie-backports packages are automatically prompted to me by the Linux Mint update manager and by Synaptic (Synaptic shows a gray exclamation-mark icon that means "Installed (upgradable)").

I found the text of your first quote on https://backports.debian.org/Instructions/

About your comment as follows:
xenopeek wrote:The backports repository is automatically set to priority 100 unless overridden.

The mechanism of this is explained on that same webpage:

backports.debian.org wrote:All backports are deactivated by default (i.e. the packages are pinned to 100 by using

Code: Select all

ButAutomaticUpgrades: yes
in the Release files).


This confirms that making a .pref file (setting Pin-Priority to 500 in my case) is needed for the user to be prompted that Debian backports packages are available.
--dg1727


Return to “Software & Applications”

Who is online

Users browsing this forum: No registered users and 1 guest