Audio out in Wine blocks audio out in native apps (& vice versa)

Questions about applications and software
Forum rules
Before you post please read how to get help
User avatar
f2x
Level 1
Level 1
Posts: 8
Joined: Sun Mar 17, 2013 3:24 pm

Audio out in Wine blocks audio out in native apps (& vice versa)

Postby f2x » Tue Jul 04, 2017 12:53 am

So essentially I use a laptop as an alarm clock, but the alarm clock application is Win32 native. I tried the native Linux alarm clocks, but they lacked certain capabilities I need because I do shift work, and I'm not nearly proficient enough to write an application myself. I tried, but it was really bad.

If I run this Win32 program under Wine, it generally works just fine, but audio from other (native Linux) apps are blocked from using the audio out while the alarm clock app is running.

On the other hand, if I run the alarm clock app while another program such as a web browser or VLC is using the audio out, the Win32 alarm clock app won't make a sound when the alarms are scheduled to go off.

This little problem has been plaguing me for a number of years now... I forget which version started this behavior, but it wasn't doing this back when I was using the original LMDE.

My current fix is to run Windows 10 in order to ensure that the alarms sound off when they are supposed to. While this isn't the worse kludge in the world, the laptop really does run a lot smoother under Linux. Websites render faster and smoother, the GUI is much more responsive, I can actually update the system on my schedule... You get the idea.

I hate to admit it, but I'm starting to fall for Cortana. She's a real pip! It would still be nice to understand what's going on with the audio out in Wine though, because having Windows on my nightstand is more than a little annoying. Highlighting text, then middle clicking on a prompt is absolutely soul crushing.

BTW, I'm using the 32 bit version of Wine 1.6.2 because I can never get the 64 bit version to work... at all, and I have 4 different machines and it is reproducible on all of them, and it shows up whenever any Win32 app requires audio out, so I don't think it's just the Intel 82801I (ICH9 Family) HD Audio Controller (rev 03) that my laptop is using, and it's not limited to this specific alarm clock program.

Yes, I Googled this. No matter how I word it, Google just gives me generic results for "no sound in wine" and that's not helpful. Any thoughts?
The coolest thing I'm currently working on is an autoblog called mBlip. Following over 70 educational channels on YouTube, new videos get added daily. Learn something new every day! http://www.mblip.com

User avatar
Flemur
Level 13
Level 13
Posts: 4548
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Audio out in Wine blocks audio out in native apps (& vice versa)

Postby Flemur » Tue Jul 04, 2017 1:09 pm

f2x wrote:If I run this Win32 program under Wine, it generally works just fine, but audio from other (native Linux) apps are blocked from using the audio out while the alarm clock app is running.

I think all the ubuntu/mint installs include pulseaudio, which should let you 'mix' audio from various sources and hear it all at the same time. Some sound cards can do that w/o pulse, but not all.
So, just a guess - some of the programs are talking to 'alsa' rather than pulse, or you don't have pulseaudio installed.

See if you have pulseaudio installed:

Code: Select all

dpkg -l "pulse*"

If it says
"ii pulseaudio" it's installed;
"uu pulseaudio" = not installed.

Check say, audio output from vlc, make sure it's pulse(audio).
Also

Code: Select all

winecfg

-> Audio tab -> set it to pulse.
Also your windows program might have some audio-out settings (foobar does).

Now try vlc and your windows program at the same time.
Mint 18.2 Xfce/fluxbox/pulse-less - Xubuntu 16.10/fluxbox/pulse-less
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

User avatar
f2x
Level 1
Level 1
Posts: 8
Joined: Sun Mar 17, 2013 3:24 pm

Re: Audio out in Wine blocks audio out in native apps (& vice versa)

Postby f2x » Tue Jul 04, 2017 11:16 pm

Flemur wrote:I think all the ubuntu/mint installs include pulseaudio, which should let you 'mix' audio from various sources and hear it all at the same time. Some sound cards can do that w/o pulse, but not all.
So, just a guess - some of the programs are talking to 'alsa' rather than pulse, or you don't have pulseaudio installed.


After doing some more digging, it appears that you are correct. Wine is talking to alsa instead of pulseaudio, and that conflict jams up the audio. Sadly I cannot correct this using the audio tab in winecfg, and I'm not even sure it could be fixed through wine regedit. Deleting the winealsa.drv key in regedit did nothing, so we can safely assume I have no idea what I'm doing.

At least this knowledge has put me back on the right track on what I need to do to correct this. There are still some un-Googleable's, like when I Google "set wine to pulseadio" the very first result is: "pulseaudio - How to change the default audio in Wine to Alsa only ..." {sigh} (I'm really starting to think Google has some kind of digital dementia.) Nevertheless, it looks like I have some more reading to do.

Thanks for the pointer!

-f2x

Edit: Yeah, the more I look into this, the more it appears the LMDE version of wine is hardwired to use alsa. Although Wine officially supports and recommends pulseaudio, many people cling to alsa because it provides lower latency. I don't know if this is still an issue with the current ubuntu branches, but I suspect that since I can't find anything regarding pulse vs alsa in the past couple of years, they probably fixed it in the latest iterations, moved on, and no one's had any complaints. It looks like the easiest fix outside of sticking with Windows 10 is to install Sonya. Does that sound about right?
The coolest thing I'm currently working on is an autoblog called mBlip. Following over 70 educational channels on YouTube, new videos get added daily. Learn something new every day! http://www.mblip.com

User avatar
Flemur
Level 13
Level 13
Posts: 4548
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Audio out in Wine blocks audio out in native apps (& vice versa)

Postby Flemur » Wed Jul 05, 2017 10:08 am

f2x wrote:[ Yeah, the more I look into this, the more it appears the LMDE version of wine is hardwired to use alsa.

I'm not familiar with LMDE or what might be different about it's wine.

Here winecfg -> Audio -> "system default"; (foobar audio = "default")...but I don't have pulseaudio installed! (I can play several sources at once and record 'what you hear' without pulseaudio, tho couldn't on previous built-in sound card; I think those are the reasons for using pulseaudio).

But try searching for (w/quotes):
"linux" "wine" "use pulseaudio"
Mint 18.2 Xfce/fluxbox/pulse-less - Xubuntu 16.10/fluxbox/pulse-less
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?


Return to “Software & Applications”

Who is online

Users browsing this forum: No registered users and 1 guest