Issue with apt-get install -f

Questions about applications and software
Forum rules
Before you post please read how to get help
0x2620
Level 2
Level 2
Posts: 67
Joined: Mon Jan 09, 2017 3:17 pm

Issue with apt-get install -f

Postby 0x2620 » Sun Sep 03, 2017 5:06 am

I was trying to install dependencies to build VBA-M because the VBA that exists in the repos doesn't recognize my usb controller and the VBA-M debs I installed crashed. When I ran cmake it told me I needed wxWidgets, so I added wxWidgets by following the instructions on their site. One of the dependencies is a version of libstdc++6 greater than 5.2-something. When I installed a deb of this it told me that I had broken dependencies and advised me to try apt-get install -f.

Here's the output of apt-get install -f:

Code: Select all

 sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  abiword-common libasound2:i386 libasyncns0:i386 libbsd0:i386 libcap2:i386 libdbus-1-3:i386 libdirectfb-1.2-9:i386
  libdrm-intel1:i386 libdrm-nouveau2:i386 libdrm-radeon1:i386 libdrm2:i386 libedit2:i386 libelf1:i386 libexpat1:i386
  libffi6:i386 libflac8:i386 libgcrypt20:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386 libgpg-error0:i386 libice6:i386
  libjson-c2:i386 libloudmouth1-0 libncursesw5:i386 libogg0:i386 libots0 libpciaccess0:i386 libpng12-0:i386 libpulse0:i386
  libslang2:i386 libsm6:i386 libsndfile1:i386 libsysfs2:i386 libsystemd0:i386 libudev1:i386 libvorbis0a:i386 libvorbisenc2:i386
  libwrap0:i386 libwv-1.2-4 libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-dri2-0:i386 libxcb-dri3-0:i386 libxcb-glx0:i386
  libxcb-present0:i386 libxcb-sync1:i386 libxcb1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxi6:i386
  libxshmfence1:i386 libxtst6:i386 libxxf86vm1:i386
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  abiword evolution-data-server gir1.2-ebook-1.2 gir1.2-ebookcontacts-1.2 libabiword-3.0 libboost-date-time1.55.0 libcaca0:i386
  libcmis-0.4-4 libebook-1.2-14 libebook-contacts-1.2-0 libedata-book-1.2-20 libgl1-mesa-dri:i386 libllvm3.5:i386
  libphonenumber6 libreoffice-base libreoffice-base-core libreoffice-base-drivers libreoffice-calc libreoffice-core
  libreoffice-gnome libreoffice-gtk libreoffice-help-en-us libreoffice-pdfimport libreoffice-sdbc-hsqldb libreoffice-writer
  libsdl1.2debian:i386 libstdc++6:i386 libtxc-dxtn-s2tc0:i386 printer-driver-brlaser python3-uno zsnes:i386
0 upgraded, 0 newly installed, 31 to remove and 1 not upgraded.
5 not fully installed or removed.
After this operation, 310 MB disk space will be freed.


I want to keep half of these programs.

I gave up compiling VBA-M and I just want this problem to go away. Is there any way I can resolve this issue without having to reinstall libreoffice and whatever else will be broken by this?

User avatar
xenopeek
Level 24
Level 24
Posts: 21458
Joined: Wed Jul 06, 2011 3:58 am
Location: The Netherlands

Re: Issue with apt-get install -f

Postby xenopeek » Sun Sep 03, 2017 12:22 pm

You should install the libstdc++6 version that goes with your operating system (with which all the software on your operating system has been compiled and tested). Probably quickest to just download the .deb file from the repository and install it manually.

If you're on Linux Mint 17.x, download the amd64 .deb file from here: https://packages.ubuntu.com/trusty/libstdc++6

If you're on Linux Mint 18.x, download the amd64 .deb file from here: https://packages.ubuntu.com/xenial/libstdc++6

After installing that run sudo apt-get install -f again to see if all issues have gone away.
Image


Return to “Software & Applications”