[SOLVED] update manager fault

Questions about applications and software
Forum rules
Before you post please read how to get help
jamesowens
Level 1
Level 1
Posts: 5
Joined: Thu Nov 16, 2017 1:22 pm

[SOLVED] update manager fault

Postby jamesowens » Sat Nov 25, 2017 9:44 am

when asked to update chromium- browser on my Linux mint this is what came back,
run "dpkg -- configure-a"
E: _cache->open() failed. please report.
can someone please tell me what route to take to clear this fault.
Last edited by Moem on Wed Nov 29, 2017 1:52 pm, edited 1 time in total.
Reason: Marked this as [SOLVED] for you; you can do this for your own topics. Thanks!

User avatar
Moem
Level 12
Level 12
Posts: 4418
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: update manager fault

Postby Moem » Sat Nov 25, 2017 9:48 am

Sure. See that command that's being suggested?

Code: Select all

dpkg -- configure-a

Copy that, paste it into a terminal, and run it.
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

User avatar
Flemur
Level 13
Level 13
Posts: 4851
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: update manager fault

Postby Flemur » Sat Nov 25, 2017 12:32 pm

Moem wrote:

Code: Select all

dpkg -- configure-a

Copy that, paste it into a terminal, and run it.

That won't work. Apparently OP copied the error message incorrectly; it's probably supposed to be

Code: Select all

sudo dpkg --configure -a
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?

User avatar
Moem
Level 12
Level 12
Posts: 4418
Joined: Tue Nov 17, 2015 9:14 am
Location: The Netherlands
Contact:

Re: update manager fault

Postby Moem » Sat Nov 25, 2017 12:45 pm

Thanks for the correction!
Image

If your issue is solved, kindly indicate that by editing the first post in the topic, and adding [SOLVED] to the title. Thanks!

jamesowens
Level 1
Level 1
Posts: 5
Joined: Thu Nov 16, 2017 1:22 pm

Re: update manager fault

Postby jamesowens » Sun Nov 26, 2017 6:24 am

This was the answer which was unable to happen as the system reported:-

│ This package automates the process of launching downloads of the source │
│ files for libdvdcss2 from videolan.org, compiling them, and installing │
│ the binary packages (libdvdcss2 libdvdcss-dev). │
│ │
│ Please run "sudo dpkg-reconfigure libdvd-pkg" to launch this process for │
│ the first time.

unfortunately nothing happened, and when I tried to close the massage it said it was still running?

User avatar
Pjotr
Level 19
Level 19
Posts: 9354
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: update manager fault

Postby Pjotr » Sun Nov 26, 2017 6:59 am

jamesowens wrote:This was the answer which was unable to happen as the system reported:-

│ This package automates the process of launching downloads of the source │
│ files for libdvdcss2 from videolan.org, compiling them, and installing │
│ the binary packages (libdvdcss2 libdvdcss-dev). │
│ │
│ Please run "sudo dpkg-reconfigure libdvd-pkg" to launch this process for │
│ the first time.

unfortunately nothing happened, and when I tried to close the massage it said it was still running?

You probably only have to wait. This compiling business is resource- and time consuming.

Waiting is annoying. For that reason, I've disabled the automatic updates for libdvdcss2 myself. Don't need those updates anyway.... The original libdvdcss2 is fine for me.
Tip: 10 things to do after installing Linux Mint 18.3 Sylvia
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

jamesowens
Level 1
Level 1
Posts: 5
Joined: Thu Nov 16, 2017 1:22 pm

Re: update manager fault

Postby jamesowens » Sun Nov 26, 2017 11:28 am

this is coming up for the last two days when I put in" sudo dpkg --configure -a" then it asks "sudo dpkg-reconfigure libdvd-pkg" and this the aswer:-
debconf: DbDriver "config": /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable.

User avatar
minitux
Level 5
Level 5
Posts: 783
Joined: Tue Sep 12, 2017 10:05 am

Re: update manager fault

Postby minitux » Sun Nov 26, 2017 1:45 pm

Code: Select all

sudo mv /var/cache/debconf/config.dat /var/cache/debconf/config.dat-old

Code: Select all

sudo dpkg-reconfigure libdvd-pkg


however, as far as I'm concerned, I'm just libdvdcss2 for DVD support installed with mint-meta-codecs
Sorry for my English, is not my language

When you ask for support, put the output of inxi -Fxz

jamesowens
Level 1
Level 1
Posts: 5
Joined: Thu Nov 16, 2017 1:22 pm

Re: update manager fault

Postby jamesowens » Wed Nov 29, 2017 6:30 am

james@james-Studio-1737 ~ $ sudo mv /var/cache/debconf/config.dat /var/cache/debconf/config.dat-old
[sudo] password for james:
mv: cannot stat '/var/cache/debconf/config.dat': No such file or directory

james@james-Studio-1737 ~ $ sudo dpkg-reconfigure libdvd-pkg/usr/sbin/dpkg-reconfigure: libdvd-pkg is broken or not fully installed.

I get the feeling that the update manager gives updates for prog/files that I have not yet installed.
what would you suggest?

User avatar
minitux
Level 5
Level 5
Posts: 783
Joined: Tue Sep 12, 2017 10:05 am

Re: update manager fault

Postby minitux » Wed Nov 29, 2017 6:46 am

it seems strange to suggest updates for packages that you did not install ....

try reinstalling that package

Code: Select all

sudo apt install --reinstall libdvd-pkg
Sorry for my English, is not my language

When you ask for support, put the output of inxi -Fxz

User avatar
Pjotr
Level 19
Level 19
Posts: 9354
Joined: Mon Mar 07, 2011 10:18 am
Location: The Netherlands (Holland)
Contact:

Re: update manager fault

Postby Pjotr » Wed Nov 29, 2017 7:27 am

As minitux says. Then again:

Code: Select all

sudo dpkg-reconfigure libdvd-pkg


If successful: lock the DVD decrypting packages you've installed to their current versions. Because updates for them are time consuming, might lead to disruptions like you've been experiencing and are rarely ever useful.

For that, use this command:

Code: Select all

sudo apt-mark hold libdvd-pkg libdvdcss2 libdvdcss-dev
Tip: 10 things to do after installing Linux Mint 18.3 Sylvia
Keep your Linux Mint healthy: Avoid these 10 fatal mistakes
Twitter: twitter.com/easylinuxtips
All in all, horse sense simply makes sense.

jamesowens
Level 1
Level 1
Posts: 5
Joined: Thu Nov 16, 2017 1:22 pm

Re: update manager fault

Postby jamesowens » Wed Nov 29, 2017 1:46 pm

Thanks Pjotr, putting a hold did the trick all the updates were successful. :D


Return to “Software & Applications”