Wine Still Not Working on LMDE 2? <SOLVED>

Questions about applications and software
Forum rules
Before you post please read how to get help

LMDE 2 support ends on 1-1-2019
Post Reply
rbeltz48
Level 4
Level 4
Posts: 228
Joined: Mon Jan 16, 2012 3:08 pm
Location: Florida, USA

Wine Still Not Working on LMDE 2? <SOLVED>

Post by rbeltz48 » Sun Jan 07, 2018 12:53 pm

I am testing LMDE 2 again after an long absence. I installed Wine and Synaptic shows that it is installed. But it doesn't show up anywhere in the menus or when I try to install an .exe file. Is there a fix for this? Otherwise LMDE 2 runs great. Thanks.
Last edited by rbeltz48 on Mon Jan 08, 2018 5:11 pm, edited 1 time in total.

User avatar
Flemur
Level 16
Level 16
Posts: 6070
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Wine Still Not Working on LMDE 2?

Post by Flemur » Sun Jan 07, 2018 3:37 pm

In a terminal try

Code: Select all

wine --version
and

Code: Select all

wine whatever.exe
FWIW, my wine (wine-stable, 2.0.4) install on regular mint put the stuff under /opt and without links to the executables, so nothing worked until I added
/opt/wine-stable/bin
to my PATH. (though other versions of wine didn't do that, and Ubuntu with wine(-stable) 2.0.2 doesn't even have a /opt directory).
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

rbeltz48
Level 4
Level 4
Posts: 228
Joined: Mon Jan 16, 2012 3:08 pm
Location: Florida, USA

Re: Wine Still Not Working on LMDE 2?

Post by rbeltz48 » Mon Jan 08, 2018 9:37 am

OK. The installed Wine version is 1.6.2. The .Wine64 directory appears in my Home directory's hidden files. If I try wine .exe in the Terminal it works. Now, how do I set up an executable so that the Wine option will appear in the Open With menu when I right click on the .exe file? Thanks.

User avatar
Flemur
Level 16
Level 16
Posts: 6070
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Wine Still Not Working on LMDE 2?

Post by Flemur » Mon Jan 08, 2018 10:19 am

rbeltz48 wrote:OK. The installed Wine version is 1.6.2. The .Wine64 directory appears in my Home directory's hidden files.
Did you set up that name (.Wine64 )? It's usually ".wine" by default. Did you "add architecture i386"? (that's not the exact syntax!)
If I try wine .exe in the Terminal it works. Now, how do I set up an executable so that the Wine option will appear in the Open With menu when I right click on the .exe file? Thanks.
In your file browser, rt-click on .exe file -> "Open with" and choose "wine", and set it as the default.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

rbeltz48
Level 4
Level 4
Posts: 228
Joined: Mon Jan 16, 2012 3:08 pm
Location: Florida, USA

Re: Wine Still Not Working on LMDE 2?

Post by rbeltz48 » Mon Jan 08, 2018 10:51 am

To answer your questions:

1) I installed Wine from Synaptic. As far as the .wine64 directory in my Home hidden files, I assume it was installed there during the installation. I didn't set up that directory.

2) In the file browser there is no "Open With" ---> "Wine Windows Program Loader" in the menu.

User avatar
Pepi
Level 5
Level 5
Posts: 688
Joined: Wed Nov 18, 2009 7:47 pm

Re: Wine Still Not Working on LMDE 2?

Post by Pepi » Mon Jan 08, 2018 12:54 pm

I followed these instructions and mine WINE works on LMDE2

viewtopic.php?f=241&t=194149

rbeltz48
Level 4
Level 4
Posts: 228
Joined: Mon Jan 16, 2012 3:08 pm
Location: Florida, USA

Re: Wine Still Not Working on LMDE 2?

Post by rbeltz48 » Mon Jan 08, 2018 5:11 pm

OK. I installed Wine 1.8 on my test laptop which has three other distros on it. I wonder why the correct repositories are not already in place in LMDE 2. This seems odd, like it's an omission in the distro itself, considering how many Linux people use Wine. I had exactly the same trouble 2 years ago and gave up on LMDE 2. I wonder why Debian makes it so hard to install and use Wine. Thanks for the tip!

User avatar
Pepi
Level 5
Level 5
Posts: 688
Joined: Wed Nov 18, 2009 7:47 pm

Re: Wine Still Not Working on LMDE 2? <SOLVED>

Post by Pepi » Tue Jan 09, 2018 11:56 am

The Debian world is not a fan of WINE from what I've read. I myself only have one computer with it installed. Too much like that awful Windows :mrgreen: :mrgreen:

Post Reply

Return to “Software & Applications”