Page 1 of 1

Wine Still Not Working on LMDE 2? <SOLVED>

Posted: Sun Jan 07, 2018 12:53 pm
by rbeltz48
I am testing LMDE 2 again after an long absence. I installed Wine and Synaptic shows that it is installed. But it doesn't show up anywhere in the menus or when I try to install an .exe file. Is there a fix for this? Otherwise LMDE 2 runs great. Thanks.

Re: Wine Still Not Working on LMDE 2?

Posted: Sun Jan 07, 2018 3:37 pm
by Flemur
In a terminal try

Code: Select all

wine --version
and

Code: Select all

wine whatever.exe
FWIW, my wine (wine-stable, 2.0.4) install on regular mint put the stuff under /opt and without links to the executables, so nothing worked until I added
/opt/wine-stable/bin
to my PATH. (though other versions of wine didn't do that, and Ubuntu with wine(-stable) 2.0.2 doesn't even have a /opt directory).

Re: Wine Still Not Working on LMDE 2?

Posted: Mon Jan 08, 2018 9:37 am
by rbeltz48
OK. The installed Wine version is 1.6.2. The .Wine64 directory appears in my Home directory's hidden files. If I try wine .exe in the Terminal it works. Now, how do I set up an executable so that the Wine option will appear in the Open With menu when I right click on the .exe file? Thanks.

Re: Wine Still Not Working on LMDE 2?

Posted: Mon Jan 08, 2018 10:19 am
by Flemur
rbeltz48 wrote:OK. The installed Wine version is 1.6.2. The .Wine64 directory appears in my Home directory's hidden files.
Did you set up that name (.Wine64 )? It's usually ".wine" by default. Did you "add architecture i386"? (that's not the exact syntax!)
If I try wine .exe in the Terminal it works. Now, how do I set up an executable so that the Wine option will appear in the Open With menu when I right click on the .exe file? Thanks.
In your file browser, rt-click on .exe file -> "Open with" and choose "wine", and set it as the default.

Re: Wine Still Not Working on LMDE 2?

Posted: Mon Jan 08, 2018 10:51 am
by rbeltz48
To answer your questions:

1) I installed Wine from Synaptic. As far as the .wine64 directory in my Home hidden files, I assume it was installed there during the installation. I didn't set up that directory.

2) In the file browser there is no "Open With" ---> "Wine Windows Program Loader" in the menu.

Re: Wine Still Not Working on LMDE 2?

Posted: Mon Jan 08, 2018 12:54 pm
by Pepi
I followed these instructions and mine WINE works on LMDE2

viewtopic.php?f=241&t=194149

Re: Wine Still Not Working on LMDE 2?

Posted: Mon Jan 08, 2018 5:11 pm
by rbeltz48
OK. I installed Wine 1.8 on my test laptop which has three other distros on it. I wonder why the correct repositories are not already in place in LMDE 2. This seems odd, like it's an omission in the distro itself, considering how many Linux people use Wine. I had exactly the same trouble 2 years ago and gave up on LMDE 2. I wonder why Debian makes it so hard to install and use Wine. Thanks for the tip!

Re: Wine Still Not Working on LMDE 2? <SOLVED>

Posted: Tue Jan 09, 2018 11:56 am
by Pepi
The Debian world is not a fan of WINE from what I've read. I myself only have one computer with it installed. Too much like that awful Windows :mrgreen: :mrgreen: