Atril/Xreader does not display www.geos.ed.ac.uk/homes/thompson/envmag/Envmag_4_5.pdf

Questions about applications and software
Forum rules
Before you post please read how to get help

LMDE 2 support ends on 1-1-2019
Post Reply
Hansl
Level 3
Level 3
Posts: 103
Joined: Fri Dec 09, 2011 3:50 pm

Atril/Xreader does not display www.geos.ed.ac.uk/homes/thompson/envmag/Envmag_4_5.pdf

Post by Hansl » Tue Jan 23, 2018 6:08 pm

See https://github.com/mate-desktop/atril/issues/291 , the Mate people sent me back to Mint since it seems a distro problem:

Code: Select all

wget www.geos.ed.ac.uk/homes/thompson/envmag/Envmag_4_5.pdf
atril Envmag_4_5.pdf 
xreader Envmag_4_5.pdf 
Tested on several LMDE2 Mate installations, old updated and brand new ones: Atril 1.18.0 using poppler/cairo (0.26.5) / Xreader 1.4.4 displays only nearly blank pages, looking like the background of the scan. While other (Windows) PDF viewers display perfectly readable scanned text.

zorzi
Level 2
Level 2
Posts: 66
Joined: Thu Aug 04, 2016 4:26 pm

Re: Atril/Xreader does not display www.geos.ed.ac.uk/homes/thompson/envmag/Envmag_4_5.pdf

Post by zorzi » Wed Jan 24, 2018 4:19 am

Tested and work fine on Debian Stretch XFCE. Evince OK, XPDF OK.
Desktop: HP Pavilion a6435 (Athlon64 2x 2,6Ghz, Radeon R7-240, Ram 4 Go, HD 500 Go) / MX Linux 17
Laptop: Packard-Bell EasyNote G1320 (Celeron 1,3 Ghz, ATI Mobility Radeon 9100 IGP, Ram 1,2 Go, HD 40 Go) / Debian Stretch

User avatar
Bolle1961
Level 5
Level 5
Posts: 706
Joined: Tue Jun 29, 2010 12:59 pm

Re: Atril/Xreader does not display www.geos.ed.ac.uk/homes/thompson/envmag/Envmag_4_5.pdf

Post by Bolle1961 » Wed Jan 24, 2018 4:45 am

Works good. Did not use wget but the url
Linux Mint 18.3 MATE x64
xreader 1.6.2
Image

User avatar
thx-1138
Level 6
Level 6
Posts: 1154
Joined: Fri Mar 10, 2017 12:15 pm
Location: Athens, Greece

Re: Atril/Xreader does not display www.geos.ed.ac.uk/homes/thompson/envmag/Envmag_4_5.pdf

Post by thx-1138 » Wed Jan 24, 2018 5:05 am

For the record: the pdf is nicely linearized (in order to keep it's size small / to be able to load fast on browsers), and doesn't contain any fonts at all (it's only scanned images).
Opens perfectly for me on Firefox 57.0.4, on mupdf 1.12, and also on qpdfview (poppler version 0.41). Note that i'm not on LMDE however.

Hansl
Level 3
Level 3
Posts: 103
Joined: Fri Dec 09, 2011 3:50 pm

Re: Atril/Xreader does not display www.geos.ed.ac.uk/homes/thompson/envmag/Envmag_4_5.pdf

Post by Hansl » Mon Jan 29, 2018 12:03 pm

Well, that's nice to hear that newer versions work.  Unfortunately LMDE is still stuck at Debian Jessie and Mate 1.18, no simple way to get updates.

Another example with very similar behaviour, also a scanned book (9 MB / 395 pages): 
http://mirror.thelifeofkenneth.com/lib/ ... 6_text.pdf
Mainly blank in LMDE2 / Atril 1.18.0, OK in other viewers.

Post Reply

Return to “Software & Applications”