<SOLVED> Need firefox_57.0.4~linuxmint1+betsy_i386.deb

Questions about applications and software
Forum rules
Before you post please read how to get help

LMDE 2 support ends on 1-1-2019
Post Reply
imthomyorke
Level 1
Level 1
Posts: 2
Joined: Sat Feb 03, 2018 3:30 am

<SOLVED> Need firefox_57.0.4~linuxmint1+betsy_i386.deb

Post by imthomyorke » Sun Feb 04, 2018 9:46 am

Is there anyone here still have firefox_57.0.4~linuxmint1+betsy_i386.deb where i can download?
I searched from duckduckgo or google but I didn't found any ftp or repo which is still have it. Thanks anyway!
Last edited by imthomyorke on Tue Feb 06, 2018 11:00 am, edited 1 time in total.

User avatar
Pierre
Level 17
Level 17
Posts: 7396
Joined: Fri Sep 05, 2008 5:33 am
Location: Perth, AU.

Re: Need firefox_57.0.4~linuxmint1+betsy_i386.deb

Post by Pierre » Sun Feb 04, 2018 10:20 am

you may still have to get that using *.tar.bz2 format:
https://www.mozilla.org/en-US/firefox/new/?scene=2
but, that probably will give the latest version of Firefox . . .

http://libre-software.net/how-to-instal ... inux-mint/
will tell you how to extract & install Firefox
Image
Please edit your original post title to include [SOLVED] - when your problem is solved!
and DO LOOK at those Unanswered Topics - - you may be able to answer some!.

User avatar
karlchen
Level 19
Level 19
Posts: 9311
Joined: Sat Dec 31, 2011 7:21 am
Location: Germany

Re: Need firefox_57.0.4~linuxmint1+betsy_i386.deb

Post by karlchen » Sun Feb 04, 2018 10:26 am

<moderator on>
The filename "firefox_57.0.4~linuxmint1+betsy_i386.deb" suggests that the request affects Linux Mint Debian Edition 2 (LMDE 2), which is not the Linux Mint Main Edition (Ubuntu based Mint 17.x and Mint 18.x). Thread moved to the LMDE 2 subforum as a consequence.
</moderator off>
Image
Linux Mint 18.1 64-bit Cinnamon Desktop, Total Commander 9.21a 64-bit
Ubuntu 18.04.1 32-bit Mate Desktop, Total Commander 9.21a 32-bit
Windows? - 1 window in every room

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Need firefox_57.0.4~linuxmint1+betsy_i386.deb

Post by Cosmo. » Sun Feb 04, 2018 10:28 am

A very bad idea. FF 57.0.4 has nearly 3 dozen security holes, most of them classified as critical or high. Do never complain, if the system does behave wrongly!

User avatar
Flemur
Level 16
Level 16
Posts: 6101
Joined: Mon Aug 20, 2012 9:41 pm
Location: Potemkin Village

Re: Need firefox_57.0.4~linuxmint1+betsy_i386.deb

Post by Flemur » Sun Feb 04, 2018 10:29 am

I install (any version I want) from here:
https://ftp.mozilla.org/pub/firefox/releases/

FF 57.0.4, 32 bit version:
https://ftp.mozilla.org/pub/firefox/rel ... .4.tar.bz2

EDit: it's not a deb file; Pierre's "how to install" link sounds right.
Please edit your original post title to include [SOLVED] if/when it is solved!
Your data and OS are backed up....right?
Mint 18.3 Xfce/fluxbox/pulse-less
Xubuntu 17.10/fluxbox/pulse-less

imthomyorke
Level 1
Level 1
Posts: 2
Joined: Sat Feb 03, 2018 3:30 am

Re: Need firefox_57.0.4~linuxmint1+betsy_i386.deb

Post by imthomyorke » Tue Feb 06, 2018 10:58 am

by karlchen » Sun Feb 04, 2018 9:26 pm
<moderator on>
The filename "firefox_57.0.4~linuxmint1+betsy_i386.deb" suggests that the request affects Linux Mint Debian Edition 2 (LMDE 2), which is not the Linux Mint Main Edition (Ubuntu based Mint 17.x and Mint 18.x). Thread moved to the LMDE 2 subforum as a consequence.
</moderator off>
Hi karichen, I am very sorry waste your time move my thread since I didn't look LMDE that have own root threads...
my eyes rolling when I missed the lmde index in front of the page, this is my first post here :roll:
by Pierre » Sun Feb 04, 2018 9:20 pm
you may still have to get that using *.tar.bz2 format:
https://www.mozilla.org/en-US/firefox/new/?scene=2
but, that probably will give the latest version of Firefox . . .

http://libre-software.net/how-to-instal ... inux-mint/
will tell you how to extract & install Firefox
Hi Pierre, thank you for your suggestion, I completed download and extract it. Solved now.
by Cosmo. » Sun Feb 04, 2018 9:28 pm
A very bad idea. FF 57.0.4 has nearly 3 dozen security holes, most of them classified as critical or high. Do never complain, if the system does behave wrongly!
Hi Cosmo, thank you for your warning, you're right there are many highly critical issue, but it is my responsibilty according to security issue, anyway FF 58.0.x profile is impossible to use anymore when you downgrade in previous version.
by Flemur » Sun Feb 04, 2018 9:29 pm
I install (any version I want) from here:
https://ftp.mozilla.org/pub/firefox/releases/

FF 57.0.4, 32 bit version:
https://ftp.mozilla.org/pub/firefox/rel ... .4.tar.bz2

EDit: it's not a deb file; Pierre's "how to install" link sounds right.
Hi flemur, very thanks for the download link, it solved now.

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Need firefox_57.0.4~linuxmint1+betsy_i386.deb

Post by Cosmo. » Tue Feb 06, 2018 5:18 pm

imthomyorke wrote:Hi Cosmo, thank you for your warning, you're right there are many highly critical issue, but it is my responsibilty according to security issue, anyway FF 58.0.x profile is impossible to use anymore when you downgrade in previous version.
What you use is indeed alone your responsibility, but as soon as you ask this question and of course expect answers, it gets a public affair.

Should should consider to use Firefox ESR instead. The current base gets supported until the end of August. With this you act responsible for yourself.

User avatar
Fred Barclay
Level 12
Level 12
Posts: 4149
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

Re: Need firefox_57.0.4~linuxmint1+betsy_i386.deb

Post by Fred Barclay » Tue Feb 06, 2018 7:24 pm

Cosmo. wrote: Should should consider to use Firefox ESR instead. The current base gets supported until the end of August. With this you act responsible for yourself.
This. +1. With a cherry on top. :)

Browsers are one of the most common attack vectors. It's ultimately your choice, but please at least consider using Firefox ESR instead of Firefox 57, since ESR gets regular security updates.

Cosmo has a guide on installing Firefox ESR on Mint: viewtopic.php?f=42&t=202594&p=1405761

Also, if you must run Firefox 57.0.4, please at least consider sandboxing it with firejail (actually, it's a pretty good idea to sandbox your browser no matter what version you use). :) I can help guide you through this if you like.
Image
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

Cosmo.
Level 23
Level 23
Posts: 17829
Joined: Sat Dec 06, 2014 7:34 am

Re: Need firefox_57.0.4~linuxmint1+betsy_i386.deb

Post by Cosmo. » Wed Feb 07, 2018 6:49 am

Fred Barclay wrote:Also, if you must run Firefox 57.0.4, please at least consider sandboxing it ...
... or run it offline. 8) Sorry, I could not resist to add this joke.

More serious: Even a sandboxed browser is no protection against privacy theft. If there are security holes, sandboxing will not close them, it can even not ensure, that the leaks cannot be used by an attacker.

Pr1ymüL
Level 1
Level 1
Posts: 14
Joined: Mon Feb 05, 2018 1:50 pm

Re: <SOLVED> Need firefox_57.0.4~linuxmint1+betsy_i386.deb

Post by Pr1ymüL » Wed Feb 07, 2018 6:32 pm

Someone suggested this to me. I haven't checked this out yet, might be recommended checking out as a alternative from the same base build. https://www.waterfoxproject.org/

:mrgreen: good luck to you!

Post Reply

Return to “Software & Applications”