(SOLVED) LMDE2 mate - problem installing nvidia drivers

Questions about hardware and drivers
Forum rules
Before you post please read how to get help
Post Reply
donki68
Level 1
Level 1
Posts: 15
Joined: Sat Aug 25, 2012 12:16 am

(SOLVED) LMDE2 mate - problem installing nvidia drivers

Post by donki68 » Sat Mar 28, 2015 12:30 pm

Is anyone else having issues install nvidia drivers? I have attempt this using smxi a number of times. At the end of the process I select "start desktop" I can login and startx and everthing runs fine.
Upon reboot X server always fails. If I run smxi again and reinstall the nvidia drivers I can get to the desktop, but if I reboot X server fails.

I have attempt to run "nvidia-xconfig" prior to reboot also.

Graphics card: nvidia G94 [GeForce 9600 GT]
Display server: X.org 1.16.4 driver nvidia
Last edited by donki68 on Tue Mar 31, 2015 12:24 pm, edited 2 times in total.

Monsta
Level 9
Level 9
Posts: 2997
Joined: Fri Aug 19, 2011 3:46 am

Re: LMDE2 mate - problem installing nvidia drivers

Post by Monsta » Tue Mar 31, 2015 3:49 am

First, which driver did you install? Maybe it wasn't a stable version?
Try using -d argument to let sgfxi install the drivers from Debian Jessie repos. As a side effect, this will allow you to get the driver updates in the future without using sgfxi.

Second, sgfxi had some issues when running on LMDE UP8, I'm not sure if they're fixed now (in regards to LMDE 2).

Third, if the problem still persists after installing the drivers from the repos, post the output of

Code: Select all

cat /var/log/Xorg.0.log

donki68
Level 1
Level 1
Posts: 15
Joined: Sat Aug 25, 2012 12:16 am

Re: LMDE2 mate - problem installing nvidia drivers (SOLVED)

Post by donki68 » Tue Mar 31, 2015 12:19 pm

Thanks for the input. sgfxi -d still failed. For some reason it could not find the proper packages.

But I just installed the Nvidia drivers outside of smxi and all works well now. Thanks for mention that smxi had issues with LMDE (1) or I would never had tried to go a different route. Below is what I did in case anyone else has this issue. It was far easier than trying to use smxi.

sudo apt-get install nvidia-driver
sudo apt-get install nvidia-xconfig
sudo nvidia-config
startx

Monsta
Level 9
Level 9
Posts: 2997
Joined: Fri Aug 19, 2011 3:46 am

Re: (SOLVED) LMDE2 mate - problem installing nvidia drivers

Post by Monsta » Tue Mar 31, 2015 1:39 pm

I'd recommend first removing any drivers installed via sgfxi - to avoid possible conflicts with the drivers from the repo.
(That would not be needed if the installation with -d option would succeed - sgfxi would automatically remove any previously installed drivers before proceeding.)

As for the drivers installation from the repos, Debian Wiki has a nice howto.

Felix2cat
Level 1
Level 1
Posts: 22
Joined: Tue Mar 03, 2015 1:31 pm

Re: (SOLVED) LMDE2 mate - problem installing nvidia drivers

Post by Felix2cat » Thu Apr 02, 2015 4:54 pm

Is there anything new in LMDE 2 for Optimus graphic cards ?
I mean like Ubuntu-Mint : without Bumblebee ? :roll:
Everyday : LMDE (Cinnamon) - Gaming : Mint Qiana (Cinnamon)
One laptop, two partitions !

Monsta
Level 9
Level 9
Posts: 2997
Joined: Fri Aug 19, 2011 3:46 am

Re: (SOLVED) LMDE2 mate - problem installing nvidia drivers

Post by Monsta » Fri Apr 03, 2015 4:47 am

If you mean Ubuntu's nvidia-prime package, then no, it's not available in Debian. Bumblebee is available.

Felix2cat
Level 1
Level 1
Posts: 22
Joined: Tue Mar 03, 2015 1:31 pm

Re: (SOLVED) LMDE2 mate - problem installing nvidia drivers

Post by Felix2cat » Fri Apr 03, 2015 1:33 pm

Yes, that's the point. 8)
What do you think of the proprietary driver (nvidia-installer) ? Is it damageable for LMDE stability ?
Everyday : LMDE (Cinnamon) - Gaming : Mint Qiana (Cinnamon)
One laptop, two partitions !

Monsta
Level 9
Level 9
Posts: 2997
Joined: Fri Aug 19, 2011 3:46 am

Re: (SOLVED) LMDE2 mate - problem installing nvidia drivers

Post by Monsta » Sat Apr 04, 2015 4:19 pm

Not sure what you mean by "nvidia-installer" - the proprietary driver should be installed as described here.

Felix2cat
Level 1
Level 1
Posts: 22
Joined: Tue Mar 03, 2015 1:31 pm

Re: (SOLVED) LMDE2 mate - problem installing nvidia drivers

Post by Felix2cat » Mon Apr 06, 2015 4:48 am

Yes, I 've to be more specific...
I found the name "nvidia-installer" on the Nvidia's site.
So I was wondering if it's a good idea to use these instructions rather than Debian's one :?:
Everyday : LMDE (Cinnamon) - Gaming : Mint Qiana (Cinnamon)
One laptop, two partitions !

Monsta
Level 9
Level 9
Posts: 2997
Joined: Fri Aug 19, 2011 3:46 am

Re: (SOLVED) LMDE2 mate - problem installing nvidia drivers

Post by Monsta » Mon Apr 06, 2015 11:53 am

Well...
When you install the drivers via their own installer, Debian's package management system won't have a clue about it because it's not a .deb package.
If you're going to install that, first remove any Debian packages with nvidia proprietary drivers if you have them installed - in order to avoid any possible conflicts.

As long as the distro-packaged drivers work for me, I'll stick to them.

Felix2cat
Level 1
Level 1
Posts: 22
Joined: Tue Mar 03, 2015 1:31 pm

Re: (SOLVED) LMDE2 mate - problem installing nvidia drivers

Post by Felix2cat » Thu Apr 09, 2015 2:41 am

Thanks, Monsta :)
Everyday : LMDE (Cinnamon) - Gaming : Mint Qiana (Cinnamon)
One laptop, two partitions !

User avatar
mockturtl
Level 4
Level 4
Posts: 452
Joined: Sat Oct 09, 2010 8:51 pm

Re: (SOLVED) LMDE2 mate - problem installing nvidia drivers

Post by mockturtl » Wed Apr 15, 2015 8:32 pm

I had problems with sgfxi, too. No joy with -d, -n, -N nouveau.

Normal installation per donki68's post fixes it for me. (Note the command is spelled nvidia-xconfig, like the package.)
Image

User avatar
drcasper
Level 2
Level 2
Posts: 78
Joined: Sun Feb 20, 2011 3:41 pm
Location: Vojvodina

Re: LMDE2 mate - problem installing nvidia drivers (SOLVED)

Post by drcasper » Tue May 26, 2015 7:11 am

donki68 wrote:Thanks for the input. sgfxi -d still failed. For some reason it could not find the proper packages.

But I just installed the Nvidia drivers outside of smxi and all works well now. Thanks for mention that smxi had issues with LMDE (1) or I would never had tried to go a different route. Below is what I did in case anyone else has this issue. It was far easier than trying to use smxi.

sudo apt-get install nvidia-driver
sudo apt-get install nvidia-xconfig
sudo nvidia-config
startx
What did you do with nouveau before installing nvidia?
Image

Monsta
Level 9
Level 9
Posts: 2997
Joined: Fri Aug 19, 2011 3:46 am

Re: (SOLVED) LMDE2 mate - problem installing nvidia drivers

Post by Monsta » Tue May 26, 2015 7:45 am

It should be auto-blacklisted during the installation of the proprietary drivers, as described here.

User avatar
killer de bug
Level 14
Level 14
Posts: 5386
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: (SOLVED) LMDE2 mate - problem installing nvidia drivers

Post by killer de bug » Tue May 26, 2015 1:42 pm

As advised here, you can also do it by hand just to be on the safe side:

Code: Select all

sudo echo blacklist nouveau > /etc/modprobe.d/blacklist-nouveau.conf 
Image
If it ain't broke, fix it until it is.

User avatar
Robsteady
Level 1
Level 1
Posts: 2
Joined: Sat Jan 18, 2014 11:39 am
Location: New Jersey, USA

Re: (SOLVED) LMDE2 mate - problem installing nvidia drivers

Post by Robsteady » Thu Jun 18, 2015 10:31 am

killer de bug wrote:As advised here, you can also do it by hand just to be on the safe side:

Code: Select all

sudo echo blacklist nouveau > /etc/modprobe.d/blacklist-nouveau.conf 
Sorry if this is a newb question. If I blacklist the nouveau driver, does the system automatically switch to using the intel chip? At this point I'm not bothering with my Optimus hardware and I'd rather see the power savings of the intel GPU over the nvidia without having to install bumblebee.

frodopogo
Level 2
Level 2
Posts: 88
Joined: Sat Oct 24, 2009 1:07 am

Re: (SOLVED) LMDE2 mate - problem installing nvidia drivers

Post by frodopogo » Wed Oct 14, 2015 1:41 am

Monsta wrote:Not sure what you mean by "nvidia-installer" - the proprietary driver should be installed as described here.
But "here" describes installation for various versions of Debian-
which one is LMDE2?

kevinthefixer
Level 4
Level 4
Posts: 268
Joined: Thu Jul 23, 2015 10:36 pm

Re: (SOLVED) LMDE2 mate - problem installing nvidia drivers

Post by kevinthefixer » Wed Oct 14, 2015 10:00 pm

Robsteady wrote: Sorry if this is a newb question. If I blacklist the nouveau driver, does the system automatically switch to using the intel chip? At this point I'm not bothering with my Optimus hardware and I'd rather see the power savings of the intel GPU over the nvidia without having to install bumblebee.
If you simply blacklist nouveau without installing the proprietary driver the system will probably switch to vesa. If you don't want to use the (presumably) off-board Nvidia card, simply remove it. Then the system will switch to the onboard (integrated?) Intel GPU.

@frodopogo, LMDE2 is based on Debian Jessie. FWIW those instructions failed to work for me, maybe you'll have better luck.

frodopogo
Level 2
Level 2
Posts: 88
Joined: Sat Oct 24, 2009 1:07 am

Re: (SOLVED) LMDE2 mate - problem installing nvidia drivers

Post by frodopogo » Sat Oct 24, 2015 3:14 pm

donki's instructions got me only partway there.

When it tries to boot, I get an MDM error indicating driver mismatch.
But when I try to get into MDM to change it, it says I need to drop to root, and I forget how to do that.
So I'm stuck at the command line.

kevinthefixer
Level 4
Level 4
Posts: 268
Joined: Thu Jul 23, 2015 10:36 pm

Re: (SOLVED) LMDE2 mate - problem installing nvidia drivers

Post by kevinthefixer » Sun Oct 25, 2015 1:34 pm

frodopogo wrote:donki's instructions got me only partway there.

When it tries to boot, I get an MDM error indicating driver mismatch.
But when I try to get into MDM to change it, it says I need to drop to root, and I forget how to do that.
So I'm stuck at the command line.
sudo?

Post Reply

Return to “Hardware Support”