(solved) LMDE 2 64 and Intel HD 5500 - software-rendering

Questions about hardware and drivers
Forum rules
Before you post please read how to get help
Jinx138
Level 1
Level 1
Posts: 2
Joined: Tue Apr 28, 2015 3:16 pm

(solved) LMDE 2 64 and Intel HD 5500 - software-rendering

Postby Jinx138 » Tue Apr 28, 2015 3:53 pm

Somehow I got a big problem to get the hardware acceleration up and running.
After a fresh install I got this message that the software-rendering-mode is active.
What I already tried was updating sgfxi and installing the intel drivers from within the script creating the x11/xorg.conf, drivers installed smoothly but after reinitializing the desktop there is still no hw-acceleration.

Code: Select all

mint ~ $ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)

glxinfo | grep rende
direct rendering: Yes
    GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
    GLX_MESA_query_renderer, GLX_OML_swap_method, GLX_SGIS_multisample,
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.5, 256 bits)
    GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,
    GL_MESA_ycbcr_texture, GL_NV_blend_square, GL_NV_conditional_render,


I got no idea what else to try. Oh, tried Ubuntu 15.04 just for testing, no problems there... But I really like to stick to a stable and actual debian release with the elegance of Mint cinnamon.
Last edited by Jinx138 on Fri May 01, 2015 9:28 am, edited 2 times in total.
Acer Aspire E 15 E5-571-55SW, i5-5200U, Intel HD Graphics 5500, 4 GB DDR3 L

Jinx138
Level 1
Level 1
Posts: 2
Joined: Tue Apr 28, 2015 3:16 pm

Re: LMDE 2 64 and Intel HD 5500 - software-rendering-mode ac

Postby Jinx138 » Fri May 01, 2015 9:26 am

Solved:
First add the following to /etc/apt/sources.list:

Code: Select all

deb http://ftp.debian.org/debian experimental main

have no fear, your system will not update other packages to experimental, you have to choose manually.

update your repositories

Code: Select all

sudo apt-get update

in synaptic navigate to xserver-xorg-video-intel, choose from 'Package': 'Force Version' 2:2.99.917-1~exp1 (or sth like that on your english environment, I'm using the german desktop).

Apply your changes, reboot, done.
Acer Aspire E 15 E5-571-55SW, i5-5200U, Intel HD Graphics 5500, 4 GB DDR3 L

bob_sup
Level 1
Level 1
Posts: 1
Joined: Tue May 12, 2015 6:58 pm

Re: (solved) LMDE 2 64 and Intel HD 5500 - software-renderin

Postby bob_sup » Tue May 12, 2015 7:03 pm

Thanks for the guidelines Jinx, but I can't "force version"
It's greyed out and I can't figure out how to enable it.
I've also tried downloading the driver directly, but the .configure fails on a whole bunch of dependencies that I can't find guidance on either.

I must be missing something dumb. Any help would be greatly appreciated.

kruthoff
Level 1
Level 1
Posts: 1
Joined: Wed Jun 10, 2015 4:16 am

Re: (solved) LMDE 2 64 and Intel HD 5500 - software-renderin

Postby kruthoff » Wed Jun 10, 2015 4:28 am

The intel video driver needs to be updated to a more recent version, i.e. 2.99.917-1~bpo8+1.
In

Code: Select all

/etc/apt/sources.list
, please add this backports repo:

Code: Select all

deb http://httpredir.debian.org/debian jessie-backports main contrib non-free

Then do

Code: Select all

sudo apt-get update

Then choose the newer

Code: Select all

xserver-xorg-video-intel
driver package, i.e. with

Code: Select all

aptitude

Then do a

Code: Select all

reboot

Done.

rgnr
Level 1
Level 1
Posts: 4
Joined: Tue Apr 21, 2015 12:05 pm

Re: (solved) LMDE 2 64 and Intel HD 5500 - software-rendering

Postby rgnr » Sat Feb 18, 2017 3:38 am

The same problem. Updating to latest version didn't help.
$ glxinfo | grep render
direct rendering: Yes
GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
GLX_MESA_query_renderer, GLX_OML_swap_method, GLX_SGIS_multisample,
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.5, 256 bits)
GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,
GL_MESA_ycbcr_texture, GL_NV_blend_square, GL_NV_conditional_render,

Update! used aptitude to update some packages, now I get:
glxinfo | grep render
direct rendering: Yes
GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
GLX_MESA_multithread_makecurrent, GLX_MESA_query_renderer,
OpenGL renderer string: Mesa DRI Intel(R) HD Graphics 5500 (Broadwell GT2)
GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,
GL_NV_conditional_render, GL_NV_depth_clamp, GL_NV_packed_depth_stencil,
GL_ARB_conditional_render_inverted, GL_ARB_conservative_depth,
GL_NV_blend_square, GL_NV_conditional_render, GL_NV_depth_clamp,
GL_OES_fbo_render_mipmap, GL_OES_get_program_binary, GL_OES_mapbuffer,

Framerate in chromium-bsu has increased from 25 to 50 fps. Guess it worked :D


Return to “Hardware Support”