Page 1 of 1

Kernel panic...

Posted: Fri May 29, 2015 8:44 pm
by vito_spatafore
Hi fellows...

I'm in a big trouble:
Image

Is there a chance to recover this mess :?:

tia!

Re: Kernel panic...

Posted: Sat May 30, 2015 8:50 am
by Fred Barclay
4 words: What Did You Do?!??!?

But seriously, what did you do? Have you recently installed something or changed anything?

Re: Kernel panic...

Posted: Sat May 30, 2015 10:10 am
by Pjotr
As addition to Fred Marclay's question: can you boot from an older kernel? This panic is from the 3.16 kernel, so the original 3.13 kernel should still be present and be bootable from the Grub menu.

Re: Kernel panic...

Posted: Sat May 30, 2015 10:20 am
by vito_spatafore
first thx 4 the feedback...

yesterday I tried to install Funtoo and that's the result ...

Code: Select all

/media/sda3-ata-TOSHIBA_MK3259GS/usr/src/broadcom-sta-6.30.223.248
/media/sda3-ata-TOSHIBA_MK3259GS/usr/src/linux
/media/sda3-ata-TOSHIBA_MK3259GS/usr/src/linux-debian-sources-3.19.3
/media/sda3-ata-TOSHIBA_MK3259GS/usr/src/linux-headers-3.16.0-4-amd64
/media/sda3-ata-TOSHIBA_MK3259GS/usr/src/linux-headers-3.16.0-4-common
/media/sda3-ata-TOSHIBA_MK3259GS/usr/src/linux-kbuild-3.16
/media/sda3-ata-TOSHIBA_MK3259GS/usr/src/ndiswrapper-1.59
/media/sda3-ata-TOSHIBA_MK3259GS/usr/src/virtualbox-guest-4.3.18
perhaps that debian-sources-3.19.3 is the inconvenient ???

edit: I'm goin to erase it :!:

my /etc/fstab

Code: Select all

 /etc/fstab: static file system information.
#
# The root filesystem should have a pass number of either 0 or 1.
# All other filesystems should have a pass number of 0 or greater than 1.
#
# NOTE: If your BOOT partition is ReiserFS, add the notail option to opts.
#
# See the manpage fstab(5) for more information.
#
# <fs>			<mountpoint>	<type>		<opts>		<dump/pass>

/dev/sda1		/boot		ext2		noauto,noatime	1 2
/dev/sda3		/		ext4		noatime		0 1
/dev/sda4		/		xfs		noatime		0 1
#/dev/cdrom		/mnt/cdrom	auto		noauto,ro	0 0
is there somethin wrong?

Re: Kernel panic...

Posted: Sat May 30, 2015 10:42 am
by vito_spatafore
Pjotr wrote: the original 3.13 kernel should still be present and be bootable from the Grub menu.
Negative!

Re: Kernel panic...

Posted: Sat May 30, 2015 11:07 am
by Fred Barclay
I don't have Mint at the moment, but did you either look under "older versions on Mint" or "additional options" on the GRUB menu for 3.13? Like I said, I don't have Mint now, so my wording might be a bit off, but look for something along these lines. (The default "Linux Mint" grub entry will boot from the newest kernel, I believe.) If you didn't remove 3.13 from within Update Manager, or via terminal, you should still have it.

Oh, and @Pjotr: Marclay?! MARclay?! Seriously?? :lol:

Re: Kernel panic...

Posted: Sat May 30, 2015 11:25 am
by Laurent85
vito_spatafore wrote:first thx 4 the feedback...
my /etc/fstab

Code: Select all

 /etc/fstab: static file system information.
/dev/sda3		/		ext4		noatime		0 1
/dev/sda4		/		xfs		noatime		0 1
Your fstab is broken, there is two root partitions !?

Re: Kernel panic...

Posted: Sat May 30, 2015 12:08 pm
by Pjotr
Fred Barclay wrote:Oh, and @Pjotr: Marclay?! MARclay?! Seriously?? :lol:
:P

Re: Kernel panic...

Posted: Sat May 30, 2015 1:26 pm
by Fred Barclay
Marclay made me mash my M&M's, boo hoo...