[Solved] No suspend after Cinnamon update

Questions about hardware and drivers
Forum rules
Before you post please read how to get help
mramish
Level 1
Level 1
Posts: 4
Joined: Wed Jun 03, 2015 12:38 pm

[Solved] No suspend after Cinnamon update

Postby mramish » Wed Jun 03, 2015 12:44 pm

After yesterdays update to cinnamon 2.6 the options to suspend the system are no longer available. Closing the lid also doesnt have any effect. System is a Lenovo T510 with Nvidia Graphics (prop. driver).
Any ideas ?
Last edited by mramish on Mon Jun 08, 2015 1:46 pm, edited 1 time in total.

User avatar
killer de bug
Level 14
Level 14
Posts: 5313
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: No suspend after Cinnamon update

Postby killer de bug » Wed Jun 03, 2015 1:52 pm

Here is the solution:
You no longer need to recompile Cinnamon to choose between consolekit and logind support. This is done in gsettings and you can decide which relevant Cinnamon components use which session/power-management backend:

Set org.cinnamon.desktop.session session-manager-uses-logind to true to make Cinnamon rely on logind to restart/shutdown/suspend/hibernate the computer from the shutdown dialog, or to false to restart/shutdown the computer via consolekit and suspend/hibernate via upower.
Set org.cinnamon.desktop.session settings-daemon-uses-logind in a similar fashion to control suspending/hibernating on idle or via multimedia keys.
Set org.cinnamon.desktop.session screensaver-uses-logind to true to make the screensaver listen to logind, or to false to make it listen to consolekit.

http://segfault.linuxmint.com/2015/06/cinnamon-2-6/

Said otherwise, here is the solution:

Code: Select all

gsettings set org.cinnamon.desktop.session settings-daemon-uses-logind true

Code: Select all

gsettings set org.cinnamon.desktop.session session-manager-uses-logind true

Code: Select all

gsettings set org.cinnamon.desktop.session screensaver-uses-logind false

And reboot
Image
If it ain't broke, fix it until it is.

BeaverPaw
Level 1
Level 1
Posts: 4
Joined: Wed Jun 03, 2015 2:20 pm

Re: No suspend after Cinnamon update

Postby BeaverPaw » Thu Jun 04, 2015 10:29 am

I actually found that I had to set "org.cinnamon.desktop.session screensaver-uses-logind" to TRUE to properly suspend on laptop lid close and from the power button pop-up menu.

User avatar
killer de bug
Level 14
Level 14
Posts: 5313
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: No suspend after Cinnamon update

Postby killer de bug » Thu Jun 04, 2015 11:08 am

You have MDM and systemd?
Image
If it ain't broke, fix it until it is.

mramish
Level 1
Level 1
Posts: 4
Joined: Wed Jun 03, 2015 12:38 pm

Re: No suspend after Cinnamon update

Postby mramish » Mon Jun 08, 2015 1:45 pm

Sorry for the late reply but the suggestion above was right. Problem solved. Thx

mideal
Level 2
Level 2
Posts: 78
Joined: Fri Jan 18, 2013 10:28 am
Location: Germany - Wilhelmshaven & Frankfurt
Contact:

Re: [Solved] No suspend after Cinnamon update

Postby mideal » Wed Jun 07, 2017 4:20 am

The setting

Code: Select all

gsettings set org.cinnamon.desktop.session screensaver-uses-logind false


is the one that even makes Linux Mint (18.1) Cinnamon (3.2.7) show the hibernation option again after wake-up. (The other two were already set to true here.)

Thanks!
Yoga 16GB/1TB running Mint 18.2 Cinnamon 64Bit
__________________________
…trust me - I’m the sunscreen.


Return to “Hardware Support”