Scanner not working after LMDE2 upgrade [SOLVED]

Questions about hardware and drivers
Forum rules
Before you post please read how to get help
Post Reply
User avatar
xfrank
Level 5
Level 5
Posts: 597
Joined: Sat Nov 24, 2012 6:09 pm
Location: Mexico City
Contact:

Scanner not working after LMDE2 upgrade [SOLVED]

Post by xfrank » Thu Jun 04, 2015 9:47 am

Just a minor bug after upgrade. I have a Brother mfc-scanner (mfc-j270w). After upgrading to LMDE2 it wasn't working anymore, either with Simplescan or Xsane, or whatever software. When attempting to scan, an error message appeared and then, nothing. But if Xsane was launched from the terminal as root, the scanner worked!
Well, after investigating around the forums, I've found the solution. Was a permission error:
http://askubuntu.com/questions/389636/i ... an2-driver
http://ubuntuforums.org/showthread.php?t=1565846

just open the terminal, see the output of lsusb, here see the path of your Brother device, and then do a chmod, for example:

Code: Select all

$ sudo chmod 666 /dev/bus/usb/003/002
or

Code: Select all

$ sudo chmod a+w /dev/bus/usb/003/002
if the scanner is in 003 / 002

Well, solved. :)
Linux everywhere. Active Distros in my many computers: LM17.3 (Cinnamon, Xfce); LM18.1 (Cinnamon,Xfce); LMDE 2 (Mate), MXLinux (Xfce), Debian 9 (Xfce).

Post Reply

Return to “Hardware Support”