Switch back to internal display not working after suspend

Questions about hardware and drivers
Forum rules
Before you post please read how to get help
dpat
Level 1
Level 1
Posts: 5
Joined: Tue Jun 24, 2014 6:53 am

Switch back to internal display not working after suspend

Postby dpat » Fri Jul 24, 2015 6:45 am

Hi,

The problem: the display does not switch back from external (HDMI1) to internal display (LVDS1) when the external display is unplugged while the notebook is in suspend.

Details:

System info:
- Notebook model: Lenovo X230
- OS: LMDE 2 Cinnamon 64 bit
- Cinnamon Version: 2.6.13
- Linux Kernel: 3.16.0-4-amd64
- Processor: Intel Core i7-3520M @ 2.90 Ghz
- Graphics card: Intel Corporation 3rd Gen Core processor Graphics Controller

I have a Samsung monitor connected to the notebook with a HDMI-to-MiniDisplayPort-Adapter (by LogiLink). I did set the external display to primary and turned off the internal laptop display.

My xrandr output while the external monitor is connected (and the internal monitor is blank)

Code: Select all

% xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
LVDS1 connected (normal left inverted right x axis y axis)
   1366x768      60.02 +
   1360x768      59.80    59.96 
   1024x768      60.00 
   800x600       60.32    56.25 
   640x480       59.94 
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 531mm x 299mm
   1920x1080     60.00*+  50.00    59.94    30.00    25.00    24.00    29.97    23.98 
   1920x1080i    60.00    50.00    59.94 
   1680x1050     59.88 
   1280x1024     75.02    60.02 
   1440x900      74.98    59.90 
   1280x960      60.00 
   1360x768      60.02 
   1280x800      59.91 
   1152x864      75.00 
   1280x720      60.00    50.00    59.94 
   1024x768      75.08    70.07    60.00 
   832x624       74.55 
   800x600       72.19    75.00    60.32    56.25 
   720x576       50.00 
   720x480       60.00    59.94 
   640x480       75.00    72.81    66.67    60.00    59.94 
   720x400       70.08 
DP1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
HDMI3 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
DP3 disconnected (normal left inverted right x axis y axis)


If I then suspend my notebook, unplug the external display, turn on the notebook again, the display stays blank... I have to replug the external display and unplug afterwards (that means: switching back to the internal display while the notebook is running works). It used to work perfectly with LMDE1. Did anyone experience the same problem or even has a solution for that problem?

Thank you for any hints!

Regards,
- Darsha

dpat
Level 1
Level 1
Posts: 5
Joined: Tue Jun 24, 2014 6:53 am

Re: Switch back to internal display not working after suspend

Postby dpat » Sun Mar 19, 2017 11:30 am

It seems that the brightness of the internal display is zero.

Increasing the brightness seems to solve the problem.


Return to “Hardware Support”