Proprietary Nvidia Drvier

Questions about hardware and drivers
Forum rules
Before you post please read how to get help
uncleguido
Level 1
Level 1
Posts: 37
Joined: Wed Dec 26, 2012 4:29 pm

Proprietary Nvidia Drvier

Postby uncleguido » Sat Sep 03, 2016 7:39 pm

I've been researching the forums and tutorials and see so many ways to install the proprietary nvidia drivers.
Can someone recommend the easiest and preferred way of installing latest drivers for LMDE2 from nvidia?

Will these drivers need to be updated as updates roll-out?

Thanks
Last edited by xenopeek on Sun Sep 04, 2016 12:34 am, edited 1 time in total.
Reason: moved to LMDE forums

User avatar
Kilwillie
Level 1
Level 1
Posts: 22
Joined: Sat Sep 03, 2016 6:47 pm

Re: Proprietary Nvidia Drvier

Postby Kilwillie » Sat Sep 03, 2016 8:01 pm

I followed the method outlined here for the 352.79 drivers from jessie-backports:

https://wiki.debian.org/NvidiaGraphicsDrivers
Image

User avatar
killer de bug
Level 14
Level 14
Posts: 5313
Joined: Tue Jul 08, 2008 1:49 pm
Location: Graz, Austria

Re: Proprietary Nvidia Drvier

Postby killer de bug » Sun Sep 04, 2016 4:06 am

Here is a nice detailed installation guide:
viewtopic.php?f=191&t=82424#p478177
Image
If it ain't broke, fix it until it is.

uncleguido
Level 1
Level 1
Posts: 37
Joined: Wed Dec 26, 2012 4:29 pm

Re: Proprietary Nvidia Drvier

Postby uncleguido » Sun Sep 04, 2016 8:06 am

So, I have a Nvidia GTX 980 Ti video card and I decided to go ahead and download the latest driver from nvidia and install that because I was impatient. So everything went smooth and was happy with the install. It asked to use dkms incase I want to update kernel and it ran nvidia-xconfig automatically. I rebooted and everything was working perfect. I had my 1920x1200 resolution for my monitor setup correct. So, I shutdown for the night and when I booted up this morning my resolution is 640x480. My xorg.conf file is using the nvidia driver but I have no resolutions settings under "Screen" section.

How can I get my resolution back?

Code: Select all

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 367.44  (buildmeister@swio-display-x86-rhel47-01)  Wed Aug 17 22:54:35 PDT 2016


Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

kevinthefixer
Level 4
Level 4
Posts: 242
Joined: Thu Jul 23, 2015 10:36 pm

Re: Proprietary Nvidia Drvier

Postby kevinthefixer » Tue Sep 20, 2016 10:18 pm

Try running nvidia-xconfig again in terminal. Also install nvidia-settings, see if you have those settings available in the GUI.

The problem seems to be that the driver can't ID the monitor properly. I had the exact same symptoms after running nvidia-xconfig while connected to a cheap projector; I simply hooked up to a decent monitor, ran nvidia-xconfig again, rebooted, opened nvidia-settings and made a few tweaks, saved those tweaks (there's a handy button), shut down and hooked back up to the projector--fixed!


Return to “Hardware Support”