TLP public key doesn't work

Questions about hardware and drivers
Forum rules
Before you post please read how to get help

LMDE 2 support ends on 1-1-2019
Post Reply
Level 1
Level 1
Posts: 2
Joined: Sun Jan 08, 2017 2:42 pm

TLP public key doesn't work

Post by mintesugar » Sun Jan 08, 2017 2:51 pm

Hello everybody,

I have a Leonovo Yoga Thinkpad 12 with LMDE2. I've tried to install TLP for better battery usage following the instructions from: ... ement.html

So I've added the TLP repository but when i tried to add the public key the answer was this:

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --homedir /tmp/tmp.Vbcp0H9k7b --no-auto-check-trustdb --trust-model always --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyring /etc/apt/trusted.gpg.d/deb-multimedia-keyring.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-jessie-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-jessie-security-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-jessie-stable.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-squeeze-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-squeeze-stable.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-automatic.gpg --keyring /etc/apt/trusted.gpg.d/debian-archive-wheezy-stable.gpg --keyserver --recv-keys 641EED65CD4E8809
gpg: requesting key CD4E8809 from hkp server
gpg: no writable keyring found: eof
gpg: error reading `[stream]': general error
gpg: Total number processed: 0

I've tried to contact the TLP help and they answered me that seems a problem with my apt keyring.

Anybody can help me???

Thanks for any advice


User avatar
Fred Barclay
Level 12
Level 12
Posts: 4189
Joined: Sat Sep 13, 2014 11:12 am
Location: Bumping around in the bush

Re: TLP public key doesn't work

Post by Fred Barclay » Mon Jan 09, 2017 3:35 pm

Hi, can you run the following commands in a terminal and post the output here?

Code: Select all

inxi -Fxz
inxi -r
sudo apt-key list
"Once you can accept the universe as matter expanding into nothing that is something, wearing stripes with plaid comes easy."
- Albert Einstein

Level 4
Level 4
Posts: 278
Joined: Thu Jul 23, 2015 10:36 pm

Re: TLP public key doesn't work

Post by kevinthefixer » Tue Jan 10, 2017 2:56 pm

Were you following the Debian instructions? It shows how to install the key. Did you type it in manually or copy/paste?

Level 1
Level 1
Posts: 2
Joined: Sun Jan 08, 2017 2:42 pm

Re: TLP public key doesn't work

Post by mintesugar » Mon Feb 13, 2017 4:18 am

Hi everybody,

for Fred this is the output

inxi -Fxz
System: Host: bombathink Kernel: 3.16.0-4-amd64 x86_64 (64 bit gcc: 4.8.4)
Desktop: MATE 1.16.1 (Gtk 3.14.5+4) Distro: LinuxMint 2 betsy
Machine: System: LENOVO product: 20DLCTO1WW v: ThinkPad S1 Yoga 12
Mobo: LENOVO model: 20DLCTO1WW v: SDK0E50510 WIN
Bios: LENOVO v: JEET74WW (1.23 ) date: 07/15/2016
CPU: Dual core Intel Core i7-5500U (-HT-MCP-) cache: 4096 KB
flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 9577
Clock Speeds: 1: 2400 MHz 2: 2638 MHz 3: 2401 MHz 4: 2404 MHz
Graphics: Card: Intel Broadwell-U Integrated Graphics bus-ID: 00:02.0
Display Server: X.Org 1.16.4 drivers: intel (unloaded: fbdev,vesa)
Resolution: 1920x1080@60.04hz
GLX Renderer: Gallium 0.4 on llvmpipe (LLVM 3.5, 256 bits)
GLX Version: 3.0 Mesa 10.3.2 Direct Rendering: Yes
Audio: Card-1 Intel Wildcat Point-LP High Definition Audio Controller
driver: snd_hda_intel bus-ID: 00:1b.0
Card-2 Intel Broadwell-U Audio Controller
driver: snd_hda_intel bus-ID: 00:03.0
Sound: Advanced Linux Sound Architecture v: k3.16.0-4-amd64
Network: Card: Intel Wireless 7265
driver: iwlwifi v: in-tree: bus-ID: 04:00.0
IF: wlan0 state: up mac: <filter>
Drives: HDD Total Size: 180.0GB (41.1% used)
ID-1: /dev/sda model: INTEL_SSDSC2BF18 size: 180.0GB
Partition: ID-1: / size: 159G used: 63G (42%) fs: ext4 dev: /dev/sda2
ID-2: swap-1 size: 7.52GB used: 0.00GB (0%) fs: swap dev: /dev/sda1
Sensors: System Temperatures: cpu: 47.0C mobo: N/A
Fan Speeds (in rpm): cpu: 257
Info: Processes: 193 Uptime: 6 min Memory: 1592.9/7671.2MB
Init: SysVinit runlevel: 2 Gcc sys: 4.9.2
Client: Shell (bash 4.3.301) inxi: 2.1.28

inxi -r
Repos: Active apt sources in file: /etc/apt/sources.list.d/official-package-repositories.list
deb betsy main upstream import
deb jessie main contrib non-free
deb jessie-updates main contrib non-free
deb jessie/updates main contrib non-free
deb jessie main non-free
deb betsy main
deb jessie main

sudo apt-key list
[sudo] password for nicola:
Sorry, try again.
[sudo] password for nicola:
pub 1024D/0FF405B2 2009-04-29
uid Clement Lefebvre (Linux Mint Package Repository v1) <>
sub 2048g/0F346519 2009-04-29

pub 4096R/65558117 2014-03-05
uid Christian Marillat <>
uid Christian Marillat <>
uid Christian Marillat <>
sub 4096R/B508B3D7 2014-03-05

pub 4096R/2B90D010 2014-11-21 [expires: 2022-11-19]
uid Debian Archive Automatic Signing Key (8/jessie) <>

pub 4096R/C857C906 2014-11-21 [expires: 2022-11-19]
uid Debian Security Archive Automatic Signing Key (8/jessie) <>

pub 4096R/518E17E1 2013-08-17 [expires: 2021-08-15]
uid Jessie Stable Release Key <>

pub 4096R/473041FA 2010-08-27 [expires: 2018-03-05]
uid Debian Archive Automatic Signing Key (6.0/squeeze) <>

pub 4096R/B98321F9 2010-08-07 [expires: 2017-08-05]
uid Squeeze Stable Release Key <>

pub 4096R/46925553 2012-04-27 [expires: 2020-04-25]
uid Debian Archive Automatic Signing Key (7.0/wheezy) <>

pub 4096R/65FFB764 2012-05-08 [expires: 2019-05-07]
uid Wheezy Stable Release Key <>

Kevinthefixer I copied/pasted from here: ... ement.html

Thanks everybody for your help :D


Post Reply

Return to “Hardware Support”