Webcam not recognized

Questions about hardware and drivers
Forum rules
Before you post please read how to get help
User avatar
dEhiN
Level 1
Level 1
Posts: 24
Joined: Tue Jul 14, 2015 9:48 am
Location: Toronto, Canada
Contact:

Webcam not recognized

Postby dEhiN » Wed Apr 19, 2017 5:12 am

Hi all, I recently put LMDE2 on a new machine - an HP Compaq Presario CQ42. Everything pretty much works great except for one thing: the camera. I first noticed it when trying to do a video call with Google Hangouts. Skype doesn't recognize it. I even tried Cheese, and it says no device found. It's the same when I try the site http://testwebcam.com/. Flash tells me there's no camera found.

I recently learned about /proc and the whole idea of everything is a file on Linux. Which means that while I'm not a newbie to Linux, I'm still more or less in the beginner stage when it comes to dealing with hardware issues in a distro. So does anyone have suggestions for how I can figure out the problem? Thanks all.
HP Compaq Presario CQ41: AMD Athlon II P340 Dual-Core @ 2.2GHz -- 4 GB DDR3 1066MHz -- LMDE 2 64-bit MATE (/dev/sda1 - 312GB - /; /dev/sda2 - 8GB - swap)

User avatar
richyrich
Level 18
Level 18
Posts: 8677
Joined: Mon May 04, 2009 8:31 pm

Re: Webcam not recognized

Postby richyrich » Wed Apr 19, 2017 8:14 am

Here are three terminal commands which may help in determining your camera hardware. Please copy the complete output of each and paste them here in a reply. :-)
lsusb
lspci

This one is to see a summary of your entire system:
inxi -Fxz

User avatar
dEhiN
Level 1
Level 1
Posts: 24
Joined: Tue Jul 14, 2015 9:48 am
Location: Toronto, Canada
Contact:

Re: Webcam not recognized

Postby dEhiN » Thu Apr 20, 2017 12:51 pm

richyrich wrote:Here are three terminal commands which may help in determining your camera hardware. Please copy the complete output of each and paste them here in a reply. :-)
lsusb
lspci

This one is to see a summary of your entire system:
inxi -Fxz

Thanks richyrich!

Here are the outputs:

Code: Select all

kooppi david # lsusb
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


Code: Select all

kooppi david # lspci
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] RS880 Host Bridge
00:01.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] RS780/RS880 PCI to PCI bridge (int gfx)
00:05.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] RS780/RS880 PCI to PCI bridge (PCIE port 1)
00:06.0 PCI bridge: Advanced Micro Devices, Inc. [AMD] RS780 PCI to PCI bridge (PCIE port 2)
00:11.0 SATA controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
00:12.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:12.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:13.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:13.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:14.0 SMBus: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 SMBus Controller (rev 41)
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)
00:14.3 ISA bridge: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 LPC host controller (rev 40)
00:14.4 PCI bridge: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 PCI to PCI Bridge (rev 40)
00:14.5 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI2 Controller
00:16.0 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
00:16.2 USB controller: Advanced Micro Devices, Inc. [AMD/ATI] SB7x0/SB8x0/SB9x0 USB EHCI Controller
00:18.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Address Map
00:18.2 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 10h Processor Link Control
01:05.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] RS880M [Mobility Radeon HD 4225/4250]
01:05.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] RS880 HDMI Audio [Radeon HD 4200 Series]
02:00.0 Network controller: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)


Code: Select all

kooppi david # inxi -Fxz
System:    Host: kooppi Kernel: 3.16.0-4-amd64 x86_64 (64 bit gcc: 4.8.4) Desktop: MATE 1.16.1 (Gtk 3.14.5+4)
           Distro: LinuxMint 2 betsy
Machine:   System: Hewlett-Packard product: Presario CQ42 Notebook PC v: 0594110000242810010020100
           Mobo: Hewlett-Packard model: 1444 v: 69.26 Bios: Hewlett-Packard v: F.17 date: 11/07/2010
CPU:       Dual core AMD Athlon II P340 (-MCP-) cache: 1024 KB flags: (lm nx sse sse2 sse3 sse4a svm) bmips: 8777
           Clock Speeds: 1: 800 MHz 2: 1600 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RS880M [Mobility Radeon HD 4225/4250] bus-ID: 01:05.0
           Display Server: X.org 1.16.4 drivers: ati,radeon (unloaded: fbdev,vesa)
           tty size: 168x46 Advanced Data: N/A for root
Audio:     Card-1 Advanced Micro Devices [AMD/ATI] RS880 HDMI Audio [Radeon HD 4200 Series]
           driver: snd_hda_intel bus-ID: 01:05.1
           Card-2 Advanced Micro Devices [AMD/ATI] SBx00 Azalia (Intel HDA) driver: snd_hda_intel bus-ID: 00:14.2
           Sound: Advanced Linux Sound Architecture v: k3.16.0-4-amd64
Network:   Card-1: Realtek RTL8101E/RTL8102E PCI Express Fast Ethernet controller
           driver: r8169 v: 2.3LK-NAPI port: 2000 bus-ID: 03:00.0
           IF: eth0 state: down mac: <filter>
           Card-2: Broadcom BCM4313 802.11bgn Wireless Network Adapter driver: wl bus-ID: 02:00.0
           IF: wlan0 state: up mac: <filter>
Drives:    HDD Total Size: 320.1GB (17.9% used) ID-1: /dev/sda model: WDC_WD3200BEVT size: 320.1GB temp: 45C
Partition: ID-1: / size: 286G used: 47G (18%) fs: ext4 dev: /dev/sda1
           ID-2: swap-1 size: 7.97GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors:   System Temperatures: cpu: 60.8C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 173 Uptime: 1:12 Memory: 2656.9/3707.3MB Init: SysVinit runlevel: 2 Gcc sys: 4.9.2
           Client: Shell (bash 4.3.301) inxi: 2.1.28
HP Compaq Presario CQ41: AMD Athlon II P340 Dual-Core @ 2.2GHz -- 4 GB DDR3 1066MHz -- LMDE 2 64-bit MATE (/dev/sda1 - 312GB - /; /dev/sda2 - 8GB - swap)

User avatar
richyrich
Level 18
Level 18
Posts: 8677
Joined: Mon May 04, 2009 8:31 pm

Re: Webcam not recognized

Postby richyrich » Thu Apr 20, 2017 2:34 pm

Nope ! :(

Not one is related to your webcam . . and what is not recognized . . :(

Thought: Is there a switch to turn the webcam on/off ?

If a switch is a definite no . .
Suggestion: Try a Live USB or DVD with Mint 18.1 to see if it is recognized.

DanielR
Level 4
Level 4
Posts: 222
Joined: Mon Sep 23, 2013 1:22 pm

Re: Webcam not recognized

Postby DanielR » Thu Apr 20, 2017 3:19 pm

I did a bit of research on the webcam of the Presario. It should have a USB interface. Therefore, lsusb should find it, provided it is switched on. As richyrich suggested, please check your manual for that laptop if there is either a switch or key combination to switch the camera on/off or if there is a BIOS setting for enabling/disabling the camera. There might however be a chance that the webcam hardware is a very striped down version which requires the proper driver (mostly Windows) to function at all. The modem board in my HP notebook is such a stripped down example. It will not work with any other OS than Windows.

User avatar
dEhiN
Level 1
Level 1
Posts: 24
Joined: Tue Jul 14, 2015 9:48 am
Location: Toronto, Canada
Contact:

Re: Webcam not recognized

Postby dEhiN » Thu Apr 20, 2017 4:23 pm

As far as I can tell there isn't a switch. But I'll do some digging, including trying the Live DVD of LM, and see what I can find. I'll report anything that might help back here. Thanks guys.
HP Compaq Presario CQ41: AMD Athlon II P340 Dual-Core @ 2.2GHz -- 4 GB DDR3 1066MHz -- LMDE 2 64-bit MATE (/dev/sda1 - 312GB - /; /dev/sda2 - 8GB - swap)


Return to “Hardware Support”