LMDE2 on a SSD, can't change scheduler to deadline

Questions about hardware and drivers
Level 3
Level 3
Posts: 164
Joined: Thu Jun 24, 2010 2:22 pm

LMDE2 on a SSD, can't change scheduler to deadline

Post by BrunoMiranda » Fri Apr 28, 2017 4:50 pm

Hi all,

I've put LMDE2 on a SSD. The SSD is recognized, as
/sys/block/sda/queue/rotational is reporting a '0'

Everything is fine except that I can't change scheduler to deadline at boot time.

If I type

Code: Select all

cat /sys/block/sda/queue/scheduler
I get this output:
noop deadline [cfq] bfq
(meaning cfq is enabled and deadline is not enabled but available)

If I run

Code: Select all

echo deadline >/sys/block/sda/queue/scheduler
as root, it will change the scheduler, as
cat /sys/block/sda/queue/scheduler will output
noop [deadline] cfq bfq
but after rebooting it will default back to
noop deadline [cfq] bfq
Note: If I run

Code: Select all

echo deadline >/sys/block/sda/queue/scheduler
as non-root or with sudo, I will get
bash: /sys/block/sda/queue/scheduler: Permission denied

If I add

Code: Select all

GRUB_CMDLINE_LINUX_DEFAULT="elevator=deadline quiet splash"
on /etc/default/grub and then run sudo update-grub, it still does not change the scheduler.

On /etc/rc.local I've added

Code: Select all

echo deadline >/sys/block/sda/queue/scheduler
echo 1 > /sys/block/sda/queue/iosched/fifo_batch
(above the exit 0)
and it still does nothing.

I've created a
having inside it

Code: Select all

# Set deadline scheduler for non-rotational disks
ACTION=="add|change", KERNEL=="sd[a-z]", TEST!="queue/rotational", ATTR{queue/scheduler}="deadline"
ACTION=="add|change", KERNEL=="sd[a-z]", ATTR{queue/rotational}=="0", ATTR{queue/scheduler}="deadline"
I've also tried

Code: Select all

sudo update-initramfs -u
But nothing has worked so far, after reboot, the system defaults back to bfq.

- I have not installed LMDE2 on this SSD from scratch. Instead, I've restored a backup (using fsarchiver) of this system while using a HDD;
- I'm using the Liquorix Kernel (4.10.0-11.1-liquorix-amd64). Could this have an impact on this issue?

I've ran out of options and ideas. Any hints, please? Thanks!
Bye for now,

(Always backup before you fvckup :mrgreen: )


Return to “Hardware Support”