[SOLVED] Printer driver needs old library

Questions about hardware and drivers
Forum rules
Before you post please read how to get help
dclement
Level 4
Level 4
Posts: 255
Joined: Thu Apr 19, 2012 9:59 am

[SOLVED] Printer driver needs old library

Postby dclement » Sun Jun 25, 2017 3:06 pm

Hello,

I had to reinstall an OS (LMDE2, fresh install, latest ISO) on my daughter's laptop.

We have a problem when it comes to set up her "old" Canon MFP495 printer. Canon provides a Linux driver as a .deb package, but it depends on libtiff4... LMDE2 has libtiff5 now!

So that stubborn driver won't install, and since my daughter lives near Paris I can't have both the printer and the laptop at hand. I can only test on a similar laptop and forward the results to my daughter.

So, any trick or insight would be very much appreciated. Thanks in advance, best regards - Daniel
Last edited by dclement on Mon Jun 26, 2017 6:06 am, edited 1 time in total.

Monsta
Level 9
Level 9
Posts: 2998
Joined: Fri Aug 19, 2011 3:46 am

Re: Printer driver needs old library

Postby Monsta » Mon Jun 26, 2017 4:50 am

You can get the package from Wheezy:
https://packages.debian.org/wheezy/libtiff4

It will require one more old lib:
https://packages.debian.org/wheezy/libjpeg8

dclement
Level 4
Level 4
Posts: 255
Joined: Thu Apr 19, 2012 9:59 am

Re: Printer driver needs old library

Postby dclement » Mon Jun 26, 2017 5:09 am

Thank you Monsta!
Monsta wrote:You can get the package from Wheezy:
https://packages.debian.org/wheezy/libtiff4
Yes, I had noticed this old package but...
It will require one more old lib:
https://packages.debian.org/wheezy/libjpeg8
... only one, this is perfectly fine! I had given up, wrongly assuming that libjipeg8 was just the first one of a veeery long list, as I had seen on other occasions. (The joy of proprietary drivers...)

Now I can forward my daughter these instructions, which are quite easy and harmless for her PC.

Thanks again - Daniel

Monsta
Level 9
Level 9
Posts: 2998
Joined: Fri Aug 19, 2011 3:46 am

Re: Printer driver needs old library

Postby Monsta » Mon Jun 26, 2017 5:10 am

That's what I saw at that page - I didn't actually try to install it; it might be that there's something more hidden :)

To play it safe, I would try it first in some local system, maybe even a VM.

dclement
Level 4
Level 4
Posts: 255
Joined: Thu Apr 19, 2012 9:59 am

Re: Printer driver needs old library

Postby dclement » Mon Jun 26, 2017 5:32 am

Damn, I spoke too fast.

libjpeg8 is already installed, and has a lot of pre-dependencies. It seems unreasonable to suppress it. I could force a downgrade with dpkg, but I bet the result wouldn't be very pretty.

OTTH, I saw another user somewhere else who claimed to have solved the problem by installing an even older libtiff4 (not the one in Wheezy - security). I've not been able to locate it. But then, I guess it was on an older install.

So, it's not looking as good as I first believed...

Monsta
Level 9
Level 9
Posts: 2998
Joined: Fri Aug 19, 2011 3:46 am

Re: Printer driver needs old library

Postby Monsta » Mon Jun 26, 2017 5:39 am

You can check older versions here:
http://snapshot.debian.org/binary/libtiff4/

dclement
Level 4
Level 4
Posts: 255
Joined: Thu Apr 19, 2012 9:59 am

Re: Printer driver needs old library

Postby dclement » Mon Jun 26, 2017 6:02 am

Monsta wrote:You can check older versions here:
http://snapshot.debian.org/binary/libtiff4/
Useful link, I'm bookmarking it!

Well after some trial and error the solution was called libtiff4 3.9.7-2. Slightly more recent version, and not older as I wrote. With this library installed, I was able go through the whole driver install, on a PC which is virtually the same as my daughter's.

I'd better give her detailed instructions...

Thanks again Monsta - I'm now trying to mark the thread solved


Return to “Hardware Support”