AMD RX550 UHD on LMDE?

Questions about hardware and drivers
Forum rules
Before you post please read how to get help

LMDE 2 support ends on 1-1-2019
Post Reply
Hansl
Level 2
Level 2
Posts: 91
Joined: Fri Dec 09, 2011 3:50 pm

AMD RX550 UHD on LMDE?

Post by Hansl » Wed Dec 20, 2017 4:03 pm

I've now gone and switched from my big old dual Eizo CAD screens on a NVIDIA GF119 [GeForce GT 610] to a large UHD 3840x2160 screen on an inexpensive Sapphire Radeon RX550 with Display Port. Using LMDE2 with Kernel: 4.9.0-0.bpo.2-amd64 from jessie-backports. My needs are hires CAD and office, no games or cinema.

After replacing the graphics Xorg did not come up at all. Installed from jessie-backports xserver-xorg-video-amdgpu and firmware-amd-graphics — still no Xorg. Finally remembered to delete my specially crafted xorg.conf — phew, Xorg and the Mint desktop came up. Unfortunately only with 1024x768 (and really big letters) on an “unknown screen”.

Code: Select all

$ inxi -G
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Device 67ff
           Display Server: X.Org 1.16.4 drivers: fbdev,ati (unloaded: vesa,radeon)
           Resolution: 1024x768@0.00hz
           GLX Renderer: N/A GLX Version: N/A 
What now? It appears the RX550 was a unlucky choice, is it too new for LMDE? Needs Debian 9 and Mesa 17.1? See
https://wiki.debian.org/AtiHowTo
https://www.heise.de/ct/artikel/Mesa-17 ... 06515.html (german)
Do I need to leave LMDE since it seems to lag behind, staying on Debian 8 / Jessie?

[Edit] For now, I removed the RX550 and used the onboard Intel CPU graphics — its HDMI should support 3840x2160 but with 24 Hz only. LMDE came up with 2560x1440 (well, way better than 1024x768) and I can't see how to switch to 3840x2160. Now:

Code: Select all

inxi -F
System:    Host: ibl4 Kernel: 4.9.0-0.bpo.2-amd64 x86_64 (64 bit) Desktop: MATE 1.18.0  Distro: LinuxMint 2 betsy 
Machine:   Mobo: MSI model: Z87-G43 (MS-7816) v: 1.0 Bios: American Megatrends v: V1.6 date: 11/27/2013
CPU:       Quad core Intel Core i5-4570 (-MCP-) cache: 6144 KB 
           Clock Speeds: 1: 800 MHz 2: 800 MHz 3: 800 MHz 4: 800 MHz
Graphics:  Card: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
           Display Server: X.org 1.16.4 drivers: fbdev,vesa,intel tty size: 132x43 Advanced Data: N/A for root
[Edit] It seems I would really need Mesa >= 17.1. Which is not yet on Debian 9:
https://packages.debian.org/search?keyw ... 1-mesa-glx
https://www.phoronix.com/scan.php?page= ... -First-Try

Would it be (reasonably) safe to install Mesa from Debian testing into LMDE?
The proprietary AMDGPU-Pro driver is said to be working, but is offered only for Ubuntu (and Red Hat and Suse):
http://support.amd.com/en-us/kb-article ... Notes.aspx
Would it be (reasonably) safe to install this into LMDE?

Hansl
Level 2
Level 2
Posts: 91
Joined: Fri Dec 09, 2011 3:50 pm

Re: AMD RX550 UHD on LMDE?

Post by Hansl » Fri Dec 29, 2017 10:26 am

Well, I've given up on the RX550 and bought an MSI GeForce GT 1030 2G LP OC.
Using the proprietary Nvidia driver via sgfxi, all is fine and running now.
Wanting to avoid those proprietary drivers was my reason for choosing the RX550 in the first place… sigh.

cm1
Level 1
Level 1
Posts: 35
Joined: Fri Mar 17, 2017 6:08 pm

Re: AMD RX550 UHD on LMDE?

Post by cm1 » Mon Apr 23, 2018 10:57 am

If you wanted to give it a try again, my post on the RX560 might help: viewtopic.php?f=239&t=266999

Hansl
Level 2
Level 2
Posts: 91
Joined: Fri Dec 09, 2011 3:50 pm

Re: AMD RX550 UHD on LMDE?

Post by Hansl » Wed Apr 25, 2018 4:10 pm

Wow.  19 steps including compiling a newer kernel… respect! Thank you, but I think I'll stay with my current Nvidia.
Mind you, only the RX550 seems to need Mesa >= 17.1 because of an oversight in the Radeon driver…

Post Reply

Return to “Hardware Support”