Touchpad doesn't work

Questions about hardware and drivers
Forum rules
Before you post please read how to get help

LMDE 2 support ends on 1-1-2019
Post Reply
cm1
Level 1
Level 1
Posts: 35
Joined: Fri Mar 17, 2017 6:08 pm

Touchpad doesn't work

Post by cm1 » Sat Feb 03, 2018 3:10 pm

My touchpad stopped working in LMDE2 the other day on my laptop. It was working fine one day, and then next day I booted up the laptop, it wasn't working. When I booted into Windows (laptop is configured for dual-boot), the touchpad works just fine.

I booted into the LMDE2 image/installer I had on my USB, and the touchpad worked fine while booted into it. I then wiped the LMDE partitions on the hard drive, reinstalled LMDE2 fresh from scratch & booted from the hard drive without touching or changing any settings. The touchpad is still not working!

A USB mouse plugged in works just fine. "Enable touchpad" is ON in the system settings control panel. The command:

Code: Select all

grep "Name=" /proc/bus/input/devices
doesn't list anything that looks like a touchpad.

This command returns nothing:

Code: Select all

egrep -i 'synap|alps|etps|elan' /proc/bus/input/devices
Pressing Fn-F7 (trackpad symbol with an X through it) doesn't do anything.

Any idea what might be going on and how I can fix this? Thanks in advance.

cm1
Level 1
Level 1
Posts: 35
Joined: Fri Mar 17, 2017 6:08 pm

Re: Touchpad doesn't work

Post by cm1 » Sat Feb 03, 2018 3:53 pm

I temporarily fixed it by going into Windows, rebooted into LMDE and the Trackpad started working again in LMDE2.
Last edited by cm1 on Mon Feb 12, 2018 7:00 pm, edited 1 time in total.

cm1
Level 1
Level 1
Posts: 35
Joined: Fri Mar 17, 2017 6:08 pm

Re: Touchpad doesn't work

Post by cm1 » Mon Feb 12, 2018 7:00 pm

I spoke too soon.

After booting into Windows, and rebooting into LMDE2 the trackpad works - for that boot. If I shut down, and start back up into LMDE2, the trackpad doesn't work. I'll need to boot again back into Windows to get it to work in LMDE2!

Anyone has any idea why this is happening, and how to permanently keep it working without having to boot into Windows?

Windows reports the trackpad device ID as: acpi\ven_etd&dev_0109 ... the trackpad works perfectly & consistently in Windows.

cm1
Level 1
Level 1
Posts: 35
Joined: Fri Mar 17, 2017 6:08 pm

Re: Touchpad doesn't work

Post by cm1 » Mon Feb 12, 2018 8:50 pm

Fixed it after reading: https://bugzilla.kernel.org/show_bug.cgi?id=81331

I added "i8042.kbdreset=1" to kernel parameters in /etc/default/grub

Post Reply

Return to “Hardware Support”