[Solved] monitor resolution problem with coffee lake

Questions about hardware and drivers
Forum rules
Before you post please read how to get help
Post Reply
chris99
Level 1
Level 1
Posts: 1
Joined: Mon Feb 26, 2018 4:53 pm

[Solved] monitor resolution problem with coffee lake

Post by chris99 » Mon Feb 26, 2018 5:38 pm

I have a new build with an I7-8700 on a Gigabyte Z370 HD3P board. It has essentially the same problem as detailed in: "Monitor resolution increase not allowed" see: viewtopic.php?f=59&t=260995&p=1410574&h ... t#p1410574 (in my case the default monitor resolution of 1024x768 is the ONLY one allowed). The solution for that problem was to install the 4.15.0-041500rc6-generic kernel. However, that solution was valid for the 'main edition' of mint, and my understanding is that LMDE Betsy2 is based on a different enough kernel that installing this 4.15 kernel would be a reckless idea, at least without more confirming information. The fix seems to be well understood as detailed in: viewtopic.php?f=59&t=260995&p=1410574&h ... t#p1410574 and is related to using the kernel flag: GRUB_CMDLINE_LINUX_DEFAULT="i915.alpha_support=1 quiet splash" which for the kernel I'm using: 3.16.0-5-amd64 #1 SMP Debian 3.16.51-3+deb8u1 (2018-01-08) x86_64 GNU/Linux has no effect (the actual fix activacted is probably much newer). In any case my question is will this fix for the on-board i7-8700 UHD graphics 630 be backported into a LMDE Betsy2 kernel any time soon? Is there a firmware patch already released as a .deb that I'm not aware of? I'd hate to buy a graphics card days ahead of a patch release. :) If anyone has ANY information about this, or has somehow found a hack around it I'd love to hear from you.
===================================
Finally figured this one out (lots of log file study and reading). The solution that works for me (I have simple graphics needs - obviously, as this is for motherboard graphics) is to force the use of the vesa driver by using Xorg. It had been some years since I had to look at Xorg, and it seems to have moved to the files at: /usr/share/X11/xorg.conf.d I found a good example of what I needed done at: https://wiki.archlinux.org/index.php/xorg about a third of the way down the page. The example file was named: /etc/X11/xorg.conf.d/10-monitor.conf (this is for archlinux). I changed the DefaultDepth (and Depth) from 16 to 24 and put in the resolution (only) that I needed by changing "1024x768_75.00" to "1600x1200". I now have the native resolution of my screen, without a graphics card or a new or revised kernel. I hope this will be of some help to interested readers who might be stuck at 1024x768.

Post Reply

Return to “Hardware Support”