Epson no longer found

Questions about hardware and drivers
Forum rules
Before you post please read how to get help
Post Reply
amphib
Level 1
Level 1
Posts: 43
Joined: Thu Jan 25, 2018 11:13 am

Epson no longer found

Post by amphib » Fri Apr 13, 2018 5:41 pm

My Mint18.3 machine stopped recognizing my network printer (Epson WF-3520). It still works fine from my wife's Win10 machine. I figured the Mint machine got dizzy or something so I deleted the epson from the printers and tried to add it back. Now my Mint18.3 machine cannot find the epson on my network at all. I tried reinstalling the linux debian driver from the epson site, but haven't had much luck doing that.
Help?

User avatar
AZgl1500
Level 6
Level 6
Posts: 1246
Joined: Thu Dec 31, 2015 3:20 am
Location: /Home/Desktop
Contact:

Re: Epson no longer found

Post by AZgl1500 » Fri Apr 13, 2018 7:13 pm

Have you installed the lastest Epson software release?
it was dated very recently, like in the last 4 or 5 weeks?

it totally solved my problems with Epson ET-2550 which could not be installed period before that new release of Linux drivers.

that driver covers every Epson printer they make

here is my thread on the topic

viewtopic.php?f=51&t=265873
Firefox / 4.13.0-41, Mint 18.3 Sylvia, Cinnamon 3.6.7

kevinthefixer
Level 4
Level 4
Posts: 266
Joined: Thu Jul 23, 2015 10:36 pm

Re: Epson no longer found

Post by kevinthefixer » Fri Apr 13, 2018 10:16 pm

And, uh, do you realize you're posting on the LMDE2 forum? Wrong place for LM18 questions. Hope you found your answer anyway!

User avatar
AZgl1500
Level 6
Level 6
Posts: 1246
Joined: Thu Dec 31, 2015 3:20 am
Location: /Home/Desktop
Contact:

Re: Epson no longer found

Post by AZgl1500 » Fri Apr 13, 2018 10:40 pm

kevinthefixer wrote:
Fri Apr 13, 2018 10:16 pm
And, uh, do you realize you're posting on the LMDE2 forum? Wrong place for LM18 questions. Hope you found your answer anyway!
the printer drivers from Epson are for Linux period, not just LM18...

I provided the links to where the drivers can be found, it is up to the user to download the correct version for his OS.
Firefox / 4.13.0-41, Mint 18.3 Sylvia, Cinnamon 3.6.7

Post Reply

Return to “Hardware Support”