Page 1 of 1

[solved] USB pen drives causing troubles, Nemo not working

Posted: Wed Jul 11, 2018 11:07 am
by roepel
Hi there

Im having trouble using my LMDE these days, main concern beeing nemo refusing to start up / work properly. After system start up everything's fine but after some time of usage, especially when using usb pen drives are connected, nemo doesn't start anymore. I even can acces my USB drives in the beginning, but, after some time something seems to prevent proper device read out or something.

I tried to work around and access the device via cd in the terminal. Even ls -l on /media/$USER freezes and even Ctrl+C doesnt help. Same with 'Disks' (gnome-disk-utility) - freeze after clicking on the (anyhow existing) entry of my usb pen drive.

Can anyone help me on that?

Code: Select all

System:    Host: minttu Kernel: 3.16.0-6-amd64 x86_64 (64 bit gcc: 4.9.2) 
           Desktop: Cinnamon 3.4.6 (Gtk 3.14.5+4) dm: mdm 
           Distro: LinuxMint 2 betsy
cheers roepel.

Re: [solved] USB pen drives causing troubles, Nemo not working

Posted: Mon Jul 23, 2018 7:07 am
by roepel
Figured out that the problem could be something like this: ... teruptible

I managed to get my pendrives and external HDD working again by overwriting the latter, making new (GPT) partition table and formatting it (NTFS) on another machine running on Debian 9. Could be that the main reason for my troubles was in fact the communication with the external HDD which is pluged in most of the time and regularily used in background for scheduled backups. During copying files to another drive before reformatting I also noticed some unreadable sectors/files.

Not sure if this helps for long but for now everything seems to be working.