No graphics acceleration on LMDE 2

Archived topics about LMDE 2
Locked
Vaden1970
Level 1
Level 1
Posts: 1
Joined: Sat Jul 28, 2018 9:21 am

No graphics acceleration on LMDE 2

Post by Vaden1970 » Sat Jul 28, 2018 9:29 am

Hello,

I just arrived on the forum because I tried to install LMDE 2 but I encounter difficulties

The trouble is that, since the installation by usb key, I have no graphics animations ...

It was like I was on LMDE 2 MATE while I'm on Cinnamon ...

I told myself that it was because I was doing a USB key installation and that after installation it will go but it does not matter ...

I do not know the error message I had at the top right but it was something like "The mode of rendering is in mode of emergency without graphic acceleration, that can be due to a pilot"

Yet my config is very recent as the PC

Processor: Intel® Core ™ i5-7200U CPU @ 2.50GHz × 4

Graphic Chipset: Intel® HD Graphics 620 (Kaby Lake GT2)

RAM: 4 GB

If anyone has a solution

User avatar
smurphos
Level 13
Level 13
Posts: 4785
Joined: Fri Sep 05, 2014 12:18 am
Location: Britisher
Contact:

Re: No graphics acceleration on LMDE 2

Post by smurphos » Sun Jul 29, 2018 3:45 am

I believe LMDE 2 ships with a 3.16 series kernel.

Your relatively new hardware requires kernel 4.10 or later.

LMDE 3 is imminent (Beta ISO's currently in testing) - I think (may be wrong) that will ship with kernel 4.9 - so still no good for your hardware.

Mint 19 (kernel 4.15) or 18.3 (kernel 4.10, upgradable to 4.15) should work out of the box.
For custom Nemo actions, useful scripts for the Cinnamon desktop, and Cinnamox themes visit my Github pages.

kevinthefixer
Level 4
Level 4
Posts: 278
Joined: Thu Jul 23, 2015 10:36 pm

Re: No graphics acceleration on LMDE 2

Post by kevinthefixer » Sun Jul 29, 2018 7:20 pm

Yes, Debian Stable is currently running 4.9.0.7. This can be worked around, but it's not a plug-n-play type thing.

Locked

Return to “LMDE 2 "Betsy" Archive”