[SOLVED] How can I tell LMDE2 to turn off the touchpad?

Questions about hardware and drivers
Locked
BrunoMiranda
Level 3
Level 3
Posts: 164
Joined: Thu Jun 24, 2010 2:22 pm

[SOLVED] How can I tell LMDE2 to turn off the touchpad?

Post by BrunoMiranda » Tue Dec 11, 2018 1:52 pm

I just can't get the touchpad do turn off. This is a bad one and it does more harm than good.

I've disabled everything in the touchpad controls on the Control Center, but all that is ignored and the touchpad is happilly getting itself on the way. :twisted:

I've seen this post regarding the same problem on LMDE3 but there's no help there. I'm about to put a sticker on top of the touchpad so it can't feel me.

viewtopic.php?f=247&t=277930


My question is, is there any way I can disable the touchpad? Terminal commands would be fine, as I could write something up to keep it disabled at boot time, and eventually when I need it I can run any other commands and after it kill it again.

Any suggestions, please? Thanks!
Last edited by BrunoMiranda on Wed Dec 12, 2018 5:35 pm, edited 1 time in total.
Bye for now,
Bruno


(Always backup before you fvckup :mrgreen: )

sleeper12
Level 5
Level 5
Posts: 909
Joined: Thu May 25, 2017 3:22 pm

Re: How can I tell LMDE2 to turn off the touchpad?

Post by sleeper12 » Tue Dec 11, 2018 4:42 pm

Try in terminal:

synclient TouchpadOff=1

Turn back on:

synclient TouchpadOff=0

BrunoMiranda
Level 3
Level 3
Posts: 164
Joined: Thu Jun 24, 2010 2:22 pm

Re: How can I tell LMDE2 to turn off the touchpad?

Post by BrunoMiranda » Wed Dec 12, 2018 5:35 pm

@sleeper12, thanks for your reply!

It doesn't work, but your help was enough for me to keep on pushing the string and find the end of it. I've done it!

Ok, so synclient doesn't work, with the output:

Code: Select all

synclient
Couldn't find synaptics properties. No synaptics driver loaded?
So I don't think this is a synaptic touchpad.


From:
https://wiki.debian.org/SynapticsTouchpad

(funny it skips Debian Jesse!)
Determining the type of Touchpad

The following command will tell you whether you have a Synaptics, ALPS or Elantech touchpad:

egrep -i 'synap|alps|etps|elan' /proc/bus/input/devices
it outputs nothing, so I believe none if the supported touchpads is detected.

Running

Code: Select all

cat /proc/bus/input/devices
outputs (among other irrelevant stuff)

Code: Select all

I: Bus=0011 Vendor=0002 Product=0006 Version=0000
N: Name="[b]ImExPS/2 Generic Explorer Mouse[/b]"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input6
U: Uniq=
H: Handlers=mouse0 event5 
B: PROP=1
B: EV=7
B: KEY=1f0000 0 0 0 0
B: REL=143
and HardInfo detects it as:

Code: Select all

Name: ImExPS/2 Generic Explorer Mouse
Type: Mouse
Bus: 0x11
Vendor: 2
Product: 0x6
Version: 0x0
Connected to: isa0060/serio/input0
(note I do not have any mouse connected to this computer)

Doing more research I find complaints about this touchpad from 2008... Yikes! :shock:

And from
https://ubuntuforums.org/showthread.php?t=2254023

it quotes:
The module used is psmouse, unloading it prevents the touchpad from working and loading it again makes the touchpad work.
and from here I've researched how to load and unload modules. Basically:

Code: Select all

sudo rmmod /lib/modules/4.9.0-0.bpo.6-amd64/kernel/drivers/input/mouse/psmouse.ko
will unload the psmouse kernel module, disabling the touchpad! :mrgreen:

and

Code: Select all

sudo insmod /lib/modules/4.9.0-0.bpo.6-amd64/kernel/drivers/input/mouse/psmouse.ko
will load the psmouse kernel module, re-enabling the touchpad! :mrgreen:

So now I've created some simple bash scripts to disable and enable the keypad, as well as some keyboard shortcut bindings. DONE! :D

So this thread is marked as solved!
Bye for now,
Bruno


(Always backup before you fvckup :mrgreen: )

sleeper12
Level 5
Level 5
Posts: 909
Joined: Thu May 25, 2017 3:22 pm

Re: [SOLVED] How can I tell LMDE2 to turn off the touchpad?

Post by sleeper12 » Wed Dec 12, 2018 10:30 pm

Wow, great detective work :!: Maybe that will help some others too. 8)

Locked

Return to “Hardware Support”