Wifi on Mac Mini 2008 LMDE2

Questions about networking
Locked
batteryjuice4
Level 1
Level 1
Posts: 1
Joined: Tue Feb 26, 2019 1:26 am

Wifi on Mac Mini 2008 LMDE2

Post by batteryjuice4 » Tue Feb 26, 2019 1:42 am

Hi, Y'all.
This is my first post, I believe. I have a 2008 mac mini that since Mac OS was broken and wouldn't boot, I installed LMDE2. Everything works but the wifi. I can use a wireless usb but it quits after a few minutes of inactivity and I have to disconnect and reconnect. I want to get the internal wifi working so I went searching and saw that late 2008 models need the firmware-b43-installer package. I installed it but still didn't have wifi after reboot. I then did "sudo modprobe -r wl" and "sudo modprobe b43" as listed in this page https://www.linuxquestions.org/question ... 175600634/
Now if I do that every time I reboot I have my 2 wifi access points shown under the networking applet, but when I click on one of them and put in my password, it seems to try it for a bit and then asks for the wifi password again. I know I am putting in the right passwords. I even copied the password from the usb wifi adapter's settings and pasted in. Thanks for any help you can give me. If I can't use wifi that is not so bad. The mac is just a Rosetta Stone box under Wine (which is why I am weary to upgrade to LMDE3).

EDIT: I attempted to upgrade to LMDE3 but had multiple problems. It kept stopping with errors part way through. I would fix those and it would give me more. Also, it said the nvidia driver would not be supported anymore and sound quit working as well. So I used Timeshift to go back a few hours to LMDE2 before I tried upgrading.

User avatar
CaptainKirksChair
Level 4
Level 4
Posts: 339
Joined: Sat Feb 18, 2017 9:29 pm

Re: Wifi on Mac Mini 2008 LMDE2

Post by CaptainKirksChair » Sun Mar 10, 2019 12:50 pm

Go into your network settings and disable IPv6. I cannot say this will work but on Mint 18.3 with an Atheros WiFi card, I had a similar problem to yours; it kept "connecting" and then asking for the password. I disabled IPv6 and it's been working fine. Right now, I'm on an iMac 9.1 running Mint 19.0 Cinnamon and I have not had to disable IPv6 but my hardware is newer than yours.

Locked

Return to “Networking”