[Solved]LMDE Ethernet connection drops after 5 minutes

Questions about networking
Forum rules
Before you post please read this
Post Reply
User avatar
alinoe
Level 1
Level 1
Posts: 6
Joined: Mon Sep 07, 2015 6:01 am

[Solved]LMDE Ethernet connection drops after 5 minutes

Post by alinoe » Sun Oct 11, 2015 9:37 am

Hello,

I have been running on LMDE betsy for few months
with a lenovo g580 2189 i3 laptop

atheros ar8162 is my ethernet card

I have been encountering a problem with my Ethernet connection for about two weeks now,
the connection works perfectly for about 5 minutes, sometimes less sometimes more,
and then it drops,
on firefox the new open pages stayed blank loading endlessly then resulting in "unable to find page
on chromium it says "DNS_PROBE_FINISHED_NO_INTERNET"

If i unplug my Ethernet cable
and then plug in again
it solves the problem, but only for 5 minutes or so


I tried to plug in another router and the problem stayed the same

If I connect through wifi though I have no problem
if I use Ethernet through window 7 (i have dual boot) then no problem



ping 8.8.8.8

Code: Select all

PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
]From 192.168.1.13 icmp_seq=1 Destination Host Unreachable

in normal situation

Code: Select all

64 bytes from 8.8.8.8: icmp_seq=1 ttl=55 time=39.8 ms
64 bytes from 8.8.8.8: icmp_seq=2 ttl=55 time=39.0 ms
64 bytes from 8.8.8.8: icmp_seq=3 ttl=55 time=39.2 ms
64 bytes from 8.8.8.8: icmp_seq=4 ttl=55 time=39.6 ms
64 bytes from 8.8.8.8: icmp_seq=5 ttl=55 time=40.2 ms
64 bytes from 8.8.8.8: icmp_seq=6 ttl=55 time=44.7 ms




sudo ifconfig -a (as the problem occured)

Code: Select all

eth0      Link encap:Ethernet  HWaddr dc:0e:a1:fc:02:83  
          inet adr:192.168.1.13  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::de0e:a1ff:fefc:283/64 Scope:Lien
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:123887 errors:774 dropped:0 overruns:774 frame:0
          TX packets:74347 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          RX bytes:175825568 (167.6 MiB)  TX bytes:6034726 (5.7 MiB)
          Interruption:16 

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:608 errors:0 dropped:0 overruns:0 frame:0
          TX packets:608 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0 
          RX bytes:70660 (69.0 KiB)  TX bytes:70660 (69.0 KiB)

wlan0     Link encap:Ethernet  HWaddr 08:ed:b9:97:ca:2b  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interruption:17

cat /etc/network/interfaces

Code: Select all

# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
source-directory /etc/network/interfaces.d


sudo cat /var/log/dmesg |grep -i eth (as the problem occured)

Code: Select all

[    2.672078] VGA switcheroo: detected Optimus DSM method \_SB_.PCI0.PEG0.PEGP handle
[    2.675162] alx 0000:03:00.0 eth0: Qualcomm Atheros AR816x/AR817x Ethernet [dc:0e:a1:fc:02:83]
[   11.311687] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   11.480806] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[   11.481736] alx 0000:03:00.0 eth0: NIC Up: 100 Mbps Full
[   11.482261] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready


lespci

Code: Select all

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:01.1 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation 7 Series/C210 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4)
00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4)
00:1d.0 USB controller: Intel Corporation 7 Series/C210 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM76 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 7 Series Chipset Family 6-port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 7 Series/C210 Series Chipset Family SMBus Controller (rev 04)
01:00.0 3D controller: NVIDIA Corporation GF117M [GeForce 610M/710M/820M / GT 620M/625M/630M/720M] (rev a1)
03:00.0 Ethernet controller: Qualcomm Atheros AR8162 Fast Ethernet (rev 08)
04:00.0 Network controller: Broadcom Corporation BCM4313 802.11bgn Wireless Network Adapter (rev 01)

Last edited by alinoe on Mon Oct 12, 2015 1:01 pm, edited 1 time in total.

User avatar
alinoe
Level 1
Level 1
Posts: 6
Joined: Mon Sep 07, 2015 6:01 am

Re: Ethernet connection drops after 5 minutes

Post by alinoe » Mon Oct 12, 2015 1:01 pm

I think I found out what was wrong

I just had to turn off the wifi on my computer
the wifi was activated but I was not connecter through wifi

so I don't know what was the conflict with my ethernet connection

je ne sais pas exactement ce qui entrait en conflit avec ma connexion via ethernet
le wifi était activé mais je n'étais connecté à aucun réseau via wifi

Post Reply

Return to “Networking”