Can't make WOL to work.

Questions about networking
Forum rules
Before you post please read this
jia_wei
Level 1
Level 1
Posts: 25
Joined: Thu Feb 20, 2014 4:53 pm

Can't make WOL to work.

Postby jia_wei » Mon Jan 18, 2016 7:21 pm

Hi,

I got a server with LMDE 2 installed and I need your help with the wake on lan of the integrated NIC. The motherboard is an Asrock QC5000 (integrated CPU), but supose that the important is the network model card: Realtek RTL8111/8168/8411. When I installed the OS, it came with the driver r8169. Reading the wiki of Arch, I changed it for r8168: https://wiki.archlinux.org/index.php/Ne ... OL_problem

Doing that, I was able to activate the WOL of the NIC, even keeping that change between reboots:

sudo ethtool eth0
Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised pause frame use: Symmetric Receive-only
Advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Supports Wake-on: pumbg
Wake-on: g
Current message level: 0x00000033 (51)
drv probe ifdown ifup
Link detected: yes


If I'm not wrong with this it should work. The problem is when I do poweroff or shutdown -h now, I realize that the LED on the NIC are both off, the card is not active to receive the magic packet. I checked the BIOS and everything is set correctly. I should also say that I never installed any other OS in this PC (not windows, not other Linux distribution).

I also read a thread where someone could solve it: http://forums.debian.net/viewtopic.php?f=10&t=123349 but to be sincere, I'm quite newbie and don't understand what he had done to get it working...

What am I doing wrong? I thinking that it could be when I turn off, that config is not saved, but that's at least strange because in every boot it has been set right... Any other information needed, please, just ask. Thank you very much for you time!!

Return to “Networking”