Page 1 of 1

Networkmanager not able to remember LAN password (802.1X)

Posted: Tue Mar 08, 2016 4:55 am
by Tomas_IV
Hello,
it is about a month back when my wired 802.1X network connection stopped to work (working for several years without any issue up to that time). It tried to connect, asked for password, and when supplied, asked it again after a while, and again, and again...
I tried everything, including removing and recreating the connection definition, with and without certificates (updated these). It was at work so then went to our IT dept. and they tried basically the same and found, that the connection works without issues, if you check the option to ask the password every time. After the month I am a little tired of supplying the password after every reboot, so I tried and it is still the same, means if I check the option to ask password every time, I am asked for the password and connected. If I uncheck it I am also asked the password (regardless if i store it in the connection settings or not), but not connected and asked the password again. Has anyone similar experience?
Tomas

Output of few commands (while connected, after trying unsuccessfully the connection with remembering the password once, then reverting back to ask it every time):

Code: Select all

$ uname -a
Linux uozp30 3.11-2-amd64 #1 SMP Debian 3.11.8-1 (2013-11-13) x86_64 GNU/Linux

$ ifconfig eth1
eth1      Link encap:Ethernet  HWadr 78:2b:cb:a0:a9:3a  
          inet adr:10.83.50.130  Všesměr:10.83.50.255 Maska:255.255.255.0
          inet6-adr: fe80::7a2b:cbff:fea0:a93a/64 Rozsah:Linka
          AKTIVOVÁNO VŠESMĚROVÉ_VYSÍLÁNÍ BĚŽÍ MULTICAST  MTU:1500  Metrika:1
          RX packets:10289 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7709 errors:0 dropped:0 overruns:0 carrier:0
          kolizí:0 délka odchozí fronty:1000 
          RX bytes:5751634 (5.4 MiB)  TX bytes:1266603 (1.2 MiB)
          Přerušení:20 Paměť:e1500000-e1520000

$ dmesg | egrep "(e1000e|eth)"
[    2.390922] e1000e: Intel(R) PRO/1000 Network Driver - 2.3.2-k
[    2.390924] e1000e: Copyright(c) 1999 - 2013 Intel Corporation.
[    2.391047] e1000e 0000:00:19.0: setting latency timer to 64
[    2.391099] e1000e 0000:00:19.0: Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode
[    2.391119] e1000e 0000:00:19.0: irq 42 for MSI/MSI-X
[    2.596646] e1000e 0000:00:19.0 eth0: registered PHC clock
[    2.596651] e1000e 0000:00:19.0 eth0: (PCI Express:2.5GT/s:Width x1) 78:2b:cb:a0:a9:3a
[    2.596660] e1000e 0000:00:19.0 eth0: Intel(R) PRO/1000 Network Connection
[    2.596691] e1000e 0000:00:19.0 eth0: MAC: 10, PHY: 11, PBA No: E041FF-0FF
[    7.700325] systemd-udevd[446]: renamed network interface eth0 to eth1
[   34.975236] e1000e 0000:00:19.0: irq 42 for MSI/MSI-X
[   35.078275] e1000e 0000:00:19.0: irq 42 for MSI/MSI-X
[   35.078497] IPv6: ADDRCONF(NETDEV_UP): eth1: link is not ready
[   61.342204] e1000e: eth1 NIC Link is Up 100 Mbps Full Duplex, Flow Control: Rx/Tx
[   61.342212] e1000e 0000:00:19.0 eth1: 10/100 speed: disabling TSO
[   61.342247] IPv6: ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready

$ lsmod | grep e1000e 
e1000e                190982  0 
ptp                    17460  1 e1000e

Re: Networkmanager not able to remember LAN password (802.1X)

Posted: Tue Mar 08, 2016 4:26 pm
by Zill
Tomas_IV: I suggest you could try this to see if it helps...

Right-click on the NM applet and then select "Edit Connections" from the menu.
Select Ethernet > Wired connection 1.
Click on the "Edit" button and then select the General tab.
Select the following two checkboxes:
"Automatically connect to this network when it is available"
"All users may connect to this network"
Hit the "Save" button then close the NM editing screen.
NM.png
Reboot and Login again and see if the password is still being requested.

If the above works correctly then you may be able to deselect the "Use 802.1X security for this connection" checkbox in the "802.1x Security" tab. This is because wired (ethernet) connections often work by default without any security settings.

Re: Networkmanager not able to remember LAN password (802.1X)

Posted: Wed Mar 16, 2016 3:31 am
by Tomas_IV
Thanks for the suggestion, but I have the settings exactly as you recommend already. And no, LAN connection without 802.1X authentication is not possible in our network.

Re: Networkmanager not able to remember LAN password (802.1X)

Posted: Wed Mar 16, 2016 7:36 am
by Zill
The following three Ubuntu bugs may be relevant to this problem: Bug #1173152 seems to have a couple of workarounds in Comments #12 and #19 that may be helpful.

Re: Networkmanager not able to remember LAN password (802.1X)

Posted: Sat Mar 19, 2016 11:18 am
by JeremyB
Is package gnome-keyring installed?