networking restart problem

Questions about networking
Forum rules
Before you post please read this
Post Reply
PepperMint
Level 1
Level 1
Posts: 5
Joined: Fri May 08, 2009 8:35 am

networking restart problem

Post by PepperMint » Tue Aug 09, 2016 6:48 am

Hello,
I've modified my interface configuration and when i try to restart my network i've an error

service networking restart :

Code: Select all

[....] Running /etc/init.d/networking restart is deprecated because it may not r[warnble some interfaces ... (warning).
[....] Reconfiguring network interfaces.../etc/network//run: Is a directory
/etc/network//run: Is a directory
.
.
.
/etc/network//run: Is a directory
ifdown: failed to open statefile /run/network/ifstate: Too many open files
/etc/network//run: Is a directory
.
.
.
/etc/network//run: Is a directory
/bin/sh: 0: 3: Too many open files
run-parts: /etc/network/if-pre-up.d/wireless-tools exited with return code 2
ifup: pre-up script failed.
failed.

interfaces file:

Code: Select all

# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
source-directory/etc/network/interfaces.d
allow-hotplug eth0
iface eth0 inet static
address 192.168.1.6
# network 192.168.1.0
netmask 255.255.255.0
broadcast 192.168.1.255
gateway 192.168.1.1
dns-nameservers 8.8.8.8 8.8.4.4
inxi -Fxzd:

Code: Select all

System:    Host: samsung-lmde Kernel: 3.16.0-4-686-pae i686 (32 bit gcc: 4.8.4)
           Console: tty 1 Distro: LinuxMint 2 betsy
Machine:   Mobo: SAMSUNG model: NF110/NF210/NF310
           Bios: Phoenix v: 02MY.M019.20101004.JIP date: 10/04/2010
CPU:       Dual core Intel Atom N550 (-HT-MCP-) cache: 512 KB
           flags: (lm nx pae sse sse2 sse3 ssse3) bmips: 5985
           Clock Speeds: 1: 1000 MHz 2: 1000 MHz 3: 1500 MHz 4: 1500 MHz
Graphics:  Card: Intel Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller
           bus-ID: 00:02.0
           Display Server: X.org 1.16.4 drivers: intel (unloaded: fbdev,vesa)
           tty size: 80x24 Advanced Data: N/A for root out of X
Audio:     Card Intel NM10/ICH7 Family High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Sound: Advanced Linux Sound Architecture v: k3.16.0-4-686-pae
Network:   Card-1: Broadcom BCM4313 802.11bgn Wireless Network Adapter
           driver: wl bus-ID: 05:00.0
           IF: wlan0 state: down mac: <filter>
           Card-2: Marvell 88E8040 PCI-E Fast Ethernet Controller
           driver: sky2 v: 1.30 port: 2000 bus-ID: 09:00.0
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:    HDD Total Size: 750.2GB (72.4% used)
           ID-1: /dev/sda model: Hitachi_HTS54322 size: 250.1GB temp: 35C
           ID-2: USB /dev/sdc model: StorE_HDD size: 500.1GB temp: 0C
           Optical: No optical drives detected.
Partition: ID-1: / size: 24G used: 7.8G (35%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 202G used: 153G (80%) fs: ext4 dev: /dev/sda6
           ID-3: swap-1 size: 4.19GB used: 0.04GB (1%) fs: swap dev: /dev/sda5
Sensors:   System Temperatures: cpu: 47.0C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 129 Uptime: 64 days Memory: 355.1/2013.3MB
           Init: SysVinit runlevel: 5 Gcc sys: 4.9.2
           Client: Shell (bash 4.3.301) inxi: 2.1.28

Post Reply

Return to “Networking”