BCM4331 randomly disconnects

Questions about networking
Forum rules
Before you post please read this
Post Reply
cm1
Level 1
Level 1
Posts: 33
Joined: Fri Mar 17, 2017 6:08 pm

BCM4331 randomly disconnects

Post by cm1 » Sun Mar 19, 2017 1:34 am

Hi,

I'm running LMDE 2 Cinnamon, fully updated with kernel 3.16.39-1+deb8u2, on an Apple Mac Mini (late 2012) with its integrated BCM4331 wifi .... the command "lspci -vnn -d 14e4:" shows:

Code: Select all

02:00.0 Network controller [0280]: Broadcom Corporation BCM4331 802.11a/b/g/n [14e4:4331] (rev 02)
	Subsystem: Apple Inc. AirPort Extreme [106b:010e]
	Flags: bus master, fast devsel, latency 0, IRQ 17
	Memory at a0600000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: wl
So it's using the wl driver. Unfortunately, maybe 5-10 times a day, I would lose network connectivity. The wifi icon (Network Manager applet) then shows my connection strength to my wifi as 100%. Eventually, maybe a minute later, the network connectivity returns to normal and the connection strength icon & applet returns to a more normal percentage, like 65%.

I was wondering if anyone had a fix for this, or if this is simply an issue with the wl kernel driver? I installed firmware-b43-installer in an attempt to use the b43 driver instead (since it's supposed to be fully compatible with the BCM4331: http://linuxwireless.org/en/users/Drive ... ed_devices), but b43 doesn't seem to work properly.

I unload wl with "modprobe -r wl" and then load b43 with "modprobe b43"; the Network Manager applet shows that it detects my wifi and looks like it's trying to connect to it, but after a minute or two, fails. dmesg shows the kernel buffer recorded the following error (using the b43 driver):

Code: Select all

wlan0: aborting authentication with [MAC Address] by local choice (Reason: 3=DEAUTH_LEAVING)
I've also tried tweaking the txpower with iwconfig, with no noticeable effect, with the wl driver.

Can anyone help me with either fixing my issues with the BCM4331, wl, or with getting b43 to work? Thanks.

kevinthefixer
Level 4
Level 4
Posts: 266
Joined: Thu Jul 23, 2015 10:36 pm

Re: BCM4331 randomly disconnects

Post by kevinthefixer » Sun Mar 19, 2017 10:08 am

First thing to try is rebooting your router. Might examine the router settings also. Amazing how often that simple thing fixes oddball problems like this, especially when all other devices seem to work fine.

cm1
Level 1
Level 1
Posts: 33
Joined: Fri Mar 17, 2017 6:08 pm

Re: BCM4331 randomly disconnects

Post by cm1 » Sun Mar 19, 2017 11:32 am

kevinthefixer wrote:First thing to try is rebooting your router. Might examine the router settings also. Amazing how often that simple thing fixes oddball problems like this, especially when all other devices seem to work fine.
Router's fine and I've rebooted it multiple times; the mac continues to experience interruptions, no other device has a problem. When I reboot the mac into Mac OS X, it maintains a stable wifi connection, so it seems the problem is with LMDE or the drivers.

cm1
Level 1
Level 1
Posts: 33
Joined: Fri Mar 17, 2017 6:08 pm

Re: BCM4331 randomly disconnects

Post by cm1 » Mon Mar 27, 2017 4:03 pm

Wifi is stable on the Mac Mini & LMDE 2 when I drop the connection down to 802.11b on the router.

Setting the router to b+g or b+g+n causes it to randomly disconnect. Again, the connection is stable on the same Mac while in Mac OS X, with the router set to b+g or b+g+n.

JeremyB
Level 18
Level 18
Posts: 8280
Joined: Fri Feb 21, 2014 8:17 am

Re: BCM4331 randomly disconnects

Post by JeremyB » Mon Mar 27, 2017 4:46 pm

You might have better luck uninstalling the proprietary driver and install the b43 firmware but I am not sure exactly how to do that in LMDE but I am fairly sure you have to enable the non-free repository

cm1
Level 1
Level 1
Posts: 33
Joined: Fri Mar 17, 2017 6:08 pm

Re: BCM4331 randomly disconnects

Post by cm1 » Tue Apr 04, 2017 1:45 am

Looks like this problem has been going on with Debian and Debian-based distros and the BCM4331, at least since 2014!:

http://crunchbang.org/forums/viewtopic.php?id=35128

B43 doesn't work for me, as described in that thread too.

I can't find an answer anywhere.

ZMachine
Level 1
Level 1
Posts: 1
Joined: Sun Aug 06, 2017 6:51 pm

Re: BCM4331 randomly disconnects

Post by ZMachine » Sun Aug 06, 2017 6:56 pm

This is very comprehensive and helped me. I've been grappling with this problem for months :lol:
https://askubuntu.com/a/60395/433592

Post Reply

Return to “Networking”