LAN Problem, have IP addr but cannot ping 'internet'

Questions about networking
Forum rules
Before you post please read this

LMDE 2 support ends on 1-1-2019
Post Reply
jakeo25
Level 1
Level 1
Posts: 6
Joined: Thu Nov 20, 2014 11:10 pm
Location: Boulder, CO

LAN Problem, have IP addr but cannot ping 'internet'

Post by jakeo25 » Tue May 30, 2017 10:57 am

Hello folks. Can I get some help with LAN diagnostics?

This happens now and then. At first I thought something got messed with Linux Mint install, so I reinstalled. But same problem returned.

General symptoms:

1 Unable to surf internet, unable to access network shares.

2) I can fire up a VPN client (Torguard), and then ping/tracert/surf etc on outside internet only. Firefox works, etc. Still cannot access any local network shares.

3) I can access my router, but nothing on local internet (printers, windows shares)

4) Sometimes this is fixed with a reboot.

Background info:

Wired connection, IP address obtained from router, DHCP. Can also use fixed IP, same problem.

Ethernet connectors replaced.

Tried different ports on router (D-link DIR-632)

Other Windows (wired) and Android devices (wireless) can access internet and network with no problem.

$ lsb_release -a
No LSB modules are available.
Distributor ID: LinuxMint
Description: LMDE 2 Betsy
Release: 2
Codename: betsy

$ uname -a
Linux 3.16.0-4-amd64 #1 SMP Debian 3.16.43-2 (2017-04-30) x86_64 GNU/Linux

$ ifconfig eth0

eth0 Link encap:Ethernet HWaddr 00:1c:c0:61:55:33
inet addr:192.168.0.106 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::21c:c0ff:fe61:5533/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:94132 errors:0 dropped:0 overruns:0 frame:0
TX packets:53113 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:73969460 (70.5 MiB) TX bytes:10182015 (9.7 MiB)
Interrupt:20 Memory:e0300000-e0320000

If any of you can suggest steps, commands to run, I'll post outputs here in followup threads
Last edited by WharfRat on Tue May 30, 2017 2:06 pm, edited 1 time in total.
Reason: Moved here since the release is "Description: LMDE 2 Betsy"
-jake
"The quality of mercy is not strain'd, It falls as the gentle rain from heaven.” -WS
LMDE 3.11-2-amd64 (#1 SMP Debian 3.11.8-1 (2013-11-13))
Intel(R) Core(TM)2 Duo CPU E8500 @ 3.16GHz, 5918 MiB (6GB)

Pet
Level 1
Level 1
Posts: 1
Joined: Sun May 28, 2017 8:11 pm

Re: LAN Problem, have IP addr but cannot ping 'internet'

Post by Pet » Tue May 30, 2017 2:00 pm

Have a similar issue with Mint 18.1. cinnamon. Get an IP address but can not ping. When I use mii-tool i get no eth0 eth1.
comments: Is part of the PHY driver not loaded correctly in the compilation?

kevinthefixer
Level 4
Level 4
Posts: 277
Joined: Thu Jul 23, 2015 10:36 pm

Re: LAN Problem, have IP addr but cannot ping 'internet'

Post by kevinthefixer » Tue May 30, 2017 10:11 pm

Jakeo25, before you get all balled up in a bunch of hairy diagnostics, try simply rebooting your router and modem, Amazing how often this sort of weirdness gets fixed that way.

Pet, I suggest you take that up on the main forums; this one supports LMDE2.

Post Reply

Return to “Networking”