Installing Firefox ESR to LMDE 2

Write tutorials here
More tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please, Before you post please read this

LMDE 2 support ends on 1-1-2019
Post Reply
User avatar
administrollaattori
Level 15
Level 15
Posts: 5646
Joined: Tue Sep 03, 2013 4:51 am
Location: Finland
Contact:

Installing Firefox ESR to LMDE 2

Post by administrollaattori » Wed Nov 14, 2018 1:44 pm

LMDE 2 support ends in December 2018, but LMDE 2 bases on Debian Jessie, and Jessie's support ends June 2020, so the only problem with LMDE 2 is Firefox, which loses updates after 2018.

The easy fix is to remove Firefox and install Firefox ESR. Via Terminal it goes:

Code: Select all

apt update
apt remove firefox && apt install firefox-esr 
... and if needed some language pack like Finnish

Code: Select all

apt install firefox-esr-l10n-fi

zorzi
Level 2
Level 2
Posts: 68
Joined: Thu Aug 04, 2016 4:26 pm

Re: Installing Firefox ESR to LMDE 2

Post by zorzi » Thu Nov 15, 2018 2:34 pm

Yes, it took some time, but Firefox ESR 60 has arrived (at least...) in Debian Jessie repos.

Mint team had even provided its own Firefow ESR built since a few weeks.

It seems now safer to switch to Debian version, since it will probably get LTS support until 2020.
Desktop: HP Pavilion a6435 (Athlon64 2x 2,6Ghz, Radeon R7-240, Ram 4 Go, HD 500 Go) / MX Linux 17
Laptop: Packard-Bell EasyNote G1320 (Celeron 1,3 Ghz, ATI Mobility Radeon 9100 IGP, Ram 1,2 Go, HD 40 Go) / Debian Stretch

Post Reply

Return to “Tutorials”