LMDE 2 Nvidia Driver Notes (i.e. no choppy video...)

Write tutorials here
More tutorials here http://community.linuxmint.com/tutorial/welcome
Forum rules
Do not start a support topic here please, Before you post please read this
Dr. Octagon
Level 2
Level 2
Posts: 50
Joined: Mon Sep 16, 2013 4:43 pm
Location: Osnabrooklyn

LMDE 2 Nvidia Driver Notes (i.e. no choppy video...)

Postby Dr. Octagon » Tue Dec 15, 2015 3:46 pm

1. If you install the proprietary Nvidia Driver (How To's are out there enough), you have to deinstall the previous nouveau-driver (via synaptic search for xserver-xorg-video-nouveau) afterwards. If you don't do that, you might encounter choppy video playback (streaming videos and online TV in my case). Be aware to reinstall this if you decide to deinstall the proprietary Nvidia driver in the future, because otherwise you won't have a fallback graphic-driver at all!

2. It seems, that LMDE 2 needs (in my case) additional tweaking of the scrolling behavior in Firefox (although I use the smoothwheel extension): Go to about:config and change the layout.frame_rate to 480 (in my case -> I have a 120 hz Screen) and the layout.frame_rate.precise to true.

3. To get a smoth scrolling in Firefox, as like known from your smartphone, where no stutter occurs, just edit these 2 about:config settings to true: layers.offmainthreadcomposition.enabled and layers.offmainthreadcomposition.async-animations


That's all... maybe I find out something more in the future... I will post it!

Does anyone find out similar things you won't find on the internet elsewhere? ;)

My Specs:
LMDE 2 Cinnamon 64 bit
Nvidia 9600 GT
Iceweasel 38.04

Cu
Dr. Octagon
A good stumbler doesn't fall...

Dr. Octagon
Level 2
Level 2
Posts: 50
Joined: Mon Sep 16, 2013 4:43 pm
Location: Osnabrooklyn

Re: LMDE 2 Nvidia Driver Notes (i.e. no choppy video...)

Postby Dr. Octagon » Wed Dec 30, 2015 12:33 pm

Additions:

4. If you want the PC to startup with a special resolution and refresh-rate (in my case 1680x1050 @ 120 hz DVI Port 2) and nvidia won't startup with it (i.e. just in auto mode), I set
nvidia-settings --assign CurrentMetaMode="DVI-I-2: 1680x1050_120 +0+0"
(under startprograms in the menu).

5. You have always to load nvidia-settings at startup, in other cases nvidia won't load all settings right. So I set another entry under startprograms
nvidia-settings --load-config-only
... but with an interrupt of 3 seconds, so that the first "resolution and refresh rate setting" will not interfere with this setting in any way.

Cu
Dr. Octagon
A good stumbler doesn't fall...


Return to “Tutorials”